CVE-2023-2905
Cesanta Mongoose MQTT Message Parsing Heap Overflow
Due to a failure in validating the length of a provided MQTT_CMD_PUBLISH parsed message with a variable length header, Cesanta Mongoose, an embeddable web server, version 7.10 is susceptible to a heap-based buffer overflow vulnerability in the default configuration. Version 7.9 and prior does not appear to be vulnerable. This issue is resolved in version 7.11.
Attack profile
How easy it is to exploit
- Attack vector
- Adjacent network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
Due to a failure in validating the length of a provided MQTT_CMD_PUBLISH parsed message with a variable length header, Cesanta Mongoose, an embeddable web server, version 7.10 is susceptible to a heap-based buffer overflow vulnerability in the default configuration. Version 7.9 and prior does not appear to be vulnerable. This issue is resolved in version 7.11.
- Record
CVE-2023-2905- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-122, CWE-787
- Updated
- 2026-11-02
CVE List No score
Cesanta Mongoose MQTT Message Parsing Heap Overflow
Due to a failure in validating the length of a provided MQTT_CMD_PUBLISH parsed message with a variable length header, Cesanta Mongoose, an embeddable web server, version 7.10 is susceptible to a heap-based buffer overflow vulnerability in the default configuration. Version 7.9 and prior does not appear to be vulnerable. This issue is resolved in version 7.11.
- Record
CVE-2023-2905- Weakness
- CWE-122
- Updated
- 2026-11-02
EUVDEUVD-2023-34351
0.0
Due to a failure in validating the length of a provided MQTT_CMD_PUBLISH parsed message with a variable length header, Cesanta Mongoose, an embeddable web server, version 7.10 is susceptible to a heap-based buffer overflow vulnerability in the default configuration. Version 7.9 and prior does not appear to be vulnerable. This issue is resolved in version 7.11.
- Record
EUVD-2023-34351- CVSS
- 0.0 None
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-pv78-3m65-h826
8.8
Due to a failure in validating the length of a provided MQTT_CMD_PUBLISH parsed message with a...
Due to a failure in validating the length of a provided MQTT_CMD_PUBLISH parsed message with a variable length header, Cesanta Mongoose, an embeddable web server, version 7.10 is susceptible to a heap-based buffer overflow vulnerability in the default configuration. Version 7.9 and prior does not appear to be vulnerable. This issue is resolved in version 7.11.
- Record
GHSA-pv78-3m65-h826- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-122, CWE-787
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-2905
8.8
Due to a failure in validating the length of a provided MQTT_CMD_PUBLISH parsed message with a variable length header, Cesanta Mongoose, an embeddable web server, version 7.10 is susceptible to a heap-based buffer overflow vulnerability in the default configuration. Version 7.9 and prior does not appear to be vulnerable. This issue is resolved in version 7.11.
- Record
DEBIAN-CVE-2023-2905- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-2905
8.8
Due to a failure in validating the length of a provided MQTT_CMD_PUBLISH parsed message with a variable length header, Cesanta Mongoose, an embeddable web server, version 7.10 is susceptible to a heap-based buffer overflow vulnerability in the default configuration. Version 7.9 and prior does not appear to be vulnerable. This issue is resolved in version 7.11.
- Record
UBUNTU-CVE-2023-2905- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV No score
Cesanta Mongoose MQTT Message Parsing Heap Overflow
Due to a failure in validating the length of a provided MQTT_CMD_PUBLISH parsed message with a variable length header, Cesanta Mongoose, an embeddable web server, version 7.10 is susceptible to a heap-based buffer overflow vulnerability in the default configuration. Version 7.9 and prior does not appear to be vulnerable. This issue is resolved in version 7.11.
- Record
CVE-2023-2905- Weakness
- CWE-122
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
swupdateDebian:12 |
All versions, plus listed versions 2022.12+dfsg-42022.12+dfsg-4+deb12u12022.12+dfsg-4+deb12u1~bpo11+12022.12+dfsg-4+deb12u22022.12+dfsg-4+deb12u3 Show 45 moreShow less2023.05+dfsg-12023.05+dfsg-22023.05+dfsg-2~bpo12+12023.05+dfsg-32023.05+dfsg-42023.05+dfsg-52023.05+dfsg-5~bpo12+12023.12+dfsg-12023.12+dfsg-1~bpo12+12023.12.1+dfsg-12023.12.1+dfsg-1~bpo12+12023.12.1+dfsg-22023.12.1+dfsg-2~bpo12+12024.05+dfsg-12024.05.2+dfsg-12024.05.2+dfsg-22024.05.2+dfsg-2~bpo12+12024.12+dfsg-12024.12+dfsg-22024.12+dfsg-2~bpo12+12024.12.1+dfsg-12024.12.1+dfsg-1~bpo12+12024.12.1+dfsg-22024.12.1+dfsg-32024.12.1+dfsg-3~bpo12+12025.05+dfsg-12025.05+dfsg-22025.05+dfsg-2~bpo13+12025.05+dfsg-32025.05+dfsg-3~bpo13+12025.12+dfsg-12025.12+dfsg-102025.12+dfsg-10~bpo13+12025.12+dfsg-10~bpo13+22025.12+dfsg-22025.12+dfsg-2~bpo13+12025.12+dfsg-32025.12+dfsg-42025.12+dfsg-52025.12+dfsg-62025.12+dfsg-72025.12+dfsg-7~bpo13+12025.12+dfsg-82025.12+dfsg-92026.05+dfsg-1 |
None known |
swupdateDebian:13 |
before 2024.12+dfsg-1 | 2024.12+dfsg-1 |
swupdateDebian:14 |
before 2024.12+dfsg-1 | 2024.12+dfsg-1 |
swupdateUbuntu:22.04:LTS |
All versions, plus listed versions 2020.11-22021.04-1.12021.04-22021.04-2build12021.11-1 |
None known |
swupdateUbuntu:24.04:LTS |
All versions, plus listed versions 2023.05+dfsg-32023.05+dfsg-42023.05+dfsg-4build12023.05+dfsg-52023.12+dfsg-12023.12.1+dfsg-1ubuntu12023.12.1+dfsg-1ubuntu42023.12.1+dfsg-1ubuntu5 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, products, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-2905 is a high vulnerability (CVSS 8.8) in Automattic Mongoose, published August 9, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.01%, the 63rd percentile. Fixed in swupdate 2024.12+dfsg-1.
References
takeonme.org/cves/CVE-2023-2905.html
github.com/cesanta/mongoose/pull/2274
github.com/cesanta/mongoose/releases/tag/7.11
nvd.nist.gov/vuln/detail/CVE-2023-2905
github.com/advisories/GHSA-pv78-3m65-h826
github.com/CVEProject/cvelistV5/tree/main/cves/2023/2xxx/CVE-2023-2905.json
security-tracker.debian.org/tracker/CVE-2023-2905
ubuntu.com/security/CVE-2023-2905
cve.org/CVERecord?id=CVE-2023-2905
Left out here: 9 versions. The JSON record has them.