Every CVE Search/ Get API key

CVE-2023-29234

Bypass serialize checks in Apache Dubbo

9.8 CriticalFix available

A deserialization vulnerability existed when decode a malicious package.This issue affects Apache Dubbo: from 3.1.0 through 3.1.10, from 3.2.0 through 3.2.4.

Users are recommended to upgrade to the latest version, which fixes the issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

7.40%Up 7.4 points since Dec 16, 2023
90%50%10%1%

What each source reports

NVD Score used 9.8

A deserialization vulnerability existed when decode a malicious package.This issue affects Apache Dubbo: from 3.1.0 through 3.1.10, from 3.2.0 through 3.2.4.

Users are recommended to upgrade to the latest version, which fixes the issue.

Record
CVE-2023-29234
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
CVE List No score

Bypass serialize checks in Apache Dubbo

A deserialization vulnerability existed when decode a malicious package.This issue affects Apache Dubbo: from 3.1.0 through 3.1.10, from 3.2.0 through 3.2.4.

Users are recommended to upgrade to the latest version, which fixes the issue.

Record
CVE-2023-29234
Weakness
CWE-502
Updated
2026-11-02
EUVDEUVD-2023-3132 No score

A deserialization vulnerability existed when decode a malicious package.This issue affects Apache Dubbo: from 3.1.0 through 3.1.10, from 3.2.0 through 3.2.4.

Users are recommended to upgrade to the latest version, which fixes the issue.

Record
EUVD-2023-3132
Updated
2026-11-03
GitHub AdvisoriesGHSA-6x49-w35h-wqrj 9.8

Bypass serialize checks in Apache Dubbo

A deserialization vulnerability existed when decode a malicious package.This issue affects Apache Dubbo: from 3.1.0 through 3.1.10, from 3.2.0 through 3.2.4.

Users are recommended to upgrade to the latest version, which fixes the issue.

Record
GHSA-6x49-w35h-wqrj
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
OSVGHSA-6x49-w35h-wqrj 9.8

Bypass serialize checks in Apache Dubbo

A deserialization vulnerability existed when decode a malicious package.This issue affects Apache Dubbo: from 3.1.0 through 3.1.10, from 3.2.0 through 3.2.4.

Users are recommended to upgrade to the latest version, which fixes the issue.

Record
GHSA-6x49-w35h-wqrj
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
OSV No score

Bypass serialize checks in Apache Dubbo

A deserialization vulnerability existed when decode a malicious package.This issue affects Apache Dubbo: from 3.1.0 through 3.1.10, from 3.2.0 through 3.2.4.

Users are recommended to upgrade to the latest version, which fixes the issue.

Record
CVE-2023-29234
Weakness
CWE-502
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.dubbo:dubbo
Maven
3.1.0 up to 3.1.11
3.1.11
org.apache.dubbo:dubbo
Maven
3.2.0 up to 3.2.5
3.2.5
org.apache.dubbo:dubbo
Maven
3.1.0 up to 3.1.11, plus listed versions
3.1.13.1.103.1.23.1.33.1.4
Show 5 moreShow less
3.1.53.1.63.1.73.1.83.1.9
3.1.11
org.apache.dubbo:dubbo
Maven
3.2.0 up to 3.2.5, plus listed versions
3.2.13.2.23.2.33.2.4
3.2.5

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-29234 is a critical vulnerability (CVSS 9.8) in Apache Dubbo, published December 15, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 7.40%, the 94th percentile. Fixed in org.apache.dubbo:dubbo 3.1.11.

References

MoveEnter Open