CVE-2023-30253
Dolibarr vulnerable to remote code execution via uppercase manipulation
Dolibarr before 17.0.1 allows remote code execution by an authenticated user via an uppercase manipulation: <?PHP instead of <?php in injected data.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
Dolibarr before 17.0.1 allows remote code execution by an authenticated user via an uppercase manipulation: <?PHP instead of <?php in injected data.
- Record
CVE-2023-30253- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
CVE List
8.8
Dolibarr before 17.0.1 allows remote code execution by an authenticated user via an uppercase manipulation: <?PHP instead of <?php in injected data.
- Record
CVE-2023-30253- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
EUVDEUVD-2023-1519
8.8
Dolibarr before 17.0.1 allows remote code execution by an authenticated user via an uppercase manipulation: <?PHP instead of <?php in injected data.
- Record
EUVD-2023-1519- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9wqr-5jp4-mjmh
8.8
Dolibarr vulnerable to remote code execution via uppercase manipulation
Dolibarr before 17.0.1 allows remote code execution by an authenticated user via an uppercase manipulation: <?PHP instead of <?php in injected data.
- Record
GHSA-9wqr-5jp4-mjmh- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
OSV
8.8
Dolibarr before 17.0.1 allows remote code execution by an authenticated user via an uppercase manipulation: <?PHP instead of <?php in injected data.
- Record
CVE-2023-30253- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-9wqr-5jp4-mjmh
8.8
Dolibarr vulnerable to remote code execution via uppercase manipulation
Dolibarr before 17.0.1 allows remote code execution by an authenticated user via an uppercase manipulation: <?PHP instead of <?php in injected data.
- Record
GHSA-9wqr-5jp4-mjmh- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-30253
8.8
Dolibarr before 17.0.1 allows remote code execution by an authenticated user via an uppercase manipulation: <?PHP instead of <?php in injected data.
- Record
UBUNTU-CVE-2023-30253- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVBIT-dolibarr-2023-30253 No score
Dolibarr before 17.0.1 allows remote code execution by an authenticated user via an uppercase manipulation: <?PHP instead of <?php in injected data.
- Record
BIT-dolibarr-2023-30253- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
dolibarr/dolibarrPackagist |
before 17.0.1 | 17.0.1 |
dolibarrBitnami |
before 17.0.1 | 17.0.1 |
dolibarr/dolibarrPackagist |
before 17.0.1, plus listed versions 10.0.010.0.110.0.210.0.310.0.4 Show 45 moreShow less10.0.510.0.610.0.711.0.011.0.111.0.211.0.311.0.411.0.512.0.012.0.112.0.212.0.312.0.412.0.513.0.013.0.113.0.213.0.313.0.413.0.514.0.014.0.114.0.214.0.314.0.414.0.515.0.015.0.115.0.215.0.33.6.03.6.0-beta3.6.13.6.23.6.33.6.43.6.53.6.63.7.03.7.13.7.23.7.33.7.43.8.0 |
17.0.1 |
dolibarrUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 3.5.5+dfsg1-23.5.7+dfsg1-13.5.8+dfsg1-13.5.8+dfsg1-1ubuntu13.5.8+dfsg1-1ubuntu1+esm1 |
None known |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Metasploit | Dolibarr ERP/CRM Authenticated Code Injection | 2023-05-29 |
| PoC in GitHub | 04Shivam/CVE-2023-30253-Exploit | 2024-05-27 |
| PoC in GitHub | 1lkla/POC-exploit-for-Dolibarr | 2025-12-24 |
| PoC in GitHub | Jeanback1/CVE-2023-30253-exploit | 2026-05-30 |
| PoC in GitHub | Rubikcuv5/cve-2023-30253 | 2024-05-26 |
| PoC in GitHub | andria-dev/DolibabyPhp | 2024-07-10 |
| PoC in GitHub | bluetoothStrawberry/CVE-2023-30253 | 2024-09-20 |
| PoC in GitHub | dollarboysushil/Dolibarr-17.0.0-Exploit-CVE-2023-30253 | 2024-06-24 |
| PoC in GitHub | g4nkd/CVE-2023-30253-PoC | 2024-06-21 |
| PoC in GitHub | nikn0laty/Exploit-for-Dolibarr-17.0.0-CVE-2023-30253 | 2024-05-27 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, Metasploit, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-30253 is a high vulnerability (CVSS 8.8) in Dolibarr Erp\/crm, published May 29, 2023. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 82.1%, the 99th percentile. Fixed in dolibarr/dolibarr 17.0.1.
References
github.com/Dolibarr/dolibarr
swascan.com/blog
swascan.com/security-advisory-dolibarr-17-0-0
nvd.nist.gov/vuln/detail/CVE-2023-30253
github.com/advisories/GHSA-9wqr-5jp4-mjmh
github.com/CVEProject/cvelistV5/tree/main/cves/2023/30xxx/CVE-2023-30253.json
ubuntu.com/security/CVE-2023-30253
cve.org/CVERecord?id=CVE-2023-30253
Left out here: 62 versions. The JSON record has them.