CVE-2023-30260
RaspAP raspap-webgui Command Injection vulnerability
Command injection vulnerability in RaspAP raspap-webgui 2.8.8 and earlier allows remote attackers to run arbitrary commands via crafted POST request to hostapd settings form.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
Command injection vulnerability in RaspAP raspap-webgui 2.8.8 and earlier allows remote attackers to run arbitrary commands via crafted POST request to hostapd settings form.
- Record
CVE-2023-30260- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77
- Updated
- 2026-11-02
CVE List No score
Command injection vulnerability in RaspAP raspap-webgui 2.8.8 and earlier allows remote attackers to run arbitrary commands via crafted POST request to hostapd settings form.
- Record
CVE-2023-30260- Updated
- 2026-11-02
EUVDEUVD-2023-1820 No score
Command injection vulnerability in RaspAP raspap-webgui 2.8.8 and earlier allows remote attackers to run arbitrary commands via crafted POST request to hostapd settings form.
- Record
EUVD-2023-1820- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-hhqm-f4m4-pq39
8.8
RaspAP raspap-webgui Command Injection vulnerability
Command injection vulnerability in RaspAP raspap-webgui 2.8.8 and earlier allows remote attackers to run arbitrary commands via crafted POST request to hostapd settings form.
- Record
GHSA-hhqm-f4m4-pq39- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77
- Updated
- 2026-11-02
OSVGHSA-hhqm-f4m4-pq39
8.8
RaspAP raspap-webgui Command Injection vulnerability
Command injection vulnerability in RaspAP raspap-webgui 2.8.8 and earlier allows remote attackers to run arbitrary commands via crafted POST request to hostapd settings form.
- Record
GHSA-hhqm-f4m4-pq39- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77
- Updated
- 2026-11-02
OSV No score
Command injection vulnerability in RaspAP raspap-webgui 2.8.8 and earlier allows remote attackers to run arbitrary commands via crafted POST request to hostapd settings form.
- Record
CVE-2023-30260- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
billz/raspap-webguiPackagist |
before 2.8.9 | 2.8.9 |
billz/raspap-webguiPackagist |
before 2.8.9, plus listed versions 1.02.4.12.52.5.12.5.2 Show 22 moreShow less2.62.6-beta2.6.12.6.22.6.32.6.42.6.52.6.62.6.72.6.82.6.92.7.02.7.12.8.02.8.12.8.22.8.32.8.42.8.52.8.62.8.72.8.8 |
2.8.9 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-30260 is a high vulnerability (CVSS 8.8) in Raspap, published June 23, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.48%, the 84th percentile. Fixed in billz/raspap-webgui 2.8.9.
References
eldstal.se/advisories/230328-raspap.html
github.com/RaspAP/raspap-webgui/pull/1322
nvd.nist.gov/vuln/detail/CVE-2023-30260
github.com/RaspAP/raspap-webgui/commit/238e1670fcef8b18ec4628ee74fc345607536a16
github.com/advisories/GHSA-hhqm-f4m4-pq39
github.com/CVEProject/cvelistV5/tree/main/cves/2023/30xxx/CVE-2023-30260.json
github.com/RaspAP/raspap-webgui