Every CVE Search/ Get API key

CVE-2023-30362

Buffer Overflow vulnerability in coap_send function in libcoap library 4.3.1-103-g52cfd56 fixed...

7.5 HighFix available

Buffer Overflow vulnerability in coap_send function in libcoap library 4.3.1-103-g52cfd56 fixed in 4.3.1-120-ge242200 allows attackers to obtain sensitive information via malformed pdu.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

0.75%Up 0.7 points since Jun 24, 2023
90%50%10%1%

What each source reports

NVD Score used 7.5

Buffer Overflow vulnerability in coap_send function in libcoap library 4.3.1-103-g52cfd56 fixed in 4.3.1-120-ge242200 allows attackers to obtain sensitive information via malformed pdu.

Record
CVE-2023-30362
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

Buffer Overflow vulnerability in coap_send function in libcoap library 4.3.1-103-g52cfd56 fixed in 4.3.1-120-ge242200 allows attackers to obtain sensitive information via malformed pdu.

Record
CVE-2023-30362
Updated
2026-11-02
EUVDEUVD-2023-34783 No score

Buffer Overflow vulnerability in coap_send function in libcoap library 4.3.1-103-g52cfd56 fixed in 4.3.1-120-ge242200 allows attackers to obtain sensitive information via malformed pdu.

Record
EUVD-2023-34783
Updated
2026-11-03
GitHub AdvisoriesGHSA-v5wr-22jp-335p 7.5

Buffer Overflow vulnerability in coap_send function in libcoap library 4.3.1-103-g52cfd56 fixed...

Buffer Overflow vulnerability in coap_send function in libcoap library 4.3.1-103-g52cfd56 fixed in 4.3.1-120-ge242200 allows attackers to obtain sensitive information via malformed pdu.

Record
GHSA-v5wr-22jp-335p
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-125
Updated
2026-11-02
OSV 7.5

Buffer Overflow vulnerability in coap_send function in libcoap library 4.3.1-103-g52cfd56 fixed in 4.3.1-120-ge242200 allows attackers to obtain sensitive information via malformed pdu.

Record
CVE-2023-30362
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2023-30362 7.5

Buffer Overflow vulnerability in coap_send function in libcoap library 4.3.1-103-g52cfd56 fixed in 4.3.1-120-ge242200 allows attackers to obtain sensitive information via malformed pdu.

Record
DEBIAN-CVE-2023-30362
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVOESA-2023-1701 7.5

dsoftbus security update

Security Fix(es):

Buffer Overflow vulnerability in coap_send function in libcoap library 4.3.1-103-g52cfd56 fixed in 4.3.1-120-ge242200 allows attackers to obtain sensitive information via malformed pdu.(CVE-2023-30362)

Record
OESA-2023-1701
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVOESA-2023-1702 7.5

dsoftbus security update

Security Fix(es):

Buffer Overflow vulnerability in coap_send function in libcoap library 4.3.1-103-g52cfd56 fixed in 4.3.1-120-ge242200 allows attackers to obtain sensitive information via malformed pdu.(CVE-2023-30362)

Record
OESA-2023-1702
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2023-30362 7.5

Buffer Overflow vulnerability in coap_send function in libcoap library 4.3.1-103-g52cfd56 fixed in 4.3.1-120-ge242200 allows attackers to obtain sensitive information via malformed pdu.

Record
UBUNTU-CVE-2023-30362
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libcoap3
Debian:12
All versions, plus listed versions
4.3.1-14.3.1-24.3.3-14.3.4-14.3.4-1.1
Show 5 moreShow less
4.3.4-1.1~exp14.3.5-14.3.5-24.3.5-34.3.5-4
None known
libcoap3
Debian:13
before 4.3.1-2
4.3.1-2
libcoap3
Debian:14
before 4.3.1-2
4.3.1-2
dsoftbus
openEuler:22.03-LTS-SP1
before 1.0.0-5.oe2203sp1
1.0.0-5.oe2203sp1
dsoftbus
openEuler:22.03-LTS-SP2
before 1.0.0-5.oe2203sp2
1.0.0-5.oe2203sp2
libcoap
Ubuntu:18.04:LTS
All versions, plus listed versions
4.1.2-1
None known
libcoap2
Ubuntu:20.04:LTS
All versions, plus listed versions
4.2.0-24.2.1-1
None known
libcoap2
Ubuntu:22.04:LTS
All versions, plus listed versions
4.2.1-14.2.1-1build1
None known
libcoap3
Ubuntu:22.04:LTS
All versions, plus listed versions
4.3.0-24.3.0-2build1
None known
libcoap3
Ubuntu:24.04:LTS
All versions, plus listed versions
4.3.1-24.3.3-14.3.4-14.3.4-1.1build24.3.4-1.1build34.3.4-1.1build4
None known
libcoap3
Ubuntu:25.10
All versions, plus listed versions
4.3.4-1.1build4
None known
libcoap3
Ubuntu:26.10
All versions, plus listed versions
4.3.5-24.3.5-34.3.5-44.3.5-4ubuntu1
None known
libcoap3
Ubuntu:26.04:LTS
All versions, plus listed versions
4.3.4-1.1build44.3.5-14.3.5-2
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-30362 is a high vulnerability (CVSS 7.5) in Libcoap, published June 23, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.75%, the 55th percentile. Fixed in libcoap3 4.3.1-2.

References

MoveEnter Open