CVE-2023-31669
WebAssembly wat2wasm v1.0.32 allows attackers to cause a libc++abi.dylib crash by putting '@'...
WebAssembly wat2wasm v1.0.32 allows attackers to cause a libc++abi.dylib crash by putting '@' before a quote (").
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
WebAssembly wat2wasm v1.0.32 allows attackers to cause a libc++abi.dylib crash by putting '@' before a quote (").
- Record
CVE-2023-31669- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-116
- Updated
- 2026-11-02
CVE List
5.5
WebAssembly wat2wasm v1.0.32 allows attackers to cause a libc++abi.dylib crash by putting '@' before a quote (").
- Record
CVE-2023-31669- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-116
- Updated
- 2026-11-02
EUVDEUVD-2023-35964
5.5
WebAssembly wat2wasm v1.0.32 allows attackers to cause a libc++abi.dylib crash by putting '@' before a quote (").
- Record
EUVD-2023-35964- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-24pv-x5f7-pv4r
5.5
WebAssembly wat2wasm v1.0.32 allows attackers to cause a libc++abi.dylib crash by putting '@'...
WebAssembly wat2wasm v1.0.32 allows attackers to cause a libc++abi.dylib crash by putting '@' before a quote (").
- Record
GHSA-24pv-x5f7-pv4r- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-116
- Updated
- 2026-11-02
OSV
5.5
WebAssembly wat2wasm v1.0.32 allows attackers to cause a libc++abi.dylib crash by putting '@' before a quote (").
- Record
CVE-2023-31669- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-31669
5.5
WebAssembly wat2wasm v1.0.32 allows attackers to cause a libc++abi.dylib crash by putting '@' before a quote (").
- Record
DEBIAN-CVE-2023-31669- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-31669
5.5
WebAssembly wat2wasm v1.0.32 allows attackers to cause a libc++abi.dylib crash by putting '@' before a quote (").
- Record
UBUNTU-CVE-2023-31669- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wabtDebian:12 |
All versions, plus listed versions 1.0.32-11.0.33-11.0.34+dsfg+~cs1.0.32-11.0.34+dsfg2+~cs1.0.32-11.0.34+dsfg2+~cs1.0.32-2 Show 9 moreShow less1.0.34+dsfg2+~cs1.0.32-31.0.34+dsfg2+~cs1.0.32-41.0.34-11.0.36+dfsg+~cs1.0.36-11.0.36+dfsg+~cs1.0.36-21.0.41+dfsg+~cs1.0.39-11.0.41+dfsg+~cs1.0.39-21.0.42+dfsg+~cs1.0.39-11.0.42+dfsg+~cs1.0.39-2 |
None known |
wabtDebian:13 |
before 1.0.33-1 | 1.0.33-1 |
wabtDebian:14 |
before 1.0.33-1 | 1.0.33-1 |
wabtUbuntu:20.04:LTS |
All versions, plus listed versions 1.0.11-11.0.12-11.0.13-11.0.13-1build1 |
None known |
wabtUbuntu:22.04:LTS |
All versions, plus listed versions 1.0.20-11.0.24-11.0.24-21.0.25-11.0.26-11.0.27-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-31669 is a medium vulnerability (CVSS 5.5) in Webassembly Binary Toolkit, published May 23, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.28%, the 21st percentile. Fixed in wabt 1.0.33-1.
References
github.com/WebAssembly/wabt/issues/2165
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/OSFFCKXUQ5PAC5UVXY7N6HEHVQ3AC2RG
nvd.nist.gov/vuln/detail/CVE-2023-31669
lists.fedoraproject.org/archives/list/[email protected]/message/OSFFCKXUQ5PAC5UVXY7N6HEHVQ3AC2RG
github.com/advisories/GHSA-24pv-x5f7-pv4r
github.com/CVEProject/cvelistV5/tree/main/cves/2023/31xxx/CVE-2023-31669.json
security-tracker.debian.org/tracker/CVE-2023-31669
ubuntu.com/security/CVE-2023-31669
cve.org/CVERecord?id=CVE-2023-31669