CVE-2023-32184
A Insecure Storage of Sensitive Information vulnerability in openSUSE opensuse-welcome allows...
A Insecure Storage of Sensitive Information vulnerability in openSUSE opensuse-welcome allows local attackers to execute code as the user that runs opensuse-welcome if a custom layout is chosen This issue affects opensuse-welcome: from 0.1 before 0.1.9+git.35.4b9444a.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.8
A Insecure Storage of Sensitive Information vulnerability in openSUSE opensuse-welcome allows local attackers to execute code as the user that runs opensuse-welcome if a custom layout is chosen This issue affects opensuse-welcome: from 0.1 before 0.1.9+git.35.4b9444a.
- Record
CVE-2023-32184- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-922
- Updated
- 2026-11-02
EUVDEUVD-2023-36452
7.8
A Insecure Storage of Sensitive Information vulnerability in openSUSE opensuse-welcome allows local attackers to execute code as the user that runs opensuse-welcome if a custom layout is chosen This issue affects opensuse-welcome: from 0.1 before 0.1.9+git.35.4b9444a.
- Record
EUVD-2023-36452- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6cr9-4pv5-j99r
7.8
A Insecure Storage of Sensitive Information vulnerability in openSUSE opensuse-welcome allows...
A Insecure Storage of Sensitive Information vulnerability in openSUSE opensuse-welcome allows local attackers to execute code as the user that runs opensuse-welcome if a custom layout is chosen This issue affects opensuse-welcome: from 0.1 before 0.1.9+git.35.4b9444a.
- Record
GHSA-6cr9-4pv5-j99r- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-922
- Updated
- 2026-11-02
NVD
7.8
A Insecure Storage of Sensitive Information vulnerability in openSUSE opensuse-welcome allows local attackers to execute code as the user that runs opensuse-welcome if a custom layout is chosen This issue affects opensuse-welcome: from 0.1 before 0.1.9+git.35.4b9444a.
- Record
CVE-2023-32184- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-922
- Updated
- 2026-11-02
OSVopenSUSE-SU-2023:0219-1 No score
Security update for opensuse-welcome
This update for opensuse-welcome fixes the following issues:
Update to version 0.1.9+git.35.4b9444a:
- CVE-2023-32184: panellayouter: use QTemporaryFile for applyLayout() (boo#1213708).
- Translation updates.
- Record
openSUSE-SU-2023:0219-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2023:0230-1 No score
Security update for opensuse-welcome
This update for opensuse-welcome fixes the following issues:
- CVE-2023-32184: Fixed possible security issues when using the feature to change the Xfce desktop layout, caused by a fixed temporary file path used in /tmp/layout (boo#1213708)
- Record
openSUSE-SU-2023:0230-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:13126-1 No score
opensuse-welcome-0.1.9+git.35.4b9444a-1.1 on GA media
These are all security issues fixed in the opensuse-welcome-0.1.9+git.35.4b9444a-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:13126-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
opensuse-welcomeSUSE:Package Hub 15 SP5 |
before 0.1.9+git.35.4b9444a-bp155.2.3.1 | 0.1.9+git.35.4b9444a-bp155.2.3.1 |
opensuse-welcomeopenSUSE:Leap 15.5 |
before 0.1.9+git.35.4b9444a-bp155.2.3.1 | 0.1.9+git.35.4b9444a-bp155.2.3.1 |
opensuse-welcomeSUSE:Package Hub 15 SP4 |
before 0.1.9+git.0.66be0d8-bp154.2.6.1 | 0.1.9+git.0.66be0d8-bp154.2.6.1 |
opensuse-welcomeopenSUSE:Leap 15.4 |
before 0.1.9+git.0.66be0d8-bp154.2.6.1 | 0.1.9+git.0.66be0d8-bp154.2.6.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-32184 is a high vulnerability (CVSS 7.8) in Opensuse Opensuse-welcome, published August 14, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.31%, the 23rd percentile. Fixed in opensuse-welcome 0.1.9+git.35.4b9444a-bp155.2.3.1.
References
bugzilla.suse.com/show_bug.cgi?id=CVE-2023-32184
nvd.nist.gov/vuln/detail/CVE-2023-32184
github.com/advisories/GHSA-6cr9-4pv5-j99r
lists.opensuse.org/archives/list/[email protected]/thread/HSVERGEID7EOMQUUGEUFM6IS7QB7YYU3
bugzilla.suse.com/1213708
suse.com/security/cve/CVE-2023-32184
lists.opensuse.org/archives/list/[email protected]/thread/T452K3EYBY4FDSUL3JTDOFR56ND5D5OV