CVE-2023-32310
DataEase API interface has IDOR vulnerability
DataEase is an open source data visualization and analysis tool. The API interface for DataEase delete dashboard and delete system messages is vulnerable to insecure direct object references (IDOR). This could result in a user deleting another user's dashboard or messages or interfering with the interface for marking messages read. The vulnerability has been fixed in v1.18.7. There are no known workarounds aside from upgrading.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.1
DataEase API interface has IDOR vulnerability
DataEase is an open source data visualization and analysis tool. The API interface for DataEase delete dashboard and delete system messages is vulnerable to insecure direct object references (IDOR). This could result in a user deleting another user's dashboard or messages or interfering with the interface for marking messages read. The vulnerability has been fixed in v1.18.7. There are no known workarounds aside from upgrading.
- Record
CVE-2023-32310- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H - Weakness
- CWE-639
- Updated
- 2026-11-02
EUVDEUVD-2023-1734
8.1
DataEase is an open source data visualization and analysis tool. The API interface for DataEase delete dashboard and delete system messages is vulnerable to insecure direct object references (IDOR). This could result in a user deleting another user's dashboard or messages or interfering with the interface for marking messages read. The vulnerability has been fixed in v1.18.7. There are no known workarounds aside from upgrading.
- Record
EUVD-2023-1734- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-7hv6-gv38-78wj
8.1
DataEase API interface has IDOR vulnerability
Impact
The api interface for DataEase delete dashboard and delete system messages is vulnerable to IDOR.
The interface to delete the dashboard:
- Create two users: user1 and user2
- User1 creates a dashboard named pan1
- User2 creates a dashboard named pan2
- Both user1 and user2 share their dashboards with the demo user
- User1 wants to delete his dashboard. We hijack the request with burpsuite. The request will probably look like this: POST /api/share/removePanelShares/440efa7f-efd8-11ed-bec7-1144724bc08c HTTP/1.1. 440efa7f-efd8-11ed-bec7-1144724bc08c is the ID of pan1
- We replace this ID with the ID of pan2 and continue the execution (i.e. we delete the shares of others)
- Successfully remove the shared link
The interface to delete system messages:
- Our request to delete a message is shown below
- We can delete all messages by simply enumerating the message ID, regardless of whether the message belongs to the requester or not.
- The interface for marking read messages is also affected
Affected versions: <= 1.18.6
Patches
The vulnerability has been fixed in v1.18.7.
Workarounds
It is recommended to upgrade the version to v1.18.7.
References
If you have any questions or comments about this advisory:
Open an issue in https://github.com/dataease/dataease Email us at [email protected]
- Record
GHSA-7hv6-gv38-78wj- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H - Weakness
- CWE-639
- Updated
- 2026-11-02
NVD
8.1
DataEase is an open source data visualization and analysis tool. The API interface for DataEase delete dashboard and delete system messages is vulnerable to insecure direct object references (IDOR). This could result in a user deleting another user's dashboard or messages or interfering with the interface for marking messages read. The vulnerability has been fixed in v1.18.7. There are no known workarounds aside from upgrading.
- Record
CVE-2023-32310- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H - Weakness
- CWE-639
- Updated
- 2026-11-02
OSV
8.1
DataEase API interface has IDOR vulnerability
DataEase is an open source data visualization and analysis tool. The API interface for DataEase delete dashboard and delete system messages is vulnerable to insecure direct object references (IDOR). This could result in a user deleting another user's dashboard or messages or interfering with the interface for marking messages read. The vulnerability has been fixed in v1.18.7. There are no known workarounds aside from upgrading.
- Record
CVE-2023-32310- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H - Weakness
- CWE-639
- Updated
- 2026-11-02
OSVGHSA-7hv6-gv38-78wj
8.1
DataEase API interface has IDOR vulnerability
Impact
The api interface for DataEase delete dashboard and delete system messages is vulnerable to IDOR.
The interface to delete the dashboard:
- Create two users: user1 and user2
- User1 creates a dashboard named pan1
- User2 creates a dashboard named pan2
- Both user1 and user2 share their dashboards with the demo user
- User1 wants to delete his dashboard. We hijack the request with burpsuite. The request will probably look like this: POST /api/share/removePanelShares/440efa7f-efd8-11ed-bec7-1144724bc08c HTTP/1.1. 440efa7f-efd8-11ed-bec7-1144724bc08c is the ID of pan1
- We replace this ID with the ID of pan2 and continue the execution (i.e. we delete the shares of others)
- Successfully remove the shared link
The interface to delete system messages:
- Our request to delete a message is shown below
- We can delete all messages by simply enumerating the message ID, regardless of whether the message belongs to the requester or not.
- The interface for marking read messages is also affected
Affected versions: <= 1.18.6
Patches
The vulnerability has been fixed in v1.18.7.
Workarounds
It is recommended to upgrade the version to v1.18.7.
References
If you have any questions or comments about this advisory:
Open an issue in https://github.com/dataease/dataease Email us at [email protected]
- Record
GHSA-7hv6-gv38-78wj- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H - Weakness
- CWE-639
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
io.dataease:dataease-plugin-commonMaven |
through 1.18.6 | 1.18.7 |
io.dataease:dataease-plugin-commonMaven |
before 1.18.7, plus listed versions 1.01.11.10.01.11.01.11.1 Show 22 moreShow less1.11.31.12.01.13.01.14.01.15.01.16.01.17.01.18.01.18.11.18.21.18.31.18.41.18.51.18.61.21.31.41.51.61.71.8.01.9.0 |
1.18.7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-32310 is a high vulnerability (CVSS 8.1) in Dataease, published June 1, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.01%, the 63rd percentile. Fixed in io.dataease:dataease-plugin-common 1.18.7.
References
github.com/dataease/dataease/security/advisories/GHSA-7hv6-gv38-78wj
github.com/dataease/dataease/pull/5342
github.com/dataease/dataease/commit/72f428e87b5395c03d2f94ef6185fc247ddbc8dc
github.com/dataease/dataease/releases/tag/v1.18.7
nvd.nist.gov/vuln/detail/CVE-2023-32310
github.com/advisories/GHSA-7hv6-gv38-78wj
github.com/CVEProject/cvelistV5/tree/main/cves/2023/32xxx/CVE-2023-32310.json
github.com/dataease/dataease