Every CVE Search/ Get API key

CVE-2023-32726

Possible buffer overread from reading DNS responses

3.9 LowFix available

The vulnerability is caused by improper check for check if RDLENGTH does not overflow the buffer in response from DNS server.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
High
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

0.67%Up 0.6 points since Dec 19, 2023
90%50%10%1%

What each source reports

CVE List Score used 3.9

Possible buffer overread from reading DNS responses

The vulnerability is caused by improper check for check if RDLENGTH does not overflow the buffer in response from DNS server.

Record
CVE-2023-32726
CVSS 3.1
3.9 LowCVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:L
Weakness
CWE-754
Updated
2026-11-02
EUVDEUVD-2023-36953 3.9

The vulnerability is caused by improper check for check if RDLENGTH does not overflow the buffer in response from DNS server.

Record
EUVD-2023-36953
CVSS 3.1
3.9 LowCVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-fqr7-2x83-wf2r 8.1

The vulnerability is caused by improper check for check if RDLENGTH does not overflow the buffer...

The vulnerability is caused by improper check for check if RDLENGTH does not overflow the buffer in response from DNS server.

Record
GHSA-fqr7-2x83-wf2r
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-754
Updated
2026-11-02
NVD 3.9

The vulnerability is caused by improper check for check if RDLENGTH does not overflow the buffer in response from DNS server.

Record
CVE-2023-32726
CVSS 3.1
3.9 LowCVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:L
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-754
Updated
2026-11-02
OSV 8.1

The vulnerability is caused by improper check for check if RDLENGTH does not overflow the buffer in response from DNS server.

Record
CVE-2023-32726
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2023-32726 8.1

The vulnerability is caused by improper check for check if RDLENGTH does not overflow the buffer in response from DNS server.

Record
DEBIAN-CVE-2023-32726
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2023-32726 3.9

The vulnerability is caused by improper check for check if RDLENGTH does not overflow the buffer in response from DNS server.

Record
UBUNTU-CVE-2023-32726
CVSS 3.1
3.9 LowCVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:L
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
zabbix
Debian:12
All versions, plus listed versions
1:6.0.14+dfsg-11:6.0.23+dfsg-11:6.0.23+dfsg-1~bpo12+11:6.0.24+dfsg-11:6.0.25+dfsg-1
Show 24 moreShow less
1:6.0.29+dfsg-11:7.0.0+dfsg-11:7.0.0+dfsg-21:7.0.0+dfsg-2~bpo12+11:7.0.1+dfsg-11:7.0.1+dfsg-1~bpo12+11:7.0.10+dfsg-11:7.0.10+dfsg-21:7.0.2+dfsg-11:7.0.2+dfsg-1~bpo12+11:7.0.22+dfsg-11:7.0.22+dfsg-1.11:7.0.22+dfsg-1~bpo13+11:7.0.22+dfsg-1~deb13u11:7.0.27+dfsg-11:7.0.29+dfsg-11:7.0.29+dfsg-21:7.0.29+dfsg-2~bpo13+11:7.0.3+dfsg-11:7.0.5+dfsg-11:7.0.5+dfsg-1~bpo12+11:7.0.6+dfsg-11:7.0.9+dfsg-11:7.0.9+dfsg-1~bpo12+1
None known
zabbix
Debian:13
before 1:6.0.24+dfsg-1
1:6.0.24+dfsg-1
zabbix
Debian:14
before 1:6.0.24+dfsg-1
1:6.0.24+dfsg-1
zabbix
Debian:10
From an advisory covering 3 CVEs
before 1:4.0.4+dfsg-1+deb10u4, plus listed versions
1:4.0.4+dfsg-11:4.0.4+dfsg-1+deb10u11:4.0.4+dfsg-1+deb10u21:4.0.4+dfsg-1+deb10u3
1:4.0.4+dfsg-1+deb10u4
zabbix
Debian:11
From an advisory covering 31 CVEs
before 1:5.0.44+dfsg-1+deb11u1, plus listed versions
1:5.0.14+dfsg-11:5.0.14+dfsg-1~bpo11+11:5.0.17+dfsg-11:5.0.17+dfsg-1~bpo11+11:5.0.8+dfsg-1
1:5.0.44+dfsg-1+deb11u1
zabbix
Ubuntu:Pro:22.04:LTS
All versions, plus listed versions
1:5.0.8+dfsg-1build11:5.0.14+dfsg-11:5.0.17+dfsg-11:5.0.17+dfsg-1ubuntu0.1~esm1
None known

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-32726 is a low vulnerability (CVSS 3.9) in Zabbix, published December 18, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.67%, the 52nd percentile. Fixed in zabbix 1:6.0.24+dfsg-1.

References

Show 4 moreShow less
MoveEnter Open