CVE-2023-32727
Code execution vulnerability in icmpping
An attacker who has the privilege to configure Zabbix items can use function icmpping() with additional malicious command inside it to execute arbitrary code on the current Zabbix server.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
6.8
Code execution vulnerability in icmpping
An attacker who has the privilege to configure Zabbix items can use function icmpping() with additional malicious command inside it to execute arbitrary code on the current Zabbix server.
- Record
CVE-2023-32727- CVSS 3.1
- 6.8 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
EUVDEUVD-2023-36954
6.8
An attacker who has the privilege to configure Zabbix items can use function icmpping() with additional malicious command inside it to execute arbitrary code on the current Zabbix server.
- Record
EUVD-2023-36954- CVSS 3.1
- 6.8 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-8h32-vcmm-pcx8
7.2
An attacker who has the privilege to configure Zabbix items can use function icmpping() with...
An attacker who has the privilege to configure Zabbix items can use function icmpping() with additional malicious command inside it to execute arbitrary code on the current Zabbix server.
- Record
GHSA-8h32-vcmm-pcx8- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
NVD
6.8
An attacker who has the privilege to configure Zabbix items can use function icmpping() with additional malicious command inside it to execute arbitrary code on the current Zabbix server.
- Record
CVE-2023-32727- CVSS 3.1
- 6.8 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H - CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
7.2
An attacker who has the privilege to configure Zabbix items can use function icmpping() with additional malicious command inside it to execute arbitrary code on the current Zabbix server.
- Record
CVE-2023-32727- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-32727
7.2
An attacker who has the privilege to configure Zabbix items can use function icmpping() with additional malicious command inside it to execute arbitrary code on the current Zabbix server.
- Record
DEBIAN-CVE-2023-32727- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2023-32727
6.8
An attacker who has the privilege to configure Zabbix items can use function icmpping() with additional malicious command inside it to execute arbitrary code on the current Zabbix server.
- Record
UBUNTU-CVE-2023-32727- CVSS 3.1
- 6.8 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H - CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2023:0418-1 No score
Security update for zabbix
This update for zabbix fixes the following issues:
Updated to latest release 4.0.50:
- CVE-2023-32727: Fixed potential arbitrary code execution in icmpping (boo#1218199)
- Record
openSUSE-SU-2023:0418-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2023:0419-1 No score
Security update for zabbix
This update for zabbix fixes the following issues:
Updated to latest release 4.0.50:
- CVE-2023-32727: Fixed potential arbitrary code execution in icmpping (boo#1218199)
- Record
openSUSE-SU-2023:0419-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:13535-1 No score
zabbix-agent-6.0.25-1.1 on GA media
These are all security issues fixed in the zabbix-agent-6.0.25-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:13535-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
zabbixDebian:12 |
All versions, plus listed versions 1:6.0.14+dfsg-11:6.0.23+dfsg-11:6.0.23+dfsg-1~bpo12+11:6.0.24+dfsg-11:6.0.25+dfsg-1 Show 24 moreShow less1:6.0.29+dfsg-11:7.0.0+dfsg-11:7.0.0+dfsg-21:7.0.0+dfsg-2~bpo12+11:7.0.1+dfsg-11:7.0.1+dfsg-1~bpo12+11:7.0.10+dfsg-11:7.0.10+dfsg-21:7.0.2+dfsg-11:7.0.2+dfsg-1~bpo12+11:7.0.22+dfsg-11:7.0.22+dfsg-1.11:7.0.22+dfsg-1~bpo13+11:7.0.22+dfsg-1~deb13u11:7.0.27+dfsg-11:7.0.29+dfsg-11:7.0.29+dfsg-21:7.0.29+dfsg-2~bpo13+11:7.0.3+dfsg-11:7.0.5+dfsg-11:7.0.5+dfsg-1~bpo12+11:7.0.6+dfsg-11:7.0.9+dfsg-11:7.0.9+dfsg-1~bpo12+1 |
None known |
zabbixDebian:13 |
before 1:6.0.23+dfsg-1 | 1:6.0.23+dfsg-1 |
zabbixDebian:14 |
before 1:6.0.23+dfsg-1 | 1:6.0.23+dfsg-1 |
zabbixDebian:11 From an advisory covering 31 CVEs |
before 1:5.0.44+dfsg-1+deb11u1, plus listed versions 1:5.0.14+dfsg-11:5.0.14+dfsg-1~bpo11+11:5.0.17+dfsg-11:5.0.17+dfsg-1~bpo11+11:5.0.8+dfsg-1 |
1:5.0.44+dfsg-1+deb11u1 |
zabbixUbuntu:Pro:20.04:LTS |
All versions, plus listed versions 1:4.0.4+dfsg-1build21:4.0.4+dfsg-1build31:4.0.11+dfsg-11:4.0.14+dfsg-11:4.0.15+dfsg-1 Show 5 moreShow less1:4.0.16+dfsg-11:4.0.16+dfsg-1build11:4.0.17+dfsg-11:4.0.17+dfsg-1ubuntu0.1~esm11:4.0.17+dfsg-1ubuntu0.1~esm2 |
None known |
zabbixUbuntu:Pro:22.04:LTS |
All versions, plus listed versions 1:5.0.8+dfsg-1build11:5.0.14+dfsg-11:5.0.17+dfsg-11:5.0.17+dfsg-1ubuntu0.1~esm1 |
None known |
zabbixSUSE:Package Hub 15 SP5 |
before 4.0.50-bp155.3.9.1 | 4.0.50-bp155.3.9.1 |
zabbixopenSUSE:Leap 15.5 |
before 4.0.50-bp155.3.9.1 | 4.0.50-bp155.3.9.1 |
zabbixSUSE:Package Hub 15 SP4 |
before 4.0.50-bp154.2.9.1 | 4.0.50-bp154.2.9.1 |
zabbixopenSUSE:Leap 15.4 |
before 4.0.50-bp154.2.9.1 | 4.0.50-bp154.2.9.1 |
zabbixopenSUSE:Tumbleweed |
before 6.0.25-1.1 | 6.0.25-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-32727 is a medium vulnerability (CVSS 6.8) in Zabbix, published December 18, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.87%, the 59th percentile. Fixed in zabbix 1:6.0.23+dfsg-1.