CVE-2023-33189
Incorrect Authorization with specially crafted requests
Pomerium is an identity and context-aware access proxy. With specially crafted requests, incorrect authorization decisions may be made by Pomerium. This issue has been patched in versions 0.17.4, 0.18.1, 0.19.2, 0.20.1, 0.21.4 and 0.22.2.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
10.0
Incorrect Authorization with specially crafted requests
Pomerium is an identity and context-aware access proxy. With specially crafted requests, incorrect authorization decisions may be made by Pomerium. This issue has been patched in versions 0.17.4, 0.18.1, 0.19.2, 0.20.1, 0.21.4 and 0.22.2.
- Record
CVE-2023-33189- CVSS 3.1
- 10.0 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
EUVDEUVD-2023-1604
10.0
Pomerium is an identity and context-aware access proxy. With specially crafted requests, incorrect authorization decisions may be made by Pomerium. This issue has been patched in versions 0.17.4, 0.18.1, 0.19.2, 0.20.1, 0.21.4 and 0.22.2.
- Record
EUVD-2023-1604- CVSS 3.1
- 10.0 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-pvrc-wvj2-f59p
10.0
Pomerium vulnerable to Incorrect Authorization with specially crafted requests
Impact
With specially crafted requests, incorrect authorization decisions may be made by Pomerium.
Patches
We are releasing patch fixes to address this vulnerability going back to v0.17.X. Please upgrade to:
- v0.22.2
- v0.21.4
- v0.20.1
- v0.19.2
- v0.18.1
- v0.17.4
For more information
If you have any questions or comments about this advisory:
- Open an issue in pomerium/pomerium
- Email us at [email protected]
- Record
GHSA-pvrc-wvj2-f59p- CVSS 3.1
- 10.0 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
NVD
10.0
Pomerium is an identity and context-aware access proxy. With specially crafted requests, incorrect authorization decisions may be made by Pomerium. This issue has been patched in versions 0.17.4, 0.18.1, 0.19.2, 0.20.1, 0.21.4 and 0.22.2.
- Record
CVE-2023-33189- CVSS 3.1
- 10.0 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-285
- Updated
- 2026-11-02
OSV
10.0
Incorrect Authorization with specially crafted requests
Pomerium is an identity and context-aware access proxy. With specially crafted requests, incorrect authorization decisions may be made by Pomerium. This issue has been patched in versions 0.17.4, 0.18.1, 0.19.2, 0.20.1, 0.21.4 and 0.22.2.
- Record
CVE-2023-33189- CVSS 3.1
- 10.0 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
OSVGHSA-pvrc-wvj2-f59p
10.0
Pomerium vulnerable to Incorrect Authorization with specially crafted requests
Impact
With specially crafted requests, incorrect authorization decisions may be made by Pomerium.
Patches
We are releasing patch fixes to address this vulnerability going back to v0.17.X. Please upgrade to:
- v0.22.2
- v0.21.4
- v0.20.1
- v0.19.2
- v0.18.1
- v0.17.4
For more information
If you have any questions or comments about this advisory:
- Open an issue in pomerium/pomerium
- Email us at [email protected]
- Record
GHSA-pvrc-wvj2-f59p- CVSS 3.1
- 10.0 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
OSVGO-2023-1800 No score
Pomerium vulnerable to Incorrect Authorization with specially crafted requests in github.com/pomerium/pomerium
Pomerium vulnerable to Incorrect Authorization with specially crafted requests in github.com/pomerium/pomerium
- Record
GO-2023-1800- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/pomerium/pomeriumGo |
0.22.0 up to 0.22.2 | 0.22.2 |
github.com/pomerium/pomeriumGo |
0.21.0 up to 0.21.4 | 0.21.4 |
github.com/pomerium/pomeriumGo |
0.20.0 up to 0.20.1 | 0.20.1 |
github.com/pomerium/pomeriumGo |
0.19.0 up to 0.19.2 | 0.19.2 |
github.com/pomerium/pomeriumGo |
0.18.0 up to 0.18.1 | 0.18.1 |
github.com/pomerium/pomeriumGo |
before 0.17.4 | 0.17.4 |
github.com/pomerium/pomeriumGo |
before 0.17.4, 0.18.0 up to 0.18.1, 0.19.0 up to 0.19.2, 0.20.0 up to 0.20.1, 0.21.0 up to 0.21.4, 0.22.0 up to 0.22.2 | 0.17.40.18.10.19.20.20.10.21.40.22.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-33189 is a critical vulnerability (CVSS 10.0) in Pomerium, published May 26, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.92%, the 60th percentile. Fixed in github.com/pomerium/pomerium 0.22.2.
References
github.com/pomerium/pomerium/security/advisories/GHSA-pvrc-wvj2-f59p
github.com/pomerium/pomerium/commit/d315e683357a9b587ba9ef399a8813bcc52fdebb
github.com/pomerium/pomerium/releases/tag/v0.17.4
github.com/pomerium/pomerium/releases/tag/v0.18.1
github.com/pomerium/pomerium/releases/tag/v0.19.2
github.com/pomerium/pomerium/releases/tag/v0.20.1