CVE-2023-33191
kyverno seccomp control can be circumvented
Kyverno is a policy engine designed for Kubernetes. Kyverno seccomp control can be circumvented. Users of the podSecurity validate.podSecurity subrule in Kyverno 1.9.2 and 1.9.3 are vulnerable. This issue was patched in version 1.9.4.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
4.6
kyverno seccomp control can be circumvented
Kyverno is a policy engine designed for Kubernetes. Kyverno seccomp control can be circumvented. Users of the podSecurity validate.podSecurity subrule in Kyverno 1.9.2 and 1.9.3 are vulnerable. This issue was patched in version 1.9.4.
- Record
CVE-2023-33191- CVSS 3.1
- 4.6 Medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L - Weakness
- CWE-284
- Updated
- 2026-11-02
EUVDEUVD-2023-1454
4.6
Kyverno is a policy engine designed for Kubernetes. Kyverno seccomp control can be circumvented. Users of the podSecurity validate.podSecurity subrule in Kyverno 1.9.2 and 1.9.3 are vulnerable. This issue was patched in version 1.9.4.
- Record
EUVD-2023-1454- CVSS 3.1
- 4.6 Medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-33hq-f2mf-jm3c
4.6
kyverno seccomp control can be circumvented
Impact
Users of the podSecurity (validate.podSecurity) subrule in Kyverno versions v1.9.2 and v1.9.3 may be unable to enforce the check for the Seccomp control at the baseline level when using a version value of latest. There is no effect if a version number is referenced instead. See the documentation for information on this subrule type. Users of Kyverno v1.9.2 and v1.9.3 are affected.
Patches
v1.9.4 v1.10.0
Workarounds
To work around this issue without upgrading to v1.9.4, temporarily install individual policies for the respective Seccomp checks in baseline here and restricted here.
References
- Record
GHSA-33hq-f2mf-jm3c- CVSS 3.1
- 4.6 Medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L - Weakness
- CWE-284
- Updated
- 2026-11-02
NVD
4.6
Kyverno is a policy engine designed for Kubernetes. Kyverno seccomp control can be circumvented. Users of the podSecurity validate.podSecurity subrule in Kyverno 1.9.2 and 1.9.3 are vulnerable. This issue was patched in version 1.9.4.
- Record
CVE-2023-33191- CVSS 3.1
- 4.6 Medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L - CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-284
- Updated
- 2026-11-02
OSV
4.6
kyverno seccomp control can be circumvented
Kyverno is a policy engine designed for Kubernetes. Kyverno seccomp control can be circumvented. Users of the podSecurity validate.podSecurity subrule in Kyverno 1.9.2 and 1.9.3 are vulnerable. This issue was patched in version 1.9.4.
- Record
CVE-2023-33191- CVSS 3.1
- 4.6 Medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L - Weakness
- CWE-284
- Updated
- 2026-11-02
OSVGHSA-33hq-f2mf-jm3c
4.6
kyverno seccomp control can be circumvented
Impact
Users of the podSecurity (validate.podSecurity) subrule in Kyverno versions v1.9.2 and v1.9.3 may be unable to enforce the check for the Seccomp control at the baseline level when using a version value of latest. There is no effect if a version number is referenced instead. See the documentation for information on this subrule type. Users of Kyverno v1.9.2 and v1.9.3 are affected.
Patches
v1.9.4 v1.10.0
Workarounds
To work around this issue without upgrading to v1.9.4, temporarily install individual policies for the respective Seccomp checks in baseline here and restricted here.
References
- Record
GHSA-33hq-f2mf-jm3c- CVSS 3.1
- 4.6 Medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L - Weakness
- CWE-284
- Updated
- 2026-11-02
OSVGO-2023-1801 No score
kyverno seccomp control can be circumvented in github.com/kyverno/kyverno
kyverno seccomp control can be circumvented in github.com/kyverno/kyverno
- Record
GO-2023-1801- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/kyverno/kyvernoGo |
1.9.2 up to 1.9.4 | 1.9.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-33191 is a medium vulnerability (CVSS 4.6) in Kyverno, published May 25, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.48%, the 42nd percentile. Fixed in github.com/kyverno/kyverno 1.9.4.
References
github.com/kyverno/kyverno/security/advisories/GHSA-33hq-f2mf-jm3c
github.com/kyverno/kyverno/pull/7263
github.com/kyverno/kyverno/releases/tag/v1.9.4
nvd.nist.gov/vuln/detail/CVE-2023-33191
github.com/advisories/GHSA-33hq-f2mf-jm3c
github.com/CVEProject/cvelistV5/tree/main/cves/2023/33xxx/CVE-2023-33191.json
github.com/kyverno/kyverno