CVE-2023-34089
Decidim Cross-site Scripting vulnerability in the processes filter
CVE-2023-34089 is a high vulnerability (CVSS 8.1) in Decidim, published July 11, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.74%, the 54th percentile. Fixed in decidim 0.27.3.
Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. The processes filter feature is susceptible to Cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing. The problem was patched in version 0.27.3 and 0.26.7.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
8.1
Decidim Cross-site Scripting vulnerability in the processes filter
Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. The processes filter feature is susceptible to Cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing. The problem was patched in version 0.27.3 and 0.26.7.
- Record
CVE-2023-34089- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2023-1963
8.1
Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. The processes filter feature is susceptible to Cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing. The problem was patched in version 0.27.3 and 0.26.7.
- Record
EUVD-2023-1963- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5652-92r9-3fx9
8.1
Decidim Cross-site Scripting vulnerability in the processes filter
Impact
The processes filter feature is susceptible to Cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing.
Patches
- Record
GHSA-5652-92r9-3fx9- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
8.1
Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. The processes filter feature is susceptible to Cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing. The problem was patched in version 0.27.3 and 0.26.7.
- Record
CVE-2023-34089- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
8.1
Decidim Cross-site Scripting vulnerability in the processes filter
Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. The processes filter feature is susceptible to Cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing. The problem was patched in version 0.27.3 and 0.26.7.
- Record
CVE-2023-34089- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-5652-92r9-3fx9
8.1
Decidim Cross-site Scripting vulnerability in the processes filter
Impact
The processes filter feature is susceptible to Cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing.
Patches
- Record
GHSA-5652-92r9-3fx9- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
decidimRubyGems |
0.27.0 up to 0.27.3 | 0.27.3 |
decidim-coreRubyGems |
0.27.0 up to 0.27.3 | 0.27.3 |
decidimRubyGems |
0.14.0 up to 0.26.7 | 0.26.7 |
decidim-coreRubyGems |
0.14.0 up to 0.26.7 | 0.26.7 |
decidimRubyGems |
0.14.0 up to 0.26.7, plus listed versions 0.14.10.14.20.14.30.14.40.15.0 Show 43 moreShow less0.15.10.15.20.16.00.16.10.17.00.17.10.17.20.18.00.18.10.19.00.19.10.20.00.20.10.21.00.22.00.23.00.23.10.23.1.rc10.23.20.23.30.23.40.23.50.23.60.24.00.24.0.rc10.24.0.rc20.24.10.24.20.24.30.25.00.25.0.rc10.25.0.rc20.25.0.rc30.25.0.rc40.25.10.25.20.26.00.26.0.rc20.26.10.26.20.26.30.26.40.26.5 |
0.26.7 |
decidimRubyGems |
0.27.0 up to 0.27.3, plus listed versions 0.27.10.27.2 |
0.27.3 |
decidim-coreRubyGems |
0.14.0 up to 0.26.7, plus listed versions 0.14.10.14.20.14.30.14.40.15.0 Show 44 moreShow less0.15.10.15.20.16.00.16.10.17.00.17.10.17.20.18.00.18.10.19.00.19.10.20.00.20.10.21.00.22.00.23.00.23.10.23.1.rc10.23.20.23.30.23.40.23.50.23.60.24.00.24.0.rc10.24.0.rc20.24.10.24.20.24.30.25.00.25.0.rc10.25.0.rc20.25.0.rc30.25.0.rc40.25.10.25.20.26.00.26.0.rc10.26.0.rc20.26.10.26.20.26.30.26.40.26.5 |
0.26.7 |
decidim-coreRubyGems |
0.27.0 up to 0.27.3, plus listed versions 0.27.10.27.2 |
0.27.3 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases, published | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
github.com/decidim/decidim/security/advisories/GHSA-5652-92r9-3fx9
github.com/decidim/decidim/releases/tag/v0.26.6
github.com/decidim/decidim/releases/tag/v0.27.3
nvd.nist.gov/vuln/detail/CVE-2023-34089
github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim-core/CVE-2023-34089.yml
github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim/CVE-2023-34089.yml