Every CVE Search/ Get API key

CVE-2023-34541

Langchain vulnerable to arbitrary code execution

9.8 CriticalFix available

Langchain 0.0.171 is vulnerable to Arbitrary code execution in load_prompt.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.94%Up 0.9 points since Jun 21, 2023
90%50%10%1%

What each source reports

NVD Score used 9.8

Langchain 0.0.171 is vulnerable to Arbitrary code execution in load_prompt.

Record
CVE-2023-34541
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
CVE List 9.8

Langchain 0.0.171 is vulnerable to Arbitrary code execution in load_prompt.

Record
CVE-2023-34541
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
EUVDEUVD-2023-0121 9.8

Langchain 0.0.171 is vulnerable to Arbitrary code execution in load_prompt.

Record
EUVD-2023-0121
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-6643-h7h5-x9wh 9.3

Langchain vulnerable to arbitrary code execution

Langchain 0.0.171 is vulnerable to Arbitrary code execution in load_prompt.

Record
GHSA-6643-h7h5-x9wh
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV 9.8

Langchain 0.0.171 is vulnerable to Arbitrary code execution in load_prompt.

Record
CVE-2023-34541
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-6643-h7h5-x9wh 9.3

Langchain vulnerable to arbitrary code execution

Langchain 0.0.171 is vulnerable to Arbitrary code execution in load_prompt.

Record
GHSA-6643-h7h5-x9wh
CVSS 4.0
9.3 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVPYSEC-2023-92 No score

Langchain 0.0.171 is vulnerable to Arbitrary code execution in load_prompt.

Record
PYSEC-2023-92
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
langchain
PyPI
before 0.0.247
0.0.247
langchain
PyPI
before 0.0.247, plus listed versions
0.0.10.0.100.0.1000.0.1010.0.101rc0
Show 45 moreShow less
0.0.1020.0.102rc00.0.1030.0.1040.0.1050.0.1060.0.1070.0.1080.0.1090.0.110.0.1100.0.1110.0.1120.0.1130.0.1140.0.1150.0.1160.0.1170.0.1180.0.1190.0.120.0.1200.0.1210.0.1220.0.1230.0.1240.0.1250.0.1260.0.1270.0.1280.0.1290.0.130.0.1300.0.1310.0.1320.0.1330.0.1340.0.1350.0.1360.0.1370.0.1380.0.1390.0.140.0.1400.0.141
0.0.247

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-34541 is a critical vulnerability (CVSS 9.8) in Langchain, published June 20, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.94%, the 61st percentile. Fixed in langchain 0.0.247.

References

This page doesn't list everything

Left out here: 200 versions. The JSON record has them.

MoveEnter Open