Every CVE Search/ Get API key

CVE-2023-34824

fdkaac before 1.0.5 was discovered to contain a heap buffer overflow in caf_info function in...

5.5 MediumFix available

fdkaac before 1.0.5 was discovered to contain a heap buffer overflow in caf_info function in caf_reader.c.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.29%Up 0.2 points since Jun 15, 2023
90%50%10%1%

What each source reports

NVD Score used 5.5

fdkaac before 1.0.5 was discovered to contain a heap buffer overflow in caf_info function in caf_reader.c.

Record
CVE-2023-34824
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-787
Updated
2026-11-02
CVE List 5.5

fdkaac before 1.0.5 was discovered to contain a heap buffer overflow in caf_info function in caf_reader.c.

Record
CVE-2023-34824
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-787
Updated
2026-11-02
EUVDEUVD-2023-38865 5.5

fdkaac before 1.0.5 was discovered to contain a heap buffer overflow in caf_info function in caf_reader.c.

Record
EUVD-2023-38865
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-2mv6-v62f-5jpx 5.5

fdkaac before 1.0.5 was discovered to contain a heap buffer overflow in caf_info function in...

fdkaac before 1.0.5 was discovered to contain a heap buffer overflow in caf_info function in caf_reader.c.

Record
GHSA-2mv6-v62f-5jpx
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-787
Updated
2026-11-02
OSV 5.5

fdkaac before 1.0.5 was discovered to contain a heap buffer overflow in caf_info function in caf_reader.c.

Record
CVE-2023-34824
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2023-34824 5.5

fdkaac before 1.0.5 was discovered to contain a heap buffer overflow in caf_info function in caf_reader.c.

Record
DEBIAN-CVE-2023-34824
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2023-34824 5.5

fdkaac before 1.0.5 was discovered to contain a heap buffer overflow in caf_info function in caf_reader.c.

Record
UBUNTU-CVE-2023-34824
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUSN-7660-1 No score

fdkaac vulnerabilities

It was discovered that fdkaac did not correctly handle certain input. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service. (CVE-2022-36148)

It was discovered that fdkaac did not correctly handle certain memory operations. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service. (CVE-2022-37781, CVE-2023-34823, CVE-2023-34824)

Record
USN-7660-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
fdkaac
Debian:12
All versions, plus listed versions
0.6.2-10.6.3-11.0.0-11.0.6-0.1
None known
fdkaac
Debian:13
before 1.0.6-0.1, plus listed versions
0.6.2-10.6.3-11.0.0-1
1.0.6-0.1
fdkaac
Debian:14
before 1.0.6-0.1, plus listed versions
0.6.2-10.6.3-11.0.0-1
1.0.6-0.1
fdkaac
Ubuntu:Pro:16.04:LTS
before 0.6.2-1ubuntu0.1~esm1, plus listed versions
0.6.2-1
0.6.2-1ubuntu0.1~esm1
fdkaac
Ubuntu:Pro:18.04:LTS
before 0.6.3-1ubuntu0.18.04.1~esm1, plus listed versions
0.6.3-1
0.6.3-1ubuntu0.18.04.1~esm1
fdkaac
Ubuntu:Pro:20.04:LTS
before 0.6.3-1ubuntu0.20.04.1~esm1, plus listed versions
0.6.3-1
0.6.3-1ubuntu0.20.04.1~esm1
fdkaac
Ubuntu:Pro:22.04:LTS
before 1.0.0-1ubuntu0.22.04.1~esm1, plus listed versions
1.0.0-1build1
1.0.0-1ubuntu0.22.04.1~esm1
fdkaac
Ubuntu:Pro:24.04:LTS
before 1.0.0-1ubuntu0.24.04.1~esm1, plus listed versions
1.0.0-1build1
1.0.0-1ubuntu0.24.04.1~esm1
fdkaac
Ubuntu:25.10
All versions, plus listed versions
1.0.0-1build1
None known
fdkaac
Ubuntu:26.10
All versions, plus listed versions
1.0.0-1build11.0.6-0.1build1
None known
Show 6 moreShow less
Affected packages
PackageAffectedFixed
fdkaac
Ubuntu:26.04:LTS
All versions, plus listed versions
1.0.0-1build1
None known
fdkaac
Ubuntu:Pro:16.04:LTS
From an advisory covering 4 CVEs
before 0.6.2-1ubuntu0.1~esm1, plus listed versions
0.6.2-1
0.6.2-1ubuntu0.1~esm1
fdkaac
Ubuntu:Pro:18.04:LTS
From an advisory covering 4 CVEs
before 0.6.3-1ubuntu0.18.04.1~esm1, plus listed versions
0.6.3-1
0.6.3-1ubuntu0.18.04.1~esm1
fdkaac
Ubuntu:Pro:20.04:LTS
From an advisory covering 4 CVEs
before 0.6.3-1ubuntu0.20.04.1~esm1, plus listed versions
0.6.3-1
0.6.3-1ubuntu0.20.04.1~esm1
fdkaac
Ubuntu:Pro:22.04:LTS
From an advisory covering 4 CVEs
before 1.0.0-1ubuntu0.22.04.1~esm1, plus listed versions
1.0.0-1build1
1.0.0-1ubuntu0.22.04.1~esm1
fdkaac
Ubuntu:Pro:24.04:LTS
From an advisory covering 4 CVEs
before 1.0.0-1ubuntu0.24.04.1~esm1, plus listed versions
1.0.0-1build1
1.0.0-1ubuntu0.24.04.1~esm1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-34824 is a medium vulnerability (CVSS 5.5) in Fdkaac Project Fdkaac, published June 14, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.29%, the 22nd percentile. Fixed in fdkaac 1.0.6-0.1.

References

Show 5 moreShow less
MoveEnter Open