Every CVE Search/ Get API key

CVE-2023-35959

Multiple OS command injection vulnerabilities exist in the decompression functionality of GTKWave...

7.8 HighFix available

Multiple OS command injection vulnerabilities exist in the decompression functionality of GTKWave 3.3.115. A specially crafted wave file can lead to arbitrary command execution. A victim would need to open a malicious file to trigger these vulnerabilities.This vulnerability concerns .ghw decompression.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.48%Up 1.4 points since Jan 10, 2024
90%50%10%1%

What each source reports

CVE List Score used 7.8

Multiple OS command injection vulnerabilities exist in the decompression functionality of GTKWave 3.3.115. A specially crafted wave file can lead to arbitrary command execution. A victim would need to open a malicious file to trigger these vulnerabilities.This vulnerability concerns .ghw decompression.

Record
CVE-2023-35959
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-78
Updated
2026-11-02
EUVDEUVD-2023-39943 7.8

Multiple OS command injection vulnerabilities exist in the decompression functionality of GTKWave 3.3.115. A specially crafted wave file can lead to arbitrary command execution. A victim would need to open a malicious file to trigger these vulnerabilities.This vulnerability concerns .ghw decompression.

Record
EUVD-2023-39943
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-p58m-jmcr-h3gh 7.8

Multiple OS command injection vulnerabilities exist in the decompression functionality of GTKWave...

Multiple OS command injection vulnerabilities exist in the decompression functionality of GTKWave 3.3.115. A specially crafted wave file can lead to arbitrary command execution. A victim would need to open a malicious file to trigger these vulnerabilities.This vulnerability concerns .ghw decompression.

Record
GHSA-p58m-jmcr-h3gh
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-78
Updated
2026-11-02
NVD 7.8

Multiple OS command injection vulnerabilities exist in the decompression functionality of GTKWave 3.3.115. A specially crafted wave file can lead to arbitrary command execution. A victim would need to open a malicious file to trigger these vulnerabilities.This vulnerability concerns .ghw decompression.

Record
CVE-2023-35959
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-78
Updated
2026-11-02
OSV 7.8

Multiple OS command injection vulnerabilities exist in the decompression functionality of GTKWave 3.3.115. A specially crafted wave file can lead to arbitrary command execution. A victim would need to open a malicious file to trigger these vulnerabilities.This vulnerability concerns .ghw decompression.

Record
CVE-2023-35959
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2023-35959 7.8

Multiple OS command injection vulnerabilities exist in the decompression functionality of GTKWave 3.3.115. A specially crafted wave file can lead to arbitrary command execution. A victim would need to open a malicious file to trigger these vulnerabilities.This vulnerability concerns .ghw decompression.

Record
DEBIAN-CVE-2023-35959
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2023-35959 7.8

Multiple OS command injection vulnerabilities exist in the decompression functionality of GTKWave 3.3.115. A specially crafted wave file can lead to arbitrary command execution. A victim would need to open a malicious file to trigger these vulnerabilities.This vulnerability concerns .ghw decompression.

Record
UBUNTU-CVE-2023-35959
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gtkwave
Debian:12
before 3.3.118-0.1~deb12u1, plus listed versions
3.3.114-23.3.115-13.3.116-1
3.3.118-0.1~deb12u1
gtkwave
Debian:13
before 3.3.118-0.1
3.3.118-0.1
gtkwave
Debian:14
before 3.3.118-0.1
3.3.118-0.1
gtkwave
Debian:10
From an advisory covering 82 CVEs
before 3.3.98+really3.3.118-0+deb10u1, plus listed versions
3.3.98-1
3.3.98+really3.3.118-0+deb10u1
gtkwave
Debian:11
From an advisory covering 82 CVEs
before 3.3.104+really3.3.118-0+deb11u1, plus listed versions
3.3.104-2
3.3.104+really3.3.118-0+deb11u1
gtkwave
Debian:12
From an advisory covering 82 CVEs
before 3.3.118-0.1~deb12u1, plus listed versions
3.3.114-23.3.115-13.3.116-1
3.3.118-0.1~deb12u1
gtkwave
Ubuntu:16.04:LTS
All versions, plus listed versions
3.3.66-1
None known
gtkwave
Ubuntu:18.04:LTS
All versions, plus listed versions
3.3.82-13.3.86-1
None known
gtkwave
Ubuntu:20.04:LTS
All versions, plus listed versions
3.3.101-23.3.102-13.3.103-13.3.103-1build1
None known
gtkwave
Ubuntu:22.04:LTS
All versions, plus listed versions
3.3.104-23.3.104-2build1
None known
Show 4 moreShow less
Affected packages
PackageAffectedFixed
gtkwave
Ubuntu:24.04:LTS
All versions, plus listed versions
3.3.116-13.3.116-1build13.3.116-1build2
None known
gtkwave
Ubuntu:25.10
All versions, plus listed versions
3.3.121-13.3.125-1
None known
gtkwave
Ubuntu:26.10
All versions, plus listed versions
3.3.126-13.3.127-1
None known
gtkwave
Ubuntu:26.04:LTS
All versions, plus listed versions
3.3.125-13.3.126-1
None known

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-35959 is a high vulnerability (CVSS 7.8) in Gtkwave, published January 8, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.48%, the 74th percentile. Fixed in gtkwave 3.3.118-0.1~deb12u1.

References

MoveEnter Open