CVE-2023-36660
The OCB feature in libnettle in Nettle 3.9 before 3.9.1 allows memory corruption.
The OCB feature in libnettle in Nettle 3.9 before 3.9.1 allows memory corruption.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
The OCB feature in libnettle in Nettle 3.9 before 3.9.1 allows memory corruption.
- Record
CVE-2023-36660- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List No score
The OCB feature in libnettle in Nettle 3.9 before 3.9.1 allows memory corruption.
- Record
CVE-2023-36660- Updated
- 2026-11-02
EUVDEUVD-2023-40604 No score
The OCB feature in libnettle in Nettle 3.9 before 3.9.1 allows memory corruption.
- Record
EUVD-2023-40604- Updated
- 2026-11-02
GitHub AdvisoriesGHSA-whjr-4v2f-wjp4
9.8
The OCB feature in libnettle in Nettle 3.9 before 3.9.1 allows memory corruption.
The OCB feature in libnettle in Nettle 3.9 before 3.9.1 allows memory corruption.
- Record
GHSA-whjr-4v2f-wjp4- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
OSVBELL-CVE-2023-36660
9.8
CVE-2023-36660 does not affect BellSoft software
- Record
BELL-CVE-2023-36660- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV No score
The OCB feature in libnettle in Nettle 3.9 before 3.9.1 allows memory corruption.
- Record
CVE-2023-36660- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:13024-1 No score
libhogweed6-3.9.1-2.1 on GA media
These are all security issues fixed in the libhogweed6-3.9.1-2.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:13024-1- Updated
- 2026-11-02
Affected products
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-36660 is a critical vulnerability (CVSS 9.8) in Nettle Project Nettle, published June 25, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.03%, the 63rd percentile. No source names a fixed version.
References
bugzilla.suse.com/show_bug.cgi?id=1212112
git.lysator.liu.se/nettle/nettle/-/commit/867a4548b95705291a3afdd66d76e7f17ba2618f
git.lysator.liu.se/nettle/nettle/-/compare/nettle_3.9_release_20230514...nettle_3.9.1_release_20230601
security.gentoo.org/glsa/202401-24
cert-portal.siemens.com/productcert/html/ssa-794697.html
nvd.nist.gov/vuln/detail/CVE-2023-36660