Every CVE Search/ Get API key

CVE-2023-36746

Multiple heap-based buffer overflow vulnerabilities exist in the fstReaderIterBlocks2 fstWritex...

7.0 HighFix available

Multiple heap-based buffer overflow vulnerabilities exist in the fstReaderIterBlocks2 fstWritex len functionality of GTKWave 3.3.115. A specially crafted .fst file can lead to memory corruption. A victim would need to open a malicious file to trigger these vulnerabilities.This vulnerability concerns the handling of len in fstWritex when parsing the time table.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
High
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.37%Up 0.3 points since Jan 10, 2024
90%50%10%1%

What each source reports

CVE List Score used 7.0

Multiple heap-based buffer overflow vulnerabilities exist in the fstReaderIterBlocks2 fstWritex len functionality of GTKWave 3.3.115. A specially crafted .fst file can lead to memory corruption. A victim would need to open a malicious file to trigger these vulnerabilities.This vulnerability concerns the handling of len in fstWritex when parsing the time table.

Record
CVE-2023-36746
CVSS 3.1
7.0 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
EUVDEUVD-2023-40689 7.0

Multiple heap-based buffer overflow vulnerabilities exist in the fstReaderIterBlocks2 fstWritex len functionality of GTKWave 3.3.115. A specially crafted .fst file can lead to memory corruption. A victim would need to open a malicious file to trigger these vulnerabilities.This vulnerability concerns the handling of len in fstWritex when parsing the time table.

Record
EUVD-2023-40689
CVSS 3.1
7.0 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-f5jr-v79w-8298 7.0

Multiple heap-based buffer overflow vulnerabilities exist in the fstReaderIterBlocks2 fstWritex...

Multiple heap-based buffer overflow vulnerabilities exist in the fstReaderIterBlocks2 fstWritex len functionality of GTKWave 3.3.115. A specially crafted .fst file can lead to memory corruption. A victim would need to open a malicious file to trigger these vulnerabilities.This vulnerability concerns the handling of len in fstWritex when parsing the time table.

Record
GHSA-f5jr-v79w-8298
CVSS 3.1
7.0 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-119, CWE-787
Updated
2026-11-02
NVD 7.0

Multiple heap-based buffer overflow vulnerabilities exist in the fstReaderIterBlocks2 fstWritex len functionality of GTKWave 3.3.115. A specially crafted .fst file can lead to memory corruption. A victim would need to open a malicious file to trigger these vulnerabilities.This vulnerability concerns the handling of len in fstWritex when parsing the time table.

Record
CVE-2023-36746
CVSS 3.1
7.0 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-119, CWE-787
Updated
2026-11-02
OSV 7.8

Multiple heap-based buffer overflow vulnerabilities exist in the fstReaderIterBlocks2 fstWritex len functionality of GTKWave 3.3.115. A specially crafted .fst file can lead to memory corruption. A victim would need to open a malicious file to trigger these vulnerabilities.This vulnerability concerns the handling of len in fstWritex when parsing the time table.

Record
CVE-2023-36746
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2023-36746 7.8

Multiple heap-based buffer overflow vulnerabilities exist in the fstReaderIterBlocks2 fstWritex len functionality of GTKWave 3.3.115. A specially crafted .fst file can lead to memory corruption. A victim would need to open a malicious file to trigger these vulnerabilities.This vulnerability concerns the handling of len in fstWritex when parsing the time table.

Record
DEBIAN-CVE-2023-36746
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2023-36746 7.0

Multiple heap-based buffer overflow vulnerabilities exist in the fstReaderIterBlocks2 fstWritex len functionality of GTKWave 3.3.115. A specially crafted .fst file can lead to memory corruption. A victim would need to open a malicious file to trigger these vulnerabilities.This vulnerability concerns the handling of len in fstWritex when parsing the time table.

Record
UBUNTU-CVE-2023-36746
CVSS 3.1
7.0 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gtkwave
Debian:12
before 3.3.118-0.1~deb12u1, plus listed versions
3.3.114-23.3.115-13.3.116-1
3.3.118-0.1~deb12u1
gtkwave
Debian:13
before 3.3.118-0.1
3.3.118-0.1
gtkwave
Debian:14
before 3.3.118-0.1
3.3.118-0.1
gtkwave
Debian:10
From an advisory covering 82 CVEs
before 3.3.98+really3.3.118-0+deb10u1, plus listed versions
3.3.98-1
3.3.98+really3.3.118-0+deb10u1
gtkwave
Debian:11
From an advisory covering 82 CVEs
before 3.3.104+really3.3.118-0+deb11u1, plus listed versions
3.3.104-2
3.3.104+really3.3.118-0+deb11u1
gtkwave
Debian:12
From an advisory covering 82 CVEs
before 3.3.118-0.1~deb12u1, plus listed versions
3.3.114-23.3.115-13.3.116-1
3.3.118-0.1~deb12u1
gtkwave
Ubuntu:16.04:LTS
All versions, plus listed versions
3.3.66-1
None known
gtkwave
Ubuntu:18.04:LTS
All versions, plus listed versions
3.3.82-13.3.86-1
None known
gtkwave
Ubuntu:20.04:LTS
All versions, plus listed versions
3.3.101-23.3.102-13.3.103-13.3.103-1build1
None known
gtkwave
Ubuntu:22.04:LTS
All versions, plus listed versions
3.3.104-23.3.104-2build1
None known
Show 4 moreShow less
Affected packages
PackageAffectedFixed
gtkwave
Ubuntu:24.04:LTS
All versions, plus listed versions
3.3.116-13.3.116-1build13.3.116-1build2
None known
gtkwave
Ubuntu:25.10
All versions, plus listed versions
3.3.121-13.3.125-1
None known
gtkwave
Ubuntu:26.10
All versions, plus listed versions
3.3.126-13.3.127-1
None known
gtkwave
Ubuntu:26.04:LTS
All versions, plus listed versions
3.3.125-13.3.126-1
None known

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-36746 is a high vulnerability (CVSS 7.0) in Gtkwave, published January 8, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.37%, the 31st percentile. Fixed in gtkwave 3.3.118-0.1~deb12u1.

References

MoveEnter Open