CVE-2023-37360
pacparser_find_proxy in Pacparser before 1.4.2 allows JavaScript injection, and possibly...
pacparser_find_proxy in Pacparser before 1.4.2 allows JavaScript injection, and possibly privilege escalation, when the attacker controls the URL (which may be realistic within enterprise security products).
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
5.9
pacparser_find_proxy in Pacparser before 1.4.2 allows JavaScript injection, and possibly privilege escalation, when the attacker controls the URL (which may be realistic within enterprise security products).
- Record
CVE-2023-37360- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AC:L/AV:L/A:L/C:L/I:L/PR:N/S:U/UI:N - Updated
- 2026-11-02
EUVDEUVD-2023-0190
5.9
pacparser_find_proxy in Pacparser before 1.4.2 allows JavaScript injection, and possibly privilege escalation, when the attacker controls the URL (which may be realistic within enterprise security products).
- Record
EUVD-2023-0190- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AC:L/AV:L/A:L/C:L/I:L/PR:N/S:U/UI:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-jw9q-h95v-3wgq
5.9
pacparser_find_proxy in Pacparser before 1.4.2 allows JavaScript injection, and possibly...
pacparser_find_proxy in Pacparser before 1.4.2 allows JavaScript injection, and possibly privilege escalation, when the attacker controls the URL (which may be realistic within enterprise security products).
- Record
GHSA-jw9q-h95v-3wgq- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-74
- Updated
- 2026-11-02
NVD
5.9
pacparser_find_proxy in Pacparser before 1.4.2 allows JavaScript injection, and possibly privilege escalation, when the attacker controls the URL (which may be realistic within enterprise security products).
- Record
CVE-2023-37360- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-74
- Updated
- 2026-11-02
OSV
5.9
pacparser_find_proxy in Pacparser before 1.4.2 allows JavaScript injection, and possibly privilege escalation, when the attacker controls the URL (which may be realistic within enterprise security products).
- Record
CVE-2023-37360- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AC:L/AV:L/A:L/C:L/I:L/PR:N/S:U/UI:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-37360
6.1
pacparser_find_proxy in Pacparser before 1.4.2 allows JavaScript injection, and possibly privilege escalation, when the attacker controls the URL (which may be realistic within enterprise security products).
- Record
DEBIAN-CVE-2023-37360- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-37360
5.9
pacparser_find_proxy in Pacparser before 1.4.2 allows JavaScript injection, and possibly privilege escalation, when the attacker controls the URL (which may be realistic within enterprise security products).
- Record
UBUNTU-CVE-2023-37360- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVPYSEC-2023-93 No score
pacparser_find_proxy in Pacparser before 1.4.2 allows JavaScript injection, and possibly privilege escalation, when the attacker controls the URL (which may be realistic within enterprise security products).
- Record
PYSEC-2023-93- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pacparserDebian:12 |
All versions, plus listed versions 1.3.6-1.41.4.3-11.4.5-11.4.5-21.4.5-3 Show 4 moreShow less1.4.5-41.4.6-11.5.0-11.5.1-1 |
None known |
pacparserDebian:13 |
before 1.4.3-1 | 1.4.3-1 |
pacparserDebian:14 |
before 1.4.3-1 | 1.4.3-1 |
pacparserPyPI |
before 1.4.2, plus listed versions 1.3.71.3.7rc11.3.7rc51.3.7rc61.3.8.dev15 Show 27 moreShow less1.3.8.dev181.3.8.dev391.3.91.3.9.dev71.3.9.dev81.4.01.4.0.dev11.4.0.dev31.4.11.4.1.dev101.4.1.dev131.4.1.dev141.4.1.dev151.4.1.dev161.4.1.dev71.4.1.dev81.4.1.dev91.4.2.dev11.4.2.dev41.4.2.dev51.4.2.dev111.4.2.dev121.4.2.dev181.4.2.dev191.4.2.dev211.4.2.dev221.4.2.dev8 |
1.4.2 |
pacparserUbuntu:16.04:LTS |
All versions, plus listed versions 1.3.0-21.3.6-11.3.6-1.11.3.6-1.1build1 |
None known |
pacparserUbuntu:18.04:LTS |
All versions, plus listed versions 1.3.6-1.1build3 |
None known |
pacparserUbuntu:20.04:LTS |
All versions, plus listed versions 1.3.6-1.1build51.3.6-1.1build61.3.6-1.1ubuntu11.3.6-1.2 |
None known |
pacparserUbuntu:22.04:LTS |
All versions, plus listed versions 1.3.6-1.2build21.3.6-1.2build31.3.6-1.2ubuntu1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-37360 is a medium vulnerability (CVSS 5.9) in Pacparser Project Pacparser, published June 30, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.36%, the 30th percentile. Fixed in pacparser 1.4.3-1.
References
github.com/manugarg/pacparser/security/advisories/GHSA-62q6-v997-f7v9
nvd.nist.gov/vuln/detail/CVE-2023-37360
github.com/advisories/GHSA-jw9q-h95v-3wgq
github.com/CVEProject/cvelistV5/tree/main/cves/2023/37xxx/CVE-2023-37360.json
security-tracker.debian.org/tracker/CVE-2023-37360
ubuntu.com/security/CVE-2023-37360
cve.org/CVERecord?id=CVE-2023-37360