CVE-2023-38560
Ghostscript: integer overflow in pcl/pl/plfont.c:418 in pl_glyph_name
An integer overflow flaw was found in pcl/pl/plfont.c:418 in pl_glyph_name in ghostscript. This issue may allow a local attacker to cause a denial of service via transforming a crafted PCL file to PDF format.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
5.5
Ghostscript: integer overflow in pcl/pl/plfont.c:418 in pl_glyph_name
An integer overflow flaw was found in pcl/pl/plfont.c:418 in pl_glyph_name in ghostscript. This issue may allow a local attacker to cause a denial of service via transforming a crafted PCL file to PDF format.
- Record
CVE-2023-38560- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-190
- Updated
- 2026-11-07
EUVDEUVD-2023-42359
5.5
An integer overflow flaw was found in pcl/pl/plfont.c:418 in pl_glyph_name in ghostscript. This issue may allow a local attacker to cause a denial of service via transforming a crafted PCL file to PDF format.
- Record
EUVD-2023-42359- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-07
GitHub AdvisoriesGHSA-hj8r-56hg-7wg8
5.5
An integer overflow flaw was found in pcl/pl/plfont.c:418 in pl_glyph_name in ghostscript. This...
An integer overflow flaw was found in pcl/pl/plfont.c:418 in pl_glyph_name in ghostscript. This issue may allow a local attacker to cause a denial of service via transforming a crafted PCL file to PDF format.
- Record
GHSA-hj8r-56hg-7wg8- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-190
- Updated
- 2026-11-02
NVD
5.5
An integer overflow flaw was found in pcl/pl/plfont.c:418 in pl_glyph_name in ghostscript. This issue may allow a local attacker to cause a denial of service via transforming a crafted PCL file to PDF format.
- Record
CVE-2023-38560- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-190
- Updated
- 2026-11-07
OSVBELL-CVE-2023-38560
5.5
- Record
BELL-CVE-2023-38560- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSV
5.5
An integer overflow flaw was found in pcl/pl/plfont.c:418 in pl_glyph_name in ghostscript. This issue may allow a local attacker to cause a denial of service via transforming a crafted PCL file to PDF format.
- Record
CVE-2023-38560- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2023-38560
5.5
An integer overflow flaw was found in pcl/pl/plfont.c:418 in pl_glyph_name in ghostscript. This issue may allow a local attacker to cause a denial of service via transforming a crafted PCL file to PDF format.
- Record
DEBIAN-CVE-2023-38560- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-38560
5.5
An integer overflow flaw was found in pcl/pl/plfont.c:418 in pl_glyph_name in ghostscript. This issue may allow a local attacker to cause a denial of service via transforming a crafted PCL file to PDF format.
- Record
UBUNTU-CVE-2023-38560- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2023-0267 No score
Updated ghostpcl packages fix security vulnerability
An integer overflow flaw was found in pcl/pl/plfont.c:418 in pl_glyph_name in ghostscript. This issue may allow a local attacker to cause a denial of service via transforming a crafted PCL file to PDF format. (CVE-2023-38560)
- Record
MGASA-2023-0267- Updated
- 2026-11-02
OSVROOT-OS-DEBIAN-12-CVE-2023-38560 No score
CVE-2023-38560 in ghostscript - Patched by Root
Root has patched CVE-2023-38560 in the ghostscript package for Root:Debian:12. Multiple fixed versions available.
- Record
ROOT-OS-DEBIAN-12-CVE-2023-38560- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ghostscriptAlpaquita:stream |
10.0.0-r0 up to 10.02.0-r1 | 10.02.0-r1 |
ghostscriptDebian:12 |
All versions, plus listed versions 10.0.0~dfsg-1110.0.0~dfsg-11+deb12u110.0.0~dfsg-11+deb12u210.0.0~dfsg-11+deb12u310.0.0~dfsg-11+deb12u4 Show 28 moreShow less10.0.0~dfsg-11+deb12u510.0.0~dfsg-11+deb12u610.0.0~dfsg-11+deb12u710.0.0~dfsg-11+deb12u810.01.2~dfsg-110.02.0~dfsg-110.02.0~dfsg-210.02.1~dfsg-110.02.1~dfsg-210.02.1~dfsg-310.03.0~dfsg-110.03.1~dfsg-110.03.1~dfsg-210.03.1~dfsg~git20240518-110.04.0~dfsg-110.04.0~dfsg-210.05.0~dfsg-110.05.1~dfsg-110.05.1~dfsg-210.05.1~dfsg-310.06.0~dfsg-110.06.0~dfsg-210.06.0~dfsg-310.07.0~dfsg-110.07.0~dfsg-210.07.1~dfsg-110.08.0~dfsg-110.08.0~dfsg-2 |
None known |
ghostscriptDebian:13 |
before 10.02.0~dfsg-1 | 10.02.0~dfsg-1 |
ghostscriptDebian:14 |
before 10.02.0~dfsg-1 | 10.02.0~dfsg-1 |
ghostpclMageia:8 |
before 9.53.3-2.1.mga8 | 9.53.3-2.1.mga8 |
ghostpclMageia:9 |
before 10.0.0-2.2.mga9 | 10.0.0-2.2.mga9 |
ghostscriptRoot:Debian:12 |
before 10.0.0~dfsg-11+deb12u8.aikido.6 | 10.0.0~dfsg-11+deb12u8.aikido.6 |
rootio-ghostscriptRoot:Debian:12 |
before 10.0.0~dfsg-11+deb12u8.aikido.6 | 10.0.0~dfsg-11+deb12u8.aikido.6 |
ghostscriptUbuntu:Pro:20.04:LTS |
All versions, plus listed versions 9.27~dfsg+0-0ubuntu39.27~dfsg+0-0ubuntu49.50~dfsg-5ubuntu19.50~dfsg-5ubuntu29.50~dfsg-5ubuntu3 Show 19 moreShow less9.50~dfsg-5ubuntu49.50~dfsg-5ubuntu4.19.50~dfsg-5ubuntu4.29.50~dfsg-5ubuntu4.39.50~dfsg-5ubuntu4.49.50~dfsg-5ubuntu4.59.50~dfsg-5ubuntu4.69.50~dfsg-5ubuntu4.79.50~dfsg-5ubuntu4.89.50~dfsg-5ubuntu4.99.50~dfsg-5ubuntu4.109.50~dfsg-5ubuntu4.119.50~dfsg-5ubuntu4.129.50~dfsg-5ubuntu4.139.50~dfsg-5ubuntu4.149.50~dfsg-5ubuntu4.159.50~dfsg-5ubuntu4.15+esm19.50~dfsg-5ubuntu4.15+esm29.50~dfsg-5ubuntu4.15+esm3 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | EUVD | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-38560 is a medium vulnerability (CVSS 5.5) in Artifex Ghostscript, published August 1, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.32%, the 25th percentile. Fixed in ghostscript 10.02.0-r1.
References
access.redhat.com/security/cve/CVE-2023-38560
bugs.ghostscript.com/show_bug.cgi?id=706898
bugzilla.redhat.com/show_bug.cgi?id=2224368
git.ghostscript.com?p=ghostpdl.git;a=commitdiff;h=b7eb1d0174c
nvd.nist.gov/vuln/detail/CVE-2023-38560
bugs.ghostscript.com/show_bug.cgi?id=706897