Every CVE Search/ Get API key

CVE-2023-38672

FPE in paddle.linalg.matrix_power

4.7 MediumFix available

FPE in paddle.trace in PaddlePaddle before 2.5.0. This flaw can cause a runtime crash and a denial of service.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
Low

Exploit likelihood

0.74%Up 0.7 points since Jul 27, 2023
90%50%10%1%

What each source reports

CVE List Score used 4.7

FPE in paddle.linalg.matrix_power

FPE in paddle.trace in PaddlePaddle before 2.5.0. This flaw can cause a runtime crash and a denial of service.

Record
CVE-2023-38672
CVSS 3.1
4.7 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:L
Weakness
CWE-369
Updated
2026-11-02
EUVDEUVD-2023-0194 4.7

FPE in paddle.trace in PaddlePaddle before 2.5.0. This flaw can cause a runtime crash and a denial of service.

Record
EUVD-2023-0194
CVSS 3.1
4.7 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-cv2j-922j-hr56 4.7

Float point exception (FPE) in paddlepaddle

FPE in paddle.linalg.matrix_power in PaddlePaddle before 2.5.0. This flaw can cause a runtime crash and a denial of service.

Record
GHSA-cv2j-922j-hr56
CVSS 3.1
4.7 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:L
Weakness
CWE-369
Updated
2026-11-02
NVD 4.7

FPE in paddle.trace in PaddlePaddle before 2.5.0. This flaw can cause a runtime crash and a denial of service.

Record
CVE-2023-38672
CVSS 3.1
4.7 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:L
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-369
Updated
2026-11-02
OSV 7.5

FPE in paddle.trace in PaddlePaddle before 2.5.0. This flaw can cause a runtime crash and a denial of service.

Record
CVE-2023-38672
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVGHSA-cv2j-922j-hr56 4.7

Float point exception (FPE) in paddlepaddle

FPE in paddle.linalg.matrix_power in PaddlePaddle before 2.5.0. This flaw can cause a runtime crash and a denial of service.

Record
GHSA-cv2j-922j-hr56
CVSS 3.1
4.7 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:L
Weakness
CWE-369
Updated
2026-11-02
OSVPYSEC-2023-125 No score

FPE in paddle.trace in PaddlePaddle before 2.5.0. This flaw can cause a runtime crash and a denial of service.

Record
PYSEC-2023-125
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
paddlepaddle
PyPI
before 2.5.0
2.5.0
paddlepaddle
PyPI
before 2.5.0, plus listed versions
1.8.5
2.5.0
paddlepaddle
PyPI
before 2.5.0, plus listed versions
1.8.52.0.02.0.0rc02.0.0rc12.0.1
Show 19 moreShow less
2.0.22.1.02.1.12.1.22.1.32.2.02.2.0rc02.2.12.2.22.3.02.3.0rc02.3.12.3.22.4.02.4.0rc02.4.12.4.22.5.0rc02.5.0rc1
2.5.0

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-38672 is a medium vulnerability (CVSS 4.7) in Paddlepaddle, published July 26, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.74%, the 54th percentile. Fixed in paddlepaddle 2.5.0.

References

MoveEnter Open