Every CVE Search/ Get API key

CVE-2023-39660

pandasai vulnerable to prompt injection

9.8 CriticalFix available

An issue in Gaberiele Venturi pandasai v.0.8.0 and before allows a remote attacker to execute arbitrary code via a crafted request to the prompt function.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.53%Up 1.5 points since Aug 22, 2023
90%50%10%1%

What each source reports

NVD Score used 9.8

An issue in Gaberiele Venturi pandasai v.0.8.0 and before allows a remote attacker to execute arbitrary code via a crafted request to the prompt function.

Record
CVE-2023-39660
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
CVE List No score

An issue in Gaberiele Venturi pandasai v.0.8.0 and before allows a remote attacker to execute arbitrary code via a crafted request to the prompt function.

Record
CVE-2023-39660
Weakness
CWE-94
Updated
2026-11-02
EUVDEUVD-2023-2372 No score

An issue in Gaberiele Venturi pandasai v.0.8.0 and before allows a remote attacker to execute arbitrary code via a crafted request to the prompt function.

Record
EUVD-2023-2372
Updated
2026-11-03
GitHub AdvisoriesGHSA-w832-v3c6-m6rg No score

pandasai vulnerable to prompt injection

An issue in Gaberiele Venturi pandasai v.0.8.0 and before allows a remote attacker to execute arbitrary code via a crafted request to the prompt function.

Record
GHSA-w832-v3c6-m6rg
Weakness
CWE-94
Updated
2026-11-02
OSV No score

An issue in Gaberiele Venturi pandasai v.0.8.0 and before allows a remote attacker to execute arbitrary code via a crafted request to the prompt function.

Record
CVE-2023-39660
Updated
2026-11-02
OSVGHSA-w832-v3c6-m6rg No score

pandasai vulnerable to prompt injection

An issue in Gaberiele Venturi pandasai v.0.8.0 and before allows a remote attacker to execute arbitrary code via a crafted request to the prompt function.

Record
GHSA-w832-v3c6-m6rg
Weakness
CWE-94
Updated
2026-11-02
OSVPYSEC-2026-1757 No score

pandasai vulnerable to prompt injection

An issue in Gaberiele Venturi pandasai v.0.8.0 and before allows a remote attacker to execute arbitrary code via a crafted request to the prompt function.

Record
PYSEC-2026-1757
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pandasai
PyPI
before 0.8.1
0.8.1
pandasai
PyPI
before 0.8.1, plus listed versions
0.0.10.0.20.0.30.1.00.1.1
Show 44 moreShow less
0.2.00.2.10.2.100.2.110.2.120.2.130.2.140.2.150.2.160.2.20.2.30.2.40.2.50.2.60.2.70.2.80.2.90.3.00.4.00.4.10.4.20.5.00.5.10.5.20.5.30.5.40.5.50.6.00.6.10.6.100.6.110.6.120.6.20.6.30.6.40.6.50.6.60.6.70.6.80.6.90.7.00.7.10.7.20.8.0
0.8.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-39660 is a critical vulnerability (CVSS 9.8) in Gabrieleventuri Pandasai, published August 21, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.53%, the 74th percentile. Fixed in pandasai 0.8.1.

References

MoveEnter Open