CVE-2023-39949
Improper validation of sequence numbers leading to remotely reachable assertion failure
eprosima Fast DDS is a C++ implementation of the Data Distribution Service standard of the Object Management Group. Prior to versions 2.9.1 and 2.6.5, improper validation of sequence numbers may lead to remotely reachable assertion failure. This can remotely crash any Fast-DDS process. Versions 2.9.1 and 2.6.5 contain a patch for this issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
Improper validation of sequence numbers leading to remotely reachable assertion failure
eprosima Fast DDS is a C++ implementation of the Data Distribution Service standard of the Object Management Group. Prior to versions 2.9.1 and 2.6.5, improper validation of sequence numbers may lead to remotely reachable assertion failure. This can remotely crash any Fast-DDS process. Versions 2.9.1 and 2.6.5 contain a patch for this issue.
- Record
CVE-2023-39949- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-617
- Updated
- 2026-11-02
EUVDEUVD-2023-43647
7.5
eprosima Fast DDS is a C++ implementation of the Data Distribution Service standard of the Object Management Group. Prior to versions 2.9.1 and 2.6.5, improper validation of sequence numbers may lead to remotely reachable assertion failure. This can remotely crash any Fast-DDS process. Versions 2.9.1 and 2.6.5 contain a patch for this issue.
- Record
EUVD-2023-43647- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-03
NVD
7.5
eprosima Fast DDS is a C++ implementation of the Data Distribution Service standard of the Object Management Group. Prior to versions 2.9.1 and 2.6.5, improper validation of sequence numbers may lead to remotely reachable assertion failure. This can remotely crash any Fast-DDS process. Versions 2.9.1 and 2.6.5 contain a patch for this issue.
- Record
CVE-2023-39949- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-617
- Updated
- 2026-11-02
OSV
7.5
Improper validation of sequence numbers leading to remotely reachable assertion failure
eprosima Fast DDS is a C++ implementation of the Data Distribution Service standard of the Object Management Group. Prior to versions 2.9.1 and 2.6.5, improper validation of sequence numbers may lead to remotely reachable assertion failure. This can remotely crash any Fast-DDS process. Versions 2.9.1 and 2.6.5 contain a patch for this issue.
- Record
CVE-2023-39949- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-617
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-39949
7.5
eprosima Fast DDS is a C++ implementation of the Data Distribution Service standard of the Object Management Group. Prior to versions 2.9.1 and 2.6.5, improper validation of sequence numbers may lead to remotely reachable assertion failure. This can remotely crash any Fast-DDS process. Versions 2.9.1 and 2.6.5 contain a patch for this issue.
- Record
DEBIAN-CVE-2023-39949- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-39949
7.5
eprosima Fast DDS is a C++ implementation of the Data Distribution Service standard of the Object Management Group. Prior to versions 2.9.1 and 2.6.5, improper validation of sequence numbers may lead to remotely reachable assertion failure. This can remotely crash any Fast-DDS process. Versions 2.9.1 and 2.6.5 contain a patch for this issue.
- Record
UBUNTU-CVE-2023-39949- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUSN-6306-1 No score
fastdds vulnerabilities
It was discovered that Fast DDS incorrectly handled certain inputs. A remote attacker could possibly use this issue to cause a denial of service and information exposure. This issue only affected Ubuntu 22.04 LTS. (CVE-2021-38425)
It was discovered that Fast DDS incorrectly handled certain inputs. An attacker could possibly use this issue to cause a crash. (CVE-2023-39534, CVE-2023-39945, CVE-2023-39946, CVE-2023-39947, CVE-2023-39948, CVE-2023-39949)
- Record
USN-6306-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
fastddsDebian:12 |
before 2.9.1+ds-1+deb12u1, plus listed versions 2.9.1+ds-1 |
2.9.1+ds-1+deb12u1 |
fastddsDebian:13 |
before 2.10.1+ds-2 | 2.10.1+ds-2 |
fastddsDebian:11 From an advisory covering 6 CVEs |
before 2.1.0+ds-9+deb11u1, plus listed versions 2.1.0+ds-9 |
2.1.0+ds-9+deb11u1 |
fastddsDebian:12 From an advisory covering 6 CVEs |
before 2.9.1+ds-1+deb12u1, plus listed versions 2.9.1+ds-1 |
2.9.1+ds-1+deb12u1 |
fastddsUbuntu:Pro:22.04:LTS |
before 2.5.0+ds-3ubuntu0.1~esm1, plus listed versions 2.1.0+ds-92.4.1+ds-12.5.0+ds-3 |
2.5.0+ds-3ubuntu0.1~esm1 |
fastddsUbuntu:Pro:22.04:LTS From an advisory covering 7 CVEs |
before 2.5.0+ds-3ubuntu0.1~esm1, plus listed versions 2.1.0+ds-92.4.1+ds-12.5.0+ds-3 |
2.5.0+ds-3ubuntu0.1~esm1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases, published | EUVD | |
| first indexed | CVE List, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-39949 is a high vulnerability (CVSS 7.5) in Eprosima Fast-dds, published August 11, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.04%, the 64th percentile. Fixed in fastdds 2.9.1+ds-1+deb12u1.
References
github.com/eProsima/Fast-DDS/security/advisories/GHSA-3jv9-j9x3-95cg
github.com/eProsima/Fast-DDS/issues/3236
github.com/eProsima/Fast-DDS/blob/v2.9.0/src/cpp/rtps/messages/MessageReceiver.cpp
debian.org/security/2023/dsa-5481
github.com/CVEProject/cvelistV5/tree/main/cves/2023/39xxx/CVE-2023-39949.json
nvd.nist.gov/vuln/detail/CVE-2023-39949
Show 10 moreShow less
security-tracker.debian.org/tracker/CVE-2023-39949
ubuntu.com/security/CVE-2023-39949
ubuntu.com/security/notices/USN-6306-1
cve.org/CVERecord?id=CVE-2023-39949
ubuntu.com/security/CVE-2021-38425
ubuntu.com/security/CVE-2023-39534
ubuntu.com/security/CVE-2023-39945
ubuntu.com/security/CVE-2023-39946
ubuntu.com/security/CVE-2023-39947
ubuntu.com/security/CVE-2023-39948