Every CVE Search/ Get API key

CVE-2023-40032

Potential segfault due to NULL pointer dereference in libvips

5.5 MediumFix available

libvips is a demand-driven, horizontally threaded image processing library. A specially crafted SVG input can cause libvips versions 8.14.3 or earlier to segfault when attempting to parse a malformed UTF-8 character. Users should upgrade to libvips version 8.14.4 (or later) when processing untrusted input.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.25%Up 0.2 points since Sep 12, 2023
90%50%10%1%

What each source reports

CVE List Score used 5.5

Potential segfault due to NULL pointer dereference in libvips

libvips is a demand-driven, horizontally threaded image processing library. A specially crafted SVG input can cause libvips versions 8.14.3 or earlier to segfault when attempting to parse a malformed UTF-8 character. Users should upgrade to libvips version 8.14.4 (or later) when processing untrusted input.

Record
CVE-2023-40032
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-476
Updated
2026-11-02
EUVDEUVD-2023-44643 5.5

libvips is a demand-driven, horizontally threaded image processing library. A specially crafted SVG input can cause libvips versions 8.14.3 or earlier to segfault when attempting to parse a malformed UTF-8 character. Users should upgrade to libvips version 8.14.4 (or later) when processing untrusted input.

Record
EUVD-2023-44643
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
NVD 5.5

libvips is a demand-driven, horizontally threaded image processing library. A specially crafted SVG input can cause libvips versions 8.14.3 or earlier to segfault when attempting to parse a malformed UTF-8 character. Users should upgrade to libvips version 8.14.4 (or later) when processing untrusted input.

Record
CVE-2023-40032
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-476
Updated
2026-11-02
OSV 5.5

Potential segfault due to NULL pointer dereference in libvips

libvips is a demand-driven, horizontally threaded image processing library. A specially crafted SVG input can cause libvips versions 8.14.3 or earlier to segfault when attempting to parse a malformed UTF-8 character. Users should upgrade to libvips version 8.14.4 (or later) when processing untrusted input.

Record
CVE-2023-40032
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-476
Updated
2026-11-02
OSVDEBIAN-CVE-2023-40032 5.5

libvips is a demand-driven, horizontally threaded image processing library. A specially crafted SVG input can cause libvips versions 8.14.3 or earlier to segfault when attempting to parse a malformed UTF-8 character. Users should upgrade to libvips version 8.14.4 (or later) when processing untrusted input.

Record
DEBIAN-CVE-2023-40032
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2023-40032 5.5

libvips is a demand-driven, horizontally threaded image processing library. A specially crafted SVG input can cause libvips versions 8.14.3 or earlier to segfault when attempting to parse a malformed UTF-8 character. Users should upgrade to libvips version 8.14.4 (or later) when processing untrusted input.

Record
UBUNTU-CVE-2023-40032
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2026:12266-1 No score

libvips-devel-8.18.7-1.1 on GA media

These are all security issues fixed in the libvips-devel-8.18.7-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2026:12266-1
Updated
2026-11-02
OSVUSN-6437-1 No score

vips vulnerabilities

Ziqiang Gu discovered that VIPS could be made to dereference a NULL pointer. If a user or automated system were tricked into processing a specially crafted input image file, an attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 16.04 LTS and Ubuntu 18.04 LTS. (CVE-2018-7998)

It was discovered that VIPS did not properly handle uninitialized memory locations when processing corrupted input image data. An attacker could possibly use this issue to generate output images that expose sensitive information. This issue only affected Ubuntu 16.04 LTS and Ubuntu 18.04 LTS. (CVE-2019-6976)

It was discovered that VIPS did not properly manage memory due to an uninitialized variable. If a user or automated system were tricked into processing a specially crafted output file, an attacker could possibly use this issue to expose sensitive information. This issue only affected Ubuntu 16.04 LTS and Ubuntu 18.04 LTS. (CVE-2020-20739)

It was discovered that VIPS could be made to divide by zero in multiple funcions. If a user or automated system were tricked into processing a specially crafted image file, an attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 16.04 LTS and Ubuntu 18.04 LTS. (CVE-2021-27847)

It was discovered that VIPS did not properly handle certain input files that contained malformed UTF-8 characters. If a user or automated system were tricked into processing a specially crafted SVG image file, an attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 22.04 LTS. (CVE-2023-40032)

Record
USN-6437-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
vips
Debian:12
before 8.14.1-3+deb12u1, plus listed versions
8.14.1-3
8.14.1-3+deb12u1
vips
Debian:13
before 8.14.4-1
8.14.4-1
vips
Debian:14
before 8.14.4-1
8.14.4-1
vips
Ubuntu:Pro:22.04:LTS
before 8.12.1-1ubuntu0.1~esm1, plus listed versions
8.10.5-2ubuntu18.11.4-28.12.1-18.12.1-1build1
8.12.1-1ubuntu0.1~esm1
vips
Ubuntu:Pro:16.04:LTS
From an advisory covering 5 CVEs
before 8.2.2-1ubuntu0.1~esm1, plus listed versions
7.40.6-2ubuntu28.0.2-28.2.1-18.2.2-1
8.2.2-1ubuntu0.1~esm1
vips
Ubuntu:Pro:18.04:LTS
From an advisory covering 5 CVEs
before 8.4.5-1ubuntu0.1~esm1, plus listed versions
8.4.5-1build1
8.4.5-1ubuntu0.1~esm1
vips
Ubuntu:Pro:22.04:LTS
From an advisory covering 5 CVEs
before 8.12.1-1ubuntu0.1~esm1, plus listed versions
8.10.5-2ubuntu18.11.4-28.12.1-18.12.1-1build1
8.12.1-1ubuntu0.1~esm1
vips
openSUSE:Tumbleweed
From an advisory covering 9 CVEs
before 8.18.7-1.1
8.18.7-1.1

History

History
RecordedChangedSources
affected, facts
aliases, publishedEUVD
first indexedCVE List, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-40032 is a medium vulnerability (CVSS 5.5) in Libvips, published September 11, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.25%, the 16th percentile. Fixed in vips 8.14.1-3+deb12u1.

References

Show 17 moreShow less
MoveEnter Open