CVE-2023-40619
phpPgAdmin 7.14.4 and earlier is vulnerable to deserialization of untrusted data which may lead...
phpPgAdmin 7.14.4 and earlier is vulnerable to deserialization of untrusted data which may lead to remote code execution because user-controlled data is directly passed to the PHP 'unserialize()' function in multiple places. An example is the functionality to manage tables in 'tables.php' where the 'ma[]' POST parameter is deserialized.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
phpPgAdmin 7.14.4 and earlier is vulnerable to deserialization of untrusted data which may lead to remote code execution because user-controlled data is directly passed to the PHP 'unserialize()' function in multiple places. An example is the functionality to manage tables in 'tables.php' where the 'ma[]' POST parameter is deserialized.
- Record
CVE-2023-40619- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-502
- Updated
- 2026-11-02
CVE List No score
phpPgAdmin 7.14.4 and earlier is vulnerable to deserialization of untrusted data which may lead to remote code execution because user-controlled data is directly passed to the PHP 'unserialize()' function in multiple places. An example is the functionality to manage tables in 'tables.php' where the 'ma[]' POST parameter is deserialized.
- Record
CVE-2023-40619- Updated
- 2026-11-02
EUVDEUVD-2023-45175 No score
phpPgAdmin 7.14.4 and earlier is vulnerable to deserialization of untrusted data which may lead to remote code execution because user-controlled data is directly passed to the PHP 'unserialize()' function in multiple places. An example is the functionality to manage tables in 'tables.php' where the 'ma[]' POST parameter is deserialized.
- Record
EUVD-2023-45175- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-r8pf-p598-jhpm
9.8
phpPgAdmin 7.14.4 and earlier is vulnerable to deserialization of untrusted data which may lead...
phpPgAdmin 7.14.4 and earlier is vulnerable to deserialization of untrusted data which may lead to remote code execution because user-controlled data is directly passed to the PHP 'unserialize()' function in multiple places. An example is the functionality to manage tables in 'tables.php' where the 'ma[]' POST parameter is deserialized.
- Record
GHSA-r8pf-p598-jhpm- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-502
- Updated
- 2026-11-02
OSV
9.8
phpPgAdmin 7.14.4 and earlier is vulnerable to deserialization of untrusted data which may lead to remote code execution because user-controlled data is directly passed to the PHP 'unserialize()' function in multiple places. An example is the functionality to manage tables in 'tables.php' where the 'ma[]' POST parameter is deserialized.
- Record
CVE-2023-40619- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-40619
9.8
phpPgAdmin 7.14.4 and earlier is vulnerable to deserialization of untrusted data which may lead to remote code execution because user-controlled data is directly passed to the PHP 'unserialize()' function in multiple places. An example is the functionality to manage tables in 'tables.php' where the 'ma[]' POST parameter is deserialized.
- Record
DEBIAN-CVE-2023-40619- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-40619
9.8
phpPgAdmin 7.14.4 and earlier is vulnerable to deserialization of untrusted data which may lead to remote code execution because user-controlled data is directly passed to the PHP 'unserialize()' function in multiple places. An example is the functionality to manage tables in 'tables.php' where the 'ma[]' POST parameter is deserialized.
- Record
UBUNTU-CVE-2023-40619- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:13400-1 No score
phpPgAdmin-7.14.6-1.1 on GA media
These are all security issues fixed in the phpPgAdmin-7.14.6-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:13400-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
phppgadminDebian:13 |
before 7.14.7+dfsg-1 | 7.14.7+dfsg-1 |
phppgadminDebian:14 |
before 7.14.7+dfsg-1 | 7.14.7+dfsg-1 |
phppgadminDebian:10 |
before 5.1+ds-4+deb10u1, plus listed versions 5.1+ds-4 |
5.1+ds-4+deb10u1 |
phppgadminUbuntu:16.04:LTS |
All versions, plus listed versions 5.1+ds-15.1+ds-1ubuntu1 |
None known |
phppgadminUbuntu:18.04:LTS |
All versions, plus listed versions 5.1+ds-25.1+ds-3 |
None known |
phppgadminUbuntu:20.04:LTS |
All versions, plus listed versions 5.1+ds-47.12.0+ds-27.12.0+ds-37.12.1+dfsg-1 |
None known |
phppgadminUbuntu:22.04:LTS |
All versions, plus listed versions 7.13.0+dfsg-2 |
None known |
phppgadminUbuntu:24.04:LTS |
All versions, plus listed versions 7.13.0+dfsg-27.13.0+dfsg-37.14.7+dfsg-1 |
None known |
phppgadminUbuntu:25.10 |
All versions, plus listed versions 7.14.7+dfsg-1 |
None known |
phppgadminUbuntu:26.10 |
All versions, plus listed versions 7.14.7+dfsg-1build17.14.8+dfsg-1 |
None known |
phppgadminUbuntu:26.04:LTS |
All versions, plus listed versions 7.14.7+dfsg-17.14.7+dfsg-1build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-40619 is a critical vulnerability (CVSS 9.8) in Phppgadmin Project Phppgadmin, published September 20, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.32%, the 71st percentile. Fixed in phppgadmin 7.14.7+dfsg-1.
References
github.com/dub-flow/vulnerability-research/tree/main/CVE-2023-40619
lists.debian.org/debian-lts-announce/2023/11/msg00000.html
nvd.nist.gov/vuln/detail/CVE-2023-40619
github.com/advisories/GHSA-r8pf-p598-jhpm
security-tracker.debian.org/tracker/CVE-2023-40619
ubuntu.com/security/CVE-2023-40619
cve.org/CVERecord?id=CVE-2023-40619
suse.com/security/cve/CVE-2023-40619