CVE-2023-40826
pf4j vulnerable to remote code execution via the zippluginPath parameter
An issue in pf4j pf4j v.3.9.0 and before allows a remote attacker to obtain sensitive information and execute arbitrary code via the zippluginPath parameter.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
An issue in pf4j pf4j v.3.9.0 and before allows a remote attacker to obtain sensitive information and execute arbitrary code via the zippluginPath parameter.
- Record
CVE-2023-40826- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
CVE List No score
An issue in pf4j pf4j v.3.9.0 and before allows a remote attacker to obtain sensitive information and execute arbitrary code via the zippluginPath parameter.
- Record
CVE-2023-40826- Updated
- 2026-11-02
EUVDEUVD-2023-2197 No score
An issue in pf4j pf4j v.3.9.0 and before allows a remote attacker to obtain sensitive information and execute arbitrary code via the zippluginPath parameter.
- Record
EUVD-2023-2197- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3r28-rgp9-qgv4
7.5
pf4j vulnerable to remote code execution via the zippluginPath parameter
An issue in pf4j pf4j v.3.9.0 and before allows a remote attacker to obtain sensitive information and execute arbitrary code via the zippluginPath parameter.
- Record
GHSA-3r28-rgp9-qgv4- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-22, CWE-94
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-40826
7.5
An issue in pf4j pf4j v.3.9.0 and before allows a remote attacker to obtain sensitive information and execute arbitrary code via the zippluginPath parameter.
- Record
DEBIAN-CVE-2023-40826- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVGHSA-3r28-rgp9-qgv4
7.5
pf4j vulnerable to remote code execution via the zippluginPath parameter
An issue in pf4j pf4j v.3.9.0 and before allows a remote attacker to obtain sensitive information and execute arbitrary code via the zippluginPath parameter.
- Record
GHSA-3r28-rgp9-qgv4- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-22, CWE-94
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-40826
7.5
An issue in pf4j pf4j v.3.9.0 and before allows a remote attacker to obtain sensitive information and execute arbitrary code via the zippluginPath parameter.
- Record
UBUNTU-CVE-2023-40826- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSV No score
An issue in pf4j pf4j v.3.9.0 and before allows a remote attacker to obtain sensitive information and execute arbitrary code via the zippluginPath parameter.
- Record
CVE-2023-40826- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.pf4j:pf4jMaven |
through 3.9.0 | None known |
libpf4j-javaDebian:12 |
All versions, plus listed versions 3.10.0+dfsg-13.12.0+dfsg-13.13.0+dfsg-13.13.0+dfsg-23.15.0+dfsg-1 Show 4 moreShow less3.15.0+dfsg-23.8.0+dfsg-23.9.0+dfsg-13.9.0+dfsg-2 |
None known |
libpf4j-javaDebian:13 |
before 3.9.0+dfsg-2 | 3.9.0+dfsg-2 |
libpf4j-javaDebian:14 |
before 3.9.0+dfsg-2 | 3.9.0+dfsg-2 |
org.pf4j:pf4jMaven |
through 3.9.0, plus listed versions 2.0.02.1.02.2.02.3.02.4.0 Show 13 moreShow less2.5.02.6.03.0.13.1.03.2.03.3.03.3.13.4.03.4.13.5.03.6.03.7.03.8.0 |
None known |
libpf4j-javaUbuntu:22.04:LTS |
All versions, plus listed versions 3.6.0+dfsg-23.6.0+dfsg-3 |
None known |
libpf4j-javaUbuntu:24.04:LTS |
All versions, plus listed versions 3.9.0+dfsg-23.10.0+dfsg-1 |
None known |
libpf4j-javaUbuntu:25.10 |
All versions, plus listed versions 3.12.0+dfsg-1 |
None known |
libpf4j-javaUbuntu:26.10 |
All versions, plus listed versions 3.13.0+dfsg-23.15.0+dfsg-13.15.0+dfsg-2 |
None known |
libpf4j-javaUbuntu:26.04:LTS |
All versions, plus listed versions 3.12.0+dfsg-13.13.0+dfsg-13.13.0+dfsg-1ubuntu13.13.0+dfsg-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-40826 is a high vulnerability (CVSS 7.5) in Pf4j Project Pf4j, published August 28, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.37%, the 72nd percentile. Fixed in libpf4j-java 3.9.0+dfsg-2.
References
github.com/pf4j/pf4j/issues/536
nvd.nist.gov/vuln/detail/CVE-2023-40826
github.com/advisories/GHSA-3r28-rgp9-qgv4
github.com/CVEProject/cvelistV5/tree/main/cves/2023/40xxx/CVE-2023-40826.json
security-tracker.debian.org/tracker/CVE-2023-40826
github.com/pf4j/pf4j
ubuntu.com/security/CVE-2023-40826
cve.org/CVERecord?id=CVE-2023-40826