CVE-2023-4125
Weak Password Requirements in answerdev/answer
Weak Password Requirements in GitHub repository answerdev/answer prior to v1.1.0.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.8
Weak Password Requirements in answerdev/answer
Weak Password Requirements in GitHub repository answerdev/answer prior to v1.1.0.
- Record
CVE-2023-4125- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-521
- Updated
- 2026-11-02
EUVDEUVD-2023-2311
8.8
Weak Password Requirements in GitHub repository answerdev/answer prior to v1.1.0.
- Record
EUVD-2023-2311- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-j63x-f657-2m9g
8.8
Answer has Weak Password Requirements
Weak Password Requirements in GitHub repository answerdev/answer prior to v1.1.0.
- Record
GHSA-j63x-f657-2m9g- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-521
- Updated
- 2026-11-02
NVD
8.8
Weak Password Requirements in GitHub repository answerdev/answer prior to v1.1.0.
- Record
CVE-2023-4125- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-521
- Updated
- 2026-11-02
OSV
8.8
Weak Password Requirements in answerdev/answer
Weak Password Requirements in GitHub repository answerdev/answer prior to v1.1.0.
- Record
CVE-2023-4125- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-521
- Updated
- 2026-11-02
OSVGHSA-j63x-f657-2m9g
8.8
Answer has Weak Password Requirements
Weak Password Requirements in GitHub repository answerdev/answer prior to v1.1.0.
- Record
GHSA-j63x-f657-2m9g- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-521
- Updated
- 2026-11-02
OSVGO-2023-2001 No score
Answer has Weak Password Requirements in github.com/answerdev/answer
Answer has Weak Password Requirements in github.com/answerdev/answer
- Record
GO-2023-2001- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/answerdev/answerGo |
before 1.1.0 | 1.1.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-4125 is a high vulnerability (CVSS 8.8) in Answer, published August 3, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.88%, the 59th percentile. Fixed in github.com/answerdev/answer 1.1.0.
References
huntr.dev/bounties/85bfd18f-8d3b-4154-8b7b-1f8fcf704e28
github.com/answerdev/answer/commit/7d23b17cdbbefcd2e7b5c3150f0b5ec908dc835f
nvd.nist.gov/vuln/detail/CVE-2023-4125
github.com/advisories/GHSA-j63x-f657-2m9g
github.com/CVEProject/cvelistV5/tree/main/cves/2023/4xxx/CVE-2023-4125.json
github.com/answerdev/answer