CVE-2023-4126
Insufficient Session Expiration in answerdev/answer
Insufficient Session Expiration in GitHub repository answerdev/answer prior to v1.1.0.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- High
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
4.1
Insufficient Session Expiration in answerdev/answer
Insufficient Session Expiration in GitHub repository answerdev/answer prior to v1.1.0.
- Record
CVE-2023-4126- CVSS 3.0
- 4.1 Medium
CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-613
- Updated
- 2026-11-02
EUVDEUVD-2023-2293
4.1
Insufficient Session Expiration in GitHub repository answerdev/answer prior to v1.1.0.
- Record
EUVD-2023-2293- CVSS 3.0
- 4.1 Medium
CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-ggcf-hwxp-rc77
4.1
Answer Insufficient Session Expiration vulnerability
Insufficient Session Expiration in GitHub repository answerdev/answer prior to v1.1.0.
- Record
GHSA-ggcf-hwxp-rc77- CVSS 3.0
- 4.1 Medium
CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-613
- Updated
- 2026-11-02
NVD
8.8
Insufficient Session Expiration in GitHub repository answerdev/answer prior to v1.1.0.
- Record
CVE-2023-4126- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 3.0
- 4.1 Medium
CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-613
- Updated
- 2026-11-02
OSV
4.1
Insufficient Session Expiration in answerdev/answer
Insufficient Session Expiration in GitHub repository answerdev/answer prior to v1.1.0.
- Record
CVE-2023-4126- CVSS 3.0
- 4.1 Medium
CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-613
- Updated
- 2026-11-02
OSVGHSA-ggcf-hwxp-rc77
4.1
Answer Insufficient Session Expiration vulnerability
Insufficient Session Expiration in GitHub repository answerdev/answer prior to v1.1.0.
- Record
GHSA-ggcf-hwxp-rc77- CVSS 3.0
- 4.1 Medium
CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-613
- Updated
- 2026-11-02
OSVGO-2023-1996 No score
Answer Insufficient Session Expiration vulnerability in github.com/answerdev/answer
Answer Insufficient Session Expiration vulnerability in github.com/answerdev/answer
- Record
GO-2023-1996- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/answerdev/answerGo |
before 1.1.0 | 1.1.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-4126 is a medium vulnerability (CVSS 4.1) in Answer, published August 3, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.57%, the 47th percentile. Fixed in github.com/answerdev/answer 1.1.0.
References
huntr.dev/bounties/7f50bf1c-bcb9-46ca-8cec-211493d280c5
github.com/answerdev/answer/commit/4f468b58d0dea51290bfbdd3e96332b0014c8730
nvd.nist.gov/vuln/detail/CVE-2023-4126
github.com/advisories/GHSA-ggcf-hwxp-rc77
github.com/CVEProject/cvelistV5/tree/main/cves/2023/4xxx/CVE-2023-4126.json
github.com/answerdev/answer