CVE-2023-41592
Froala Editor Cross-site Scripting vulnerability
Froala Editor v4.0.1 to v4.1.1 was discovered to contain a cross-site scripting (XSS) vulnerability.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.4
Froala Editor v4.0.1 to v4.1.1 was discovered to contain a cross-site scripting (XSS) vulnerability.
- Record
CVE-2023-41592- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Froala Editor v4.0.1 to v4.1.1 was discovered to contain a cross-site scripting (XSS) vulnerability.
- Record
CVE-2023-41592- Updated
- 2026-11-02
EUVDEUVD-2023-2529 No score
Froala Editor v4.0.1 to v4.1.1 was discovered to contain a cross-site scripting (XSS) vulnerability.
- Record
EUVD-2023-2529- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-hvpq-7vcc-5hj5
5.4
Froala Editor Cross-site Scripting vulnerability
Froala Editor v4.0.1 to v4.1.1 was discovered to contain a cross-site scripting (XSS) vulnerability.
- Record
GHSA-hvpq-7vcc-5hj5- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-hvpq-7vcc-5hj5
5.4
Froala Editor Cross-site Scripting vulnerability
Froala Editor v4.0.1 to v4.1.1 was discovered to contain a cross-site scripting (XSS) vulnerability.
- Record
GHSA-hvpq-7vcc-5hj5- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV No score
Froala Editor v4.0.1 to v4.1.1 was discovered to contain a cross-site scripting (XSS) vulnerability.
- Record
CVE-2023-41592- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
froala/wysiwyg-editorPackagist |
4.0.1 to 4.1.3 | 4.1.4 |
froala-editornpm |
4.0.1 to 4.1.3 | 4.1.4 |
froala/wysiwyg-editorPackagist |
4.0.1 up to 4.1.4, plus listed versions v4.0.1v4.0.10v4.0.11v4.0.12v4.0.13 Show 18 moreShow lessv4.0.14v4.0.15v4.0.16v4.0.17v4.0.18v4.0.19v4.0.2v4.0.3v4.0.4v4.0.5v4.0.6v4.0.7v4.0.8v4.0.9v4.1.0v4.1.1v4.1.2v4.1.3 |
4.1.4 |
froala-editornpm |
4.0.1 up to 4.1.4 | 4.1.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-41592 is a medium vulnerability (CVSS 5.4) in Froala Editor, published September 14, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.04%, the 64th percentile. Fixed in froala/wysiwyg-editor 4.1.4.
References
owasp.org/Top10/A03_2021-Injection
owasp.org/www-project-top-ten
hacker.soarescorp.com/cve/2023-41592
nvd.nist.gov/vuln/detail/CVE-2023-41592
github.com/froala/wysiwyg-editor/issues/4612
froala.com/wysiwyg-editor/changelog
github.com/advisories/GHSA-hvpq-7vcc-5hj5
github.com/CVEProject/cvelistV5/tree/main/cves/2023/41xxx/CVE-2023-41592.json
github.com/froala/wysiwyg-editor