Every CVE Search/ Get API key

CVE-2023-43364

Searchor CLI's Search vulnerable to Arbitrary Code using Eval

9.8 CriticalPublic exploitFix available

main.py in Searchor before 2.4.2 uses eval on CLI input, which may cause unexpected code execution.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.89%Up 2.8 points since Dec 13, 2023
90%50%10%1%

What each source reports

NVD Score used 9.8

main.py in Searchor before 2.4.2 uses eval on CLI input, which may cause unexpected code execution.

Record
CVE-2023-43364
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-74, CWE-94
Updated
2026-11-02
CVE List 9.8

main.py in Searchor before 2.4.2 uses eval on CLI input, which may cause unexpected code execution.

Record
CVE-2023-43364
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
EUVDEUVD-2023-0236 9.8

main.py in Searchor before 2.4.2 uses eval on CLI input, which may cause unexpected code execution.

Record
EUVD-2023-0236
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-66m2-493m-crh2 9.8

Searchor CLI's Search vulnerable to Arbitrary Code using Eval

An issue in Arjun Sharda's Searchor before version v.2.4.2 allows an attacker to execute arbitrary code via a crafted script to the eval() function in Searchor's src/searchor/main.py file, affecting the search feature in Searchor's CLI (Command Line Interface).

Impact

Versions equal to, or below 2.4.1 are affected.

Patches

Versions above, or equal to 2.4.2 have patched the vulnerability.

References

https://github.com/nikn0laty/Exploit-for-Searchor-2.4.0-Arbitrary-CMD-Injection https://github.com/nexis-nexis/Searchor-2.4.0-POC-Exploit- https://github.com/jonnyzar/POC-Searchor-2.4.2 https://github.com/ArjunSharda/Searchor/pull/130

Record
GHSA-66m2-493m-crh2
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-74, CWE-94
Updated
2026-11-02
OSV 9.8

main.py in Searchor before 2.4.2 uses eval on CLI input, which may cause unexpected code execution.

Record
CVE-2023-43364
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-66m2-493m-crh2 9.8

Searchor CLI's Search vulnerable to Arbitrary Code using Eval

An issue in Arjun Sharda's Searchor before version v.2.4.2 allows an attacker to execute arbitrary code via a crafted script to the eval() function in Searchor's src/searchor/main.py file, affecting the search feature in Searchor's CLI (Command Line Interface).

Impact

Versions equal to, or below 2.4.1 are affected.

Patches

Versions above, or equal to 2.4.2 have patched the vulnerability.

References

https://github.com/nikn0laty/Exploit-for-Searchor-2.4.0-Arbitrary-CMD-Injection https://github.com/nexis-nexis/Searchor-2.4.0-POC-Exploit- https://github.com/jonnyzar/POC-Searchor-2.4.2 https://github.com/ArjunSharda/Searchor/pull/130

Record
GHSA-66m2-493m-crh2
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-74, CWE-94
Updated
2026-11-02
OSVPYSEC-2023-262 9.8

main.py in Searchor before 2.4.2 uses eval on CLI input, which may cause unexpected code execution.

Record
PYSEC-2023-262
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
searchor
PyPI
through 2.4.1
2.4.2
searchor
PyPI
before 2.4.2, plus listed versions
1.0.31.0.41.0.51.1.01.1.1
Show 21 moreShow less
1.2.01.3.01.4.02.0.02.0.12.0.22.1.12.1.22.1.32.1.42.1.52.1.62.2.02.2.12.2.22.2.32.3.02.3.12.3.22.4.02.4.1
2.4.2

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubHerick-Costa/CVE-2023-43364-Searchor-RCE-Exploit2026-06-30
PoC in GitHubIamSaishi/CVE-2023-43364_Exploit2026-09-29
PoC in GitHubdiamorphine666/CVE-2023-433642026-10-30
PoC in GitHublibertycityhacker/CVE-2023-43364-Exploit-CVE2024-04-26

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-43364 is a critical vulnerability (CVSS 9.8) in Arjunsharda Searchor, published September 25, 2023. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 2.89%, the 86th percentile. Fixed in searchor 2.4.2.

References

Show 4 moreShow less
MoveEnter Open