CVE-2023-43795
WPS Server Side Request Forgery in GeoServer
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. The OGC Web Processing Service (WPS) specification is designed to process information from any server using GET and POST requests. This presents the opportunity for Server Side Request Forgery. This vulnerability has been patched in version 2.22.5 and 2.23.2.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
8.6
WPS Server Side Request Forgery in GeoServer
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. The OGC Web Processing Service (WPS) specification is designed to process information from any server using GET and POST requests. This presents the opportunity for Server Side Request Forgery. This vulnerability has been patched in version 2.22.5 and 2.23.2.
- Record
CVE-2023-43795- CVSS 3.1
- 8.6 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L - Weakness
- CWE-918
- Updated
- 2026-11-02
EUVDEUVD-2023-2659
8.6
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. The OGC Web Processing Service (WPS) specification is designed to process information from any server using GET and POST requests. This presents the opportunity for Server Side Request Forgery. This vulnerability has been patched in version 2.22.5 and 2.23.2.
- Record
EUVD-2023-2659- CVSS 3.1
- 8.6 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5pr3-m5hm-9956
8.6
WPS Server Side Request Forgery vulnerability
Summary
The OGC Web Processing Service (WPS) specification is designed to process information from any server using GET and POST requests.
This presents the opportunity for Server Side Request Forgery.
Details
This vulnerability requires:
- The WPS extension to be installed
- The WPS security setting "Disable complex inputs" to be unselected
- Security URL checks to be disabled
Impact
This vulnerability presents the opportunity for Server Side Request Forgery.
Mitigation
The ability to reference an external URL location is defined by the WPS standard Execute operation. This operations is defined by an Industry and International standard and cannot be redefined by the GeoServer application in isolation.
To disable complex remote inputs on GeoServer 2.20.5 and GeoServer 2.21.0:
- Navigate to Security > WPS Security page
- Locate Complex Inputs heading
- Select the check box for Disable loading complex inputs from remote references
Resolution
To allow processing of complex inputs safely in GeoServer 2.22.5 and GeoServer 2.23.2:
- Navigate to Security > URL Checks
- Enable URL Checks are enabled setting
- Check the user manual for examples of how to trust specific locations for your external services.
Processing of complex inputs safely is on by default in GeoServer 2.24.0.
References
- Record
GHSA-5pr3-m5hm-9956- CVSS 3.1
- 8.6 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L - Weakness
- CWE-918
- Updated
- 2026-11-02
NVD
8.6
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. The OGC Web Processing Service (WPS) specification is designed to process information from any server using GET and POST requests. This presents the opportunity for Server Side Request Forgery. This vulnerability has been patched in version 2.22.5 and 2.23.2.
- Record
CVE-2023-43795- CVSS 3.1
- 8.6 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-918
- Updated
- 2026-11-02
OSV
8.6
WPS Server Side Request Forgery in GeoServer
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. The OGC Web Processing Service (WPS) specification is designed to process information from any server using GET and POST requests. This presents the opportunity for Server Side Request Forgery. This vulnerability has been patched in version 2.22.5 and 2.23.2.
- Record
CVE-2023-43795- CVSS 3.1
- 8.6 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L - Weakness
- CWE-918
- Updated
- 2026-11-02
OSVGHSA-5pr3-m5hm-9956
8.6
WPS Server Side Request Forgery vulnerability
Summary
The OGC Web Processing Service (WPS) specification is designed to process information from any server using GET and POST requests.
This presents the opportunity for Server Side Request Forgery.
Details
This vulnerability requires:
- The WPS extension to be installed
- The WPS security setting "Disable complex inputs" to be unselected
- Security URL checks to be disabled
Impact
This vulnerability presents the opportunity for Server Side Request Forgery.
Mitigation
The ability to reference an external URL location is defined by the WPS standard Execute operation. This operations is defined by an Industry and International standard and cannot be redefined by the GeoServer application in isolation.
To disable complex remote inputs on GeoServer 2.20.5 and GeoServer 2.21.0:
- Navigate to Security > WPS Security page
- Locate Complex Inputs heading
- Select the check box for Disable loading complex inputs from remote references
Resolution
To allow processing of complex inputs safely in GeoServer 2.22.5 and GeoServer 2.23.2:
- Navigate to Security > URL Checks
- Enable URL Checks are enabled setting
- Check the user manual for examples of how to trust specific locations for your external services.
Processing of complex inputs safely is on by default in GeoServer 2.24.0.
References
- Record
GHSA-5pr3-m5hm-9956- CVSS 3.1
- 8.6 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L - Weakness
- CWE-918
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.geoserver.extension:gs-wps-coreMaven |
before 2.22.5 | 2.22.5 |
org.geoserver.extension:gs-wps-coreMaven |
2.23.0 up to 2.23.2 | 2.23.2 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Nuclei | GeoServer WPS - Server Side Request Forgery |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, Nuclei, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-43795 is a high vulnerability (CVSS 8.6) in Geoserver, published October 24, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 69.0%, the 99th percentile. Fixed in org.geoserver.extension:gs-wps-core 2.22.5.
References
github.com/geoserver/geoserver/security/advisories/GHSA-5pr3-m5hm-9956
nvd.nist.gov/vuln/detail/CVE-2023-43795
docs.geoserver.org/latest/en/user/security/urlchecks.html
docs.geoserver.org/stable/en/user/services/wps/security.html
github.com/advisories/GHSA-5pr3-m5hm-9956
github.com/CVEProject/cvelistV5/tree/main/cves/2023/43xxx/CVE-2023-43795.json
github.com/geoserver/geoserver