CVE-2023-45196
Adminer and AdminerEvo denial of service via HTTP redirect
Adminer and AdminerEvo allow an unauthenticated remote attacker to cause a denial of service by connecting to an attacker-controlled service that responds with HTTP redirects. The denial of service is subject to PHP configuration limits. Adminer is no longer supported, but this issue was fixed in AdminerEvo version 4.8.4.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
6.9
Adminer and AdminerEvo denial of service via HTTP redirect
Adminer and AdminerEvo allow an unauthenticated remote attacker to cause a denial of service by connecting to an attacker-controlled service that responds with HTTP redirects. The denial of service is subject to PHP configuration limits. Adminer is no longer supported, but this issue was fixed in AdminerEvo version 4.8.4.
- Record
CVE-2023-45196- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/AU:Y - Weakness
- CWE-400
- Updated
- 2026-11-02
EUVDEUVD-2023-49503
6.9
Adminer and AdminerEvo allow an unauthenticated remote attacker to cause a denial of service by connecting to an attacker-controlled service that responds with HTTP redirects. The denial of service is subject to PHP configuration limits. Adminer is no longer supported, but this issue was fixed in AdminerEvo version 4.8.4.
- Record
EUVD-2023-49503- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/AU:Y - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-2fjv-ffr6-wh68
6.9
Adminer and AdminerEvo allow an unauthenticated remote attacker to cause a denial of service by...
Adminer and AdminerEvo allow an unauthenticated remote attacker to cause a denial of service by connecting to an attacker-controlled service that responds with HTTP redirects. The denial of service is subject to PHP configuration limits. Adminer is no longer supported, but this issue was fixed in AdminerEvo version 4.8.4.
- Record
GHSA-2fjv-ffr6-wh68- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:Y/R:X/V:X/RE:X/U:X - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
NVD
6.9
Adminer and AdminerEvo allow an unauthenticated remote attacker to cause a denial of service by connecting to an attacker-controlled service that responds with HTTP redirects. The denial of service is subject to PHP configuration limits. Adminer is no longer supported, but this issue was fixed in AdminerEvo version 4.8.4.
- Record
CVE-2023-45196- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:Y/R:X/V:X/RE:X/U:X - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
OSV
6.9
Adminer and AdminerEvo denial of service via HTTP redirect
Adminer and AdminerEvo allow an unauthenticated remote attacker to cause a denial of service by connecting to an attacker-controlled service that responds with HTTP redirects. The denial of service is subject to PHP configuration limits. Adminer is no longer supported, but this issue was fixed in AdminerEvo version 4.8.4.
- Record
CVE-2023-45196- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/AU:Y - Weakness
- CWE-400
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-45196
7.5
Adminer and AdminerEvo allow an unauthenticated remote attacker to cause a denial of service by connecting to an attacker-controlled service that responds with HTTP redirects. The denial of service is subject to PHP configuration limits. Adminer is no longer supported, but this issue was fixed in AdminerEvo version 4.8.4.
- Record
DEBIAN-CVE-2023-45196- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-45196
6.9
Adminer and AdminerEvo allow an unauthenticated remote attacker to cause a denial of service by connecting to an attacker-controlled service that responds with HTTP redirects. The denial of service is subject to PHP configuration limits. Adminer is no longer supported, but this issue was fixed in AdminerEvo version 4.8.4.
- Record
UBUNTU-CVE-2023-45196- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/AU:Y - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
adminerDebian:12 |
All versions, plus listed versions 4.8.1-14.8.1-24.8.1-45.1.0-15.2.1+dfsg-1 Show 12 moreShow less5.3.0+dfsg-15.4.0+dfsg-15.4.1+dfsg-15.4.2+dfsg-15.4.3+dfsg-15.4.4+dfsg-16.0.0-16.0.1-16.0.2-16.1.0-16.1.1-16.1.2-1 |
None known |
adminerDebian:13 |
before 4.8.1-4 | 4.8.1-4 |
adminerDebian:14 |
before 4.8.1-4 | 4.8.1-4 |
adminerUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 4.2.1-14.2.1-1ubuntu14.2.1-1ubuntu1+esm1 |
None known |
adminerUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 4.3.1-24.5.0-14.6.1-14.6.2-14.6.2-1ubuntu0.1~esm1 |
None known |
adminerUbuntu:Pro:20.04:LTS |
All versions, plus listed versions 4.7.2-14.7.4-14.7.5-14.7.6-14.7.6-1ubuntu0.1~esm1 |
None known |
adminerUbuntu:22.04:LTS |
All versions, plus listed versions 4.7.9-24.8.1-1 |
None known |
adminerUbuntu:24.04:LTS |
All versions, plus listed versions 4.8.1-14.8.1-1ubuntu14.8.1-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, products, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-45196 is a medium vulnerability (CVSS 6.9) in Adminer, published June 24, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.58%, the 48th percentile. Fixed in adminer 4.8.1-4.
References
github.com/adminerevo/adminerevo/pull/102/commits/23e7cdc0a32b3739e13d19ae504be0fe215142b6
nvd.nist.gov/vuln/detail/CVE-2023-45196
github.com/advisories/GHSA-2fjv-ffr6-wh68
github.com/CVEProject/cvelistV5/tree/main/cves/2023/45xxx/CVE-2023-45196.json
github.com/adminerevo/adminerevo
security-tracker.debian.org/tracker/CVE-2023-45196
ubuntu.com/security/CVE-2023-45196
cve.org/CVERecord?id=CVE-2023-45196
github.com/adminerevo/adminerevo/commit/bc44e5f676b3ff249acd97ed9835305469d55bfa