CVE-2023-45278
Yamcs API Directory Traversal vulnerability
Directory Traversal vulnerability in the storage functionality of the API in Yamcs 5.8.6 allows attackers to delete arbitrary files via crafted HTTP DELETE request.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.1
Directory Traversal vulnerability in the storage functionality of the API in Yamcs 5.8.6 allows attackers to delete arbitrary files via crafted HTTP DELETE request.
- Record
CVE-2023-45278- CVSS 3.1
- 9.1 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H - Weakness
- CWE-22
- Updated
- 2026-11-02
CVE List No score
Directory Traversal vulnerability in the storage functionality of the API in Yamcs 5.8.6 allows attackers to delete arbitrary files via crafted HTTP DELETE request.
- Record
CVE-2023-45278- Updated
- 2026-11-02
EUVDEUVD-2023-2638 No score
Directory Traversal vulnerability in the storage functionality of the API in Yamcs 5.8.6 allows attackers to delete arbitrary files via crafted HTTP DELETE request.
- Record
EUVD-2023-2638- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-43fw-536j-w37j
9.1
Yamcs API Directory Traversal vulnerability
Directory Traversal vulnerability in the storage functionality of the API in Yamcs 5.8.6 allows attackers to delete arbitrary files via crafted HTTP DELETE request.
- Record
GHSA-43fw-536j-w37j- CVSS 3.1
- 9.1 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H - Weakness
- CWE-22
- Updated
- 2026-11-02
OSVGHSA-43fw-536j-w37j
9.1
Yamcs API Directory Traversal vulnerability
Directory Traversal vulnerability in the storage functionality of the API in Yamcs 5.8.6 allows attackers to delete arbitrary files via crafted HTTP DELETE request.
- Record
GHSA-43fw-536j-w37j- CVSS 3.1
- 9.1 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H - Weakness
- CWE-22
- Updated
- 2026-11-02
OSV No score
Directory Traversal vulnerability in the storage functionality of the API in Yamcs 5.8.6 allows attackers to delete arbitrary files via crafted HTTP DELETE request.
- Record
CVE-2023-45278- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.yamcs:yamcsMaven |
before 5.8.7 | 5.8.7 |
org.yamcs:yamcsMaven |
before 5.8.7, plus listed versions 0.29.30.30.03.0.03.1.03.1.1 Show 45 moreShow less3.1.23.2.03.2.13.2.23.3.03.3.13.4.03.4.13.4.113.4.23.4.33.4.43.4.53.4.63.4.84.0.04.0.14.1.14.1.24.10.04.10.14.10.24.10.34.10.44.10.54.10.64.10.74.10.84.10.94.2.04.2.14.2.24.3.04.3.14.4.04.4.14.4.24.5.04.6.04.6.14.6.24.6.34.74.7.14.7.3 |
5.8.7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-45278 is a critical vulnerability (CVSS 9.1) in Spaceapplications Yamcs, published October 19, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.83%, the 79th percentile. Fixed in org.yamcs:yamcs 5.8.7.
References
github.com/yamcs/yamcs/compare/yamcs-5.8.6...yamcs-5.8.7
linkedin.com/pulse/yamcs-vulnerability-assessment-visionspace-technologies
nvd.nist.gov/vuln/detail/CVE-2023-45278
github.com/advisories/GHSA-43fw-536j-w37j
github.com/CVEProject/cvelistV5/tree/main/cves/2023/45xxx/CVE-2023-45278.json
github.com/yamcs/yamcs
Left out here: 65 versions. The JSON record has them.