Every CVE Search/ Get API key

CVE-2023-4570

Improper Restriction in NI MeasurementLink Python Services

8.8 HighFix available

An improper access restriction in NI MeasurementLink Python services could allow an attacker on an adjacent network to reach services exposed on localhost. These services were previously thought to be unreachable outside of the node. This affects measurement plug-ins written in Python using version 1.1.0 of the ni-measurementlink-service Python package and all previous versions.

Attack profile

How easy it is to exploit

Attack vector
Adjacent network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.32%Up 0.3 points since Oct 6, 2023
90%50%10%1%

What each source reports

CVE List Score used 8.8

Improper Restriction in NI MeasurementLink Python Services

An improper access restriction in NI MeasurementLink Python services could allow an attacker on an adjacent network to reach services exposed on localhost. These services were previously thought to be unreachable outside of the node. This affects measurement plug-ins written in Python using version 1.1.0 of the ni-measurementlink-service Python package and all previous versions.

Record
CVE-2023-4570
CVSS 3.1
8.8 HighCVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-420
Updated
2026-11-02
EUVDEUVD-2023-2628 8.8

An improper access restriction in NI MeasurementLink Python services could allow an attacker on an adjacent network to reach services exposed on localhost. These services were previously thought to be unreachable outside of the node. This affects measurement plug-ins written in Python using version 1.1.0 of the ni-measurementlink-service Python package and all previous versions.

Record
EUVD-2023-2628
CVSS 3.1
8.8 HighCVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-3f48-9j7q-q2gv 8.8

NI MeasurementLink Python Services Improper Access Restriction vulnerability

Impact

An improper access restriction in NI MeasurementLink Python services could allow an attacker on an adjacent network to reach services exposed on localhost. These services were previously thought to be unreachable outside of the node. This affects measurement plug-ins written in Python using version 1.1.0 of the ni-measurementlink-service Python package and all previous versions.

Patches

Upgrade all Python measurement plug-ins to use ni-measurementlink-service version 1.1.1 or later.

References

Visit ni.com/info and enter the info code cve-2023-4570 for more information.

Record
GHSA-3f48-9j7q-q2gv
CVSS 3.1
8.8 HighCVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-420
Updated
2026-11-02
NVD 8.8

An improper access restriction in NI MeasurementLink Python services could allow an attacker on an adjacent network to reach services exposed on localhost. These services were previously thought to be unreachable outside of the node. This affects measurement plug-ins written in Python using version 1.1.0 of the ni-measurementlink-service Python package and all previous versions.

Record
CVE-2023-4570
CVSS 3.1
8.8 HighCVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-420
Updated
2026-11-02
OSVGHSA-3f48-9j7q-q2gv 8.8

NI MeasurementLink Python Services Improper Access Restriction vulnerability

Impact

An improper access restriction in NI MeasurementLink Python services could allow an attacker on an adjacent network to reach services exposed on localhost. These services were previously thought to be unreachable outside of the node. This affects measurement plug-ins written in Python using version 1.1.0 of the ni-measurementlink-service Python package and all previous versions.

Patches

Upgrade all Python measurement plug-ins to use ni-measurementlink-service version 1.1.1 or later.

References

Visit ni.com/info and enter the info code cve-2023-4570 for more information.

Record
GHSA-3f48-9j7q-q2gv
CVSS 3.1
8.8 HighCVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-420
Updated
2026-11-02
OSVPYSEC-2026-1695 8.8

NI MeasurementLink Python Services Improper Access Restriction vulnerability

Impact

An improper access restriction in NI MeasurementLink Python services could allow an attacker on an adjacent network to reach services exposed on localhost. These services were previously thought to be unreachable outside of the node. This affects measurement plug-ins written in Python using version 1.1.0 of the ni-measurementlink-service Python package and all previous versions.

Patches

Upgrade all Python measurement plug-ins to use ni-measurementlink-service version 1.1.1 or later.

References

Visit ni.com/info and enter the info code cve-2023-4570 for more information.

Record
PYSEC-2026-1695
CVSS 3.1
8.8 HighCVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ni-measurementlink-service
PyPI
before 1.1.1
1.1.1
ni-measurementlink-service
PyPI
1.2.0.dev0 up to 1.2.0
1.2.0
ni-measurementlink-service
PyPI
before 1.1.1, plus listed versions
0.12.00.12.10.12.21.0.01.0.1
Show 4 moreShow less
1.1.01.1.0.dev01.1.0.dev11.1.0.dev2
1.1.1
ni-measurementlink-service
PyPI
1.2.0.dev0 up to 1.2.0, plus listed versions
1.2.0.dev11.2.0.dev21.2.0.dev3
1.2.0
ni-measurementlink-service
PyPI
before 1.1.1, 1.2.0.dev0 up to 1.2.0, plus listed versions
0.12.00.12.10.12.21.0.01.0.1
Show 7 moreShow less
1.1.01.1.0.dev01.1.0.dev11.1.0.dev21.2.0.dev11.2.0.dev21.2.0.dev3
1.1.11.2.0

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-4570 is a high vulnerability (CVSS 8.8) in Ni Measurementlink, published October 5, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.32%, the 24th percentile. Fixed in ni-measurementlink-service 1.1.1.

References

MoveEnter Open