Every CVE Search/ Get API key

CVE-2023-46852

In Memcached before 1.6.22, a buffer overflow exists when processing multiget requests in proxy...

7.5 HighFix available

In Memcached before 1.6.22, a buffer overflow exists when processing multiget requests in proxy mode, if there are many spaces after the "get" substring.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.91%Up 0.8 points since Oct 28, 2023
90%50%10%1%

What each source reports

NVD Score used 7.5

In Memcached before 1.6.22, a buffer overflow exists when processing multiget requests in proxy mode, if there are many spaces after the "get" substring.

Record
CVE-2023-46852
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-120
Updated
2026-11-02
CVE List No score

In Memcached before 1.6.22, a buffer overflow exists when processing multiget requests in proxy mode, if there are many spaces after the "get" substring.

Record
CVE-2023-46852
Updated
2026-11-02
EUVDEUVD-2023-51018 No score

In Memcached before 1.6.22, a buffer overflow exists when processing multiget requests in proxy mode, if there are many spaces after the "get" substring.

Record
EUVD-2023-51018
Updated
2026-11-03
GitHub AdvisoriesGHSA-47qj-rqv2-98f2 7.5

In Memcached before 1.6.22, a buffer overflow exists when processing multiget requests in proxy...

In Memcached before 1.6.22, a buffer overflow exists when processing multiget requests in proxy mode, if there are many spaces after the "get" substring.

Record
GHSA-47qj-rqv2-98f2
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-120
Updated
2026-11-02
OSVAZL-31716 7.5

CVE-2023-46852 affecting package memcached for versions less than 1.6.22-1

In Memcached before 1.6.22, a buffer overflow exists when processing multiget requests in proxy mode, if there are many spaces after the "get" substring.

Record
AZL-31716
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVAZL-34976 7.5

CVE-2023-46852 affecting package memcached for versions less than 1.6.27-1

In Memcached before 1.6.22, a buffer overflow exists when processing multiget requests in proxy mode, if there are many spaces after the "get" substring.

Record
AZL-34976
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 6 moreShow less
OSVDEBIAN-CVE-2023-46852 7.5

In Memcached before 1.6.22, a buffer overflow exists when processing multiget requests in proxy mode, if there are many spaces after the "get" substring.

Record
DEBIAN-CVE-2023-46852
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2023-46852 7.5

In Memcached before 1.6.22, a buffer overflow exists when processing multiget requests in proxy mode, if there are many spaces after the "get" substring.

Record
UBUNTU-CVE-2023-46852
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVBIT-memcached-2023-46852 No score

In Memcached before 1.6.22, a buffer overflow exists when processing multiget requests in proxy mode, if there are many spaces after the "get" substring.

Record
BIT-memcached-2023-46852
Updated
2026-11-02
OSV No score

In Memcached before 1.6.22, a buffer overflow exists when processing multiget requests in proxy mode, if there are many spaces after the "get" substring.

Record
CVE-2023-46852
Updated
2026-11-02
OSVopenSUSE-SU-2024:13427-1 No score

memcached-1.6.22-1.1 on GA media

These are all security issues fixed in the memcached-1.6.22-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:13427-1
Updated
2026-11-02
OSVUSN-6476-1 No score

memcached vulnerabilities

It was discovered that Memcached incorrectly handled certain multiget requests in proxy mode. A remote attacker could use this issue to cause Memcached to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2023-46852)

It was discovered that Memcached incorrectly handled certain proxy requests in proxy mode. A remote attacker could use this issue to cause Memcached to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2023-46853)

Record
USN-6476-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
memcached
Azure Linux:2
before 1.6.22-1
1.6.22-1
memcached
Azure Linux:3
before 1.6.27-1
1.6.27-1
memcached
Bitnami
before 1.6.22
1.6.22
memcached
Debian:12
before 1.6.18-1+deb12u1, plus listed versions
1.6.18-1
1.6.18-1+deb12u1
memcached
Debian:13
before 1.6.22-1
1.6.22-1
memcached
Debian:14
before 1.6.22-1
1.6.22-1
memcached
Ubuntu:22.04:LTS
before 1.6.14-1ubuntu0.1, plus listed versions
1.6.9+dfsg-1build11.6.12+dfsg-2ubuntu11.6.12+dfsg-31.6.12+dfsg-41.6.13-11.6.14-1
1.6.14-1ubuntu0.1
memcached
Ubuntu:22.04:LTS
From an advisory covering 2 CVEs
before 1.6.14-1ubuntu0.1, plus listed versions
1.6.9+dfsg-1build11.6.12+dfsg-2ubuntu11.6.12+dfsg-31.6.12+dfsg-41.6.13-11.6.14-1
1.6.14-1ubuntu0.1
memcached
openSUSE:Tumbleweed
From an advisory covering 2 CVEs
before 1.6.22-1.1
1.6.22-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-46852 is a high vulnerability (CVSS 7.5) in Memcached, published October 27, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.91%, the 60th percentile. Fixed in memcached 1.6.22-1.

References

Show 6 moreShow less
MoveEnter Open