Every CVE Search/ Get API key

CVE-2023-49438

Open redirect vulnerability in Flask-Security-Too

6.1 MediumPublic exploitFix available

An open redirect vulnerability in the python package Flask-Security-Too <=5.3.2 allows attackers to redirect unsuspecting users to malicious sites via a crafted URL by abusing the ?next parameter on the /login and /register routes.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.08%Up 1.0 points since Dec 27, 2023
90%50%10%1%

What each source reports

NVD Score used 6.1

An open redirect vulnerability in the python package Flask-Security-Too <=5.3.2 allows attackers to redirect unsuspecting users to malicious sites via a crafted URL by abusing the ?next parameter on the /login and /register routes.

Record
CVE-2023-49438
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-601
Updated
2026-11-02
CVE List No score

An open redirect vulnerability in the python package Flask-Security-Too <=5.3.2 allows attackers to redirect unsuspecting users to malicious sites via a crafted URL by abusing the ?next parameter on the /login and /register routes.

Record
CVE-2023-49438
Updated
2026-11-02
EUVDEUVD-2023-0079 No score

An open redirect vulnerability in the python package Flask-Security-Too <=5.3.2 allows attackers to redirect unsuspecting users to malicious sites via a crafted URL by abusing the ?next parameter on the /login and /register routes.

Record
EUVD-2023-0079
Updated
2026-11-02
GitHub AdvisoriesGHSA-672h-6x89-76m5 5.3

Open redirect vulnerability in Flask-Security-Too

An open redirect vulnerability in the python package Flask-Security-Too <=5.3.2 allows attackers to redirect unsuspecting users to malicious sites via a crafted URL by abusing the ?next parameter on the /login and /register routes.

Flask-Security-Too contains logic to validate that the URL specified within the next parameter is either relative or has the same network location as the requesting URL in an attempt to prevent open redirections. Previously known examples that bypassed the validation logic such as https://example/login?next=\\\\\\github.com were patched in version 4.1.0

However, examples such as https://example/login?next=/\\github.com and https://example/login?next=\\/github.com were discovered due to how web browsers normalize slashes in URLs, which makes the package vulnerable through version <=5.3.2

Additionally, with Werkzeug >=2.1.0 the autocorrect_location_header configuration was changed to False - which means that location headers in redirects are relative by default. Thus, this issue may impact applications that were previously not impacted, if they are using Werkzeug >=2.1.0 as the WSGI layer.

Record
GHSA-672h-6x89-76m5
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-601
Updated
2026-11-02
OSVGHSA-672h-6x89-76m5 5.3

Open redirect vulnerability in Flask-Security-Too

An open redirect vulnerability in the python package Flask-Security-Too <=5.3.2 allows attackers to redirect unsuspecting users to malicious sites via a crafted URL by abusing the ?next parameter on the /login and /register routes.

Flask-Security-Too contains logic to validate that the URL specified within the next parameter is either relative or has the same network location as the requesting URL in an attempt to prevent open redirections. Previously known examples that bypassed the validation logic such as https://example/login?next=\\\\\\github.com were patched in version 4.1.0

However, examples such as https://example/login?next=/\\github.com and https://example/login?next=\\/github.com were discovered due to how web browsers normalize slashes in URLs, which makes the package vulnerable through version <=5.3.2

Additionally, with Werkzeug >=2.1.0 the autocorrect_location_header configuration was changed to False - which means that location headers in redirects are relative by default. Thus, this issue may impact applications that were previously not impacted, if they are using Werkzeug >=2.1.0 as the WSGI layer.

Record
GHSA-672h-6x89-76m5
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-601
Updated
2026-11-02
OSVPYSEC-2023-248 6.1

An open redirect vulnerability in the python package Flask-Security-Too <=5.3.2 allows attackers to redirect unsuspecting users to malicious sites via a crafted URL by abusing the ?next parameter on the /login and /register routes.

Record
PYSEC-2023-248
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVopenSUSE-SU-2024:13563-1 No score

python310-Flask-Security-Too-5.3.3-1.1 on GA media

These are all security issues fixed in the python310-Flask-Security-Too-5.3.3-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:13563-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:14555-1 No score

python310-Flask-Security-5.5.2-1.1 on GA media

These are all security issues fixed in the python310-Flask-Security-5.5.2-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:14555-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
flask-security-too
PyPI
before 5.3.3
5.3.3
flask-security-too
PyPI
before 5.3.3, plus listed versions
3.0.13.0.1rc13.0.1rc23.0.1rc33.0.2
Show 39 moreShow less
3.1.0rc13.2.03.2.0rc13.2.0rc33.2.0rc43.3.03.3.0rc13.3.0rc23.3.0rc33.3.13.3.23.3.33.4.03.4.13.4.23.4.33.4.43.4.54.0.04.0.0rc14.0.0rc24.0.14.1.04.1.14.1.24.1.34.1.44.1.54.1.65.0.05.0.15.0.25.1.05.1.15.1.25.2.05.3.05.3.15.3.2
5.3.3
python-Flask-Security
openSUSE:Tumbleweed
From an advisory covering 3 CVEs
before 5.5.2-1.1
5.5.2-1.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubbrandon-t-elliott/CVE-2023-494382023-12-14
NucleiPython Flask-Security-Too <=5.3.2 - Open Redirect

History

History
RecordedChangedSources
affected, exploits, facts
first indexedCVE List, EUVD, GitHub Advisories, Nuclei, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-49438 is a medium vulnerability (CVSS 6.1) in Flask-security-too Project Flask-security-too, published December 26, 2023. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.08%, the 65th percentile. Fixed in flask-security-too 5.3.3.

References

Show 5 moreShow less
MoveEnter Open