Every CVE Search/ Get API key

CVE-2023-49465

Libde265 v1.0.14 was discovered to contain a heap-buffer-overflow vulnerability in the...

8.8 HighFix available

Libde265 v1.0.14 was discovered to contain a heap-buffer-overflow vulnerability in the derive_spatial_luma_vector_prediction function at motion.cc.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.80%Up 0.8 points since Dec 8, 2023
90%50%10%1%

What each source reports

NVD Score used 8.8

Libde265 v1.0.14 was discovered to contain a heap-buffer-overflow vulnerability in the derive_spatial_luma_vector_prediction function at motion.cc.

Record
CVE-2023-49465
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

Libde265 v1.0.14 was discovered to contain a heap-buffer-overflow vulnerability in the derive_spatial_luma_vector_prediction function at motion.cc.

Record
CVE-2023-49465
Updated
2026-11-02
EUVDEUVD-2023-53426 No score

Libde265 v1.0.14 was discovered to contain a heap-buffer-overflow vulnerability in the derive_spatial_luma_vector_prediction function at motion.cc.

Record
EUVD-2023-53426
Updated
2026-11-03
GitHub AdvisoriesGHSA-xxjf-hhmr-jhmq 8.8

Libde265 v1.0.14 was discovered to contain a heap-buffer-overflow vulnerability in the...

Libde265 v1.0.14 was discovered to contain a heap-buffer-overflow vulnerability in the derive_spatial_luma_vector_prediction function at motion.cc.

Record
GHSA-xxjf-hhmr-jhmq
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-787
Updated
2026-11-02
OSVALPINE-CVE-2023-49465 8.8

Libde265 v1.0.14 was discovered to contain a heap-buffer-overflow vulnerability in the derive_spatial_luma_vector_prediction function at motion.cc.

Record
ALPINE-CVE-2023-49465
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2023-49465 8.8

Libde265 v1.0.14 was discovered to contain a heap-buffer-overflow vulnerability in the derive_spatial_luma_vector_prediction function at motion.cc.

Record
DEBIAN-CVE-2023-49465
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2023-49465 8.8

Libde265 v1.0.14 was discovered to contain a heap-buffer-overflow vulnerability in the derive_spatial_luma_vector_prediction function at motion.cc.

Record
UBUNTU-CVE-2023-49465
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV No score

Libde265 v1.0.14 was discovered to contain a heap-buffer-overflow vulnerability in the derive_spatial_luma_vector_prediction function at motion.cc.

Record
CVE-2023-49465
Updated
2026-11-02
OSVUSN-6677-1 No score

libde265 vulnerabilities

It was discovered that libde265 could be made to dereference invalid memory. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 20.04 LTS and Ubuntu 22.04 LTS. (CVE-2023-27102)

It was discovered that libde265 could be made to write out of bounds. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, and Ubuntu 22.04 LTS. (CVE-2023-27103)

It was discovered that libde265 could be made to write out of bounds. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2023-43887, CVE-2023-47471, CVE-2023-49465, CVE-2023-49467, CVE-2023-49468)

Record
USN-6677-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libde265
Alpine:v3.16
before 1.0.15-r0
1.0.15-r0
libde265
Alpine:v3.17
before 1.0.15-r0
1.0.15-r0
libde265
Alpine:v3.18
before 1.0.15-r0
1.0.15-r0
libde265
Alpine:v3.19
before 1.0.15-r0
1.0.15-r0
libde265
Alpine:v3.20
before 1.0.15-r0
1.0.15-r0
libde265
Alpine:v3.21
before 1.0.15-r0
1.0.15-r0
libde265
Alpine:v3.22
before 1.0.15-r0
1.0.15-r0
libde265
Alpine:v3.23
before 1.0.15-r0
1.0.15-r0
libde265
Alpine:v3.24
before 1.0.15-r0
1.0.15-r0
libde265
Debian:12
before 1.0.11-1+deb12u2, plus listed versions
1.0.11-11.0.11-1+deb12u1
1.0.11-1+deb12u2
Show 11 moreShow less
Affected packages
PackageAffectedFixed
libde265
Debian:13
before 1.0.15-1
1.0.15-1
libde265
Debian:14
before 1.0.15-1
1.0.15-1
libde265
Debian:10
From an advisory covering 3 CVEs
before 1.0.11-0+deb10u6, plus listed versions
1.0.11-0+deb10u41.0.11-0+deb10u51.0.3-11.0.3-1+deb10u11.0.3-1+deb10u2
Show 7 moreShow less
1.0.3-1+deb10u31.0.4-11.0.7-11.0.8-11.0.8-1.11.0.9-11.0.9-1.1
1.0.11-0+deb10u6
libde265
Ubuntu:Pro:16.04:LTS
before 1.0.2-2ubuntu0.16.04.1~esm4, plus listed versions
1.0.2-1build11.0.2-21.0.2-2ubuntu0.16.04.1~esm11.0.2-2ubuntu0.16.04.1~esm21.0.2-2ubuntu0.16.04.1~esm3
1.0.2-2ubuntu0.16.04.1~esm4
libde265
Ubuntu:Pro:18.04:LTS
before 1.0.2-2ubuntu0.18.04.1~esm4, plus listed versions
1.0.2-2build11.0.2-2ubuntu0.18.04.1~esm11.0.2-2ubuntu0.18.04.1~esm21.0.2-2ubuntu0.18.04.1~esm3
1.0.2-2ubuntu0.18.04.1~esm4
libde265
Ubuntu:20.04:LTS
before 1.0.4-1ubuntu0.4, plus listed versions
1.0.3-1build11.0.4-11.0.4-1build11.0.4-1ubuntu0.11.0.4-1ubuntu0.21.0.4-1ubuntu0.3
1.0.4-1ubuntu0.4
libde265
Ubuntu:22.04:LTS
before 1.0.8-1ubuntu0.3, plus listed versions
1.0.8-11.0.8-1ubuntu0.11.0.8-1ubuntu0.2
1.0.8-1ubuntu0.3
libde265
Ubuntu:Pro:16.04:LTS
From an advisory covering 7 CVEs
before 1.0.2-2ubuntu0.16.04.1~esm4, plus listed versions
1.0.2-1build11.0.2-21.0.2-2ubuntu0.16.04.1~esm11.0.2-2ubuntu0.16.04.1~esm21.0.2-2ubuntu0.16.04.1~esm3
1.0.2-2ubuntu0.16.04.1~esm4
libde265
Ubuntu:Pro:18.04:LTS
From an advisory covering 7 CVEs
before 1.0.2-2ubuntu0.18.04.1~esm4, plus listed versions
1.0.2-2build11.0.2-2ubuntu0.18.04.1~esm11.0.2-2ubuntu0.18.04.1~esm21.0.2-2ubuntu0.18.04.1~esm3
1.0.2-2ubuntu0.18.04.1~esm4
libde265
Ubuntu:20.04:LTS
From an advisory covering 7 CVEs
before 1.0.4-1ubuntu0.4, plus listed versions
1.0.3-1build11.0.4-11.0.4-1build11.0.4-1ubuntu0.11.0.4-1ubuntu0.21.0.4-1ubuntu0.3
1.0.4-1ubuntu0.4
libde265
Ubuntu:22.04:LTS
From an advisory covering 7 CVEs
before 1.0.8-1ubuntu0.3, plus listed versions
1.0.8-11.0.8-1ubuntu0.11.0.8-1ubuntu0.2
1.0.8-1ubuntu0.3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-49465 is a high vulnerability (CVSS 8.8) in Struktur Libde265, published December 7, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.80%, the 56th percentile. Fixed in libde265 1.0.15-r0.

References

Show 10 moreShow less
MoveEnter Open