CVE-2023-50254
Deepin Reader RCE vulnerability due to a design flaw
Deepin Linux's default document reader deepin-reader software suffers from a serious vulnerability in versions prior to 6.0.7 due to a design flaw that leads to remote command execution via crafted docx document. This is a file overwrite vulnerability. Remote code execution (RCE) can be achieved by overwriting files like .bash_rc, .bash_login, etc. RCE will be triggered when the user opens the terminal. Version 6.0.7 contains a patch for the issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
9.3
Deepin Reader RCE vulnerability due to a design flaw
Deepin Linux's default document reader deepin-reader software suffers from a serious vulnerability in versions prior to 6.0.7 due to a design flaw that leads to remote command execution via crafted docx document. This is a file overwrite vulnerability. Remote code execution (RCE) can be achieved by overwriting files like .bash_rc, .bash_login, etc. RCE will be triggered when the user opens the terminal. Version 6.0.7 contains a patch for the issue.
- Record
CVE-2023-50254- CVSS 3.1
- 9.3 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:H - Weakness
- CWE-27, CWE-22
- Updated
- 2026-11-02
EUVDEUVD-2023-55069
9.3
Deepin Linux's default document reader deepin-reader software suffers from a serious vulnerability in versions prior to 6.0.7 due to a design flaw that leads to remote command execution via crafted docx document. This is a file overwrite vulnerability. Remote code execution (RCE) can be achieved by overwriting files like .bash_rc, .bash_login, etc. RCE will be triggered when the user opens the terminal. Version 6.0.7 contains a patch for the issue.
- Record
EUVD-2023-55069- CVSS 3.1
- 9.3 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:H - Updated
- 2026-11-03
NVD
9.3
Deepin Linux's default document reader deepin-reader software suffers from a serious vulnerability in versions prior to 6.0.7 due to a design flaw that leads to remote command execution via crafted docx document. This is a file overwrite vulnerability. Remote code execution (RCE) can be achieved by overwriting files like .bash_rc, .bash_login, etc. RCE will be triggered when the user opens the terminal. Version 6.0.7 contains a patch for the issue.
- Record
CVE-2023-50254- CVSS 3.1
- 9.3 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:H - CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-22, CWE-27
- Updated
- 2026-11-02
OSV
9.3
Deepin Reader RCE vulnerability due to a design flaw
Deepin Linux's default document reader deepin-reader software suffers from a serious vulnerability in versions prior to 6.0.7 due to a design flaw that leads to remote command execution via crafted docx document. This is a file overwrite vulnerability. Remote code execution (RCE) can be achieved by overwriting files like .bash_rc, .bash_login, etc. RCE will be triggered when the user opens the terminal. Version 6.0.7 contains a patch for the issue.
- Record
CVE-2023-50254- CVSS 3.1
- 9.3 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:H - Weakness
- CWE-22, CWE-27
- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:13536-1 No score
deepin-reader-5.10.23-2.1 on GA media
These are all security issues fixed in the deepin-reader-5.10.23-2.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:13536-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
deepin-readeropenSUSE:Tumbleweed |
before 5.10.23-2.1 | 5.10.23-2.1 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | febinrev/deepin-linux_reader_RCE-exploit | 2023-12-22 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, published | EUVD | |
| first indexed | CVE List, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-50254 is a critical vulnerability (CVSS 9.3) in Deepin Reader, published December 22, 2023. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 2.12%, the 81st percentile. Fixed in deepin-reader 5.10.23-2.1.
References
github.com/linuxdeepin/developer-center/security/advisories/GHSA-q9jr-726g-9495
github.com/linuxdeepin/deepin-reader/commit/4db7a079fb7bd77257b1b9208a7ab26aade8fe04
github.com/linuxdeepin/deepin-reader/commit/c192fd20a2fe4003e0581c3164489a89e06420c6
github.com/CVEProject/cvelistV5/tree/main/cves/2023/50xxx/CVE-2023-50254.json
nvd.nist.gov/vuln/detail/CVE-2023-50254
suse.com/security/cve/CVE-2023-50254