Every CVE Search/ Get API key

CVE-2023-50255

Zip Path Traversal in Deepin-Compressor

9.3 CriticalFix available

Deepin-Compressor is the default archive manager of Deepin Linux OS. Prior to 5.12.21, there's a path traversal vulnerability in deepin-compressor that can be exploited to achieve Remote Command Execution on the target system upon opening crafted archives. Users are advised to update to version 5.12.21 which addresses the issue. There are no known workarounds for this vulnerability.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

1.05%Up 1.0 points since Dec 28, 2023
90%50%10%1%

What each source reports

CVE List Score used 9.3

Zip Path Traversal in Deepin-Compressor

Deepin-Compressor is the default archive manager of Deepin Linux OS. Prior to 5.12.21, there's a path traversal vulnerability in deepin-compressor that can be exploited to achieve Remote Command Execution on the target system upon opening crafted archives. Users are advised to update to version 5.12.21 which addresses the issue. There are no known workarounds for this vulnerability.

Record
CVE-2023-50255
CVSS 3.1
9.3 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
Weakness
CWE-23, CWE-26, CWE-22
Updated
2026-11-02
EUVDEUVD-2023-55070 9.3

Deepin-Compressor is the default archive manager of Deepin Linux OS. Prior to 5.12.21, there's a path traversal vulnerability in deepin-compressor that can be exploited to achieve Remote Command Execution on the target system upon opening crafted archives. Users are advised to update to version 5.12.21 which addresses the issue. There are no known workarounds for this vulnerability.

Record
EUVD-2023-55070
CVSS 3.1
9.3 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
Updated
2026-11-03
NVD 9.3

Deepin-Compressor is the default archive manager of Deepin Linux OS. Prior to 5.12.21, there's a path traversal vulnerability in deepin-compressor that can be exploited to achieve Remote Command Execution on the target system upon opening crafted archives. Users are advised to update to version 5.12.21 which addresses the issue. There are no known workarounds for this vulnerability.

Record
CVE-2023-50255
CVSS 3.1
9.3 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-22, CWE-23, CWE-26
Updated
2026-11-02
OSV 9.3

Zip Path Traversal in Deepin-Compressor

Deepin-Compressor is the default archive manager of Deepin Linux OS. Prior to 5.12.21, there's a path traversal vulnerability in deepin-compressor that can be exploited to achieve Remote Command Execution on the target system upon opening crafted archives. Users are advised to update to version 5.12.21 which addresses the issue. There are no known workarounds for this vulnerability.

Record
CVE-2023-50255
CVSS 3.1
9.3 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
Weakness
CWE-22, CWE-23, CWE-26
Updated
2026-11-02
OSVOESA-2026-3506 7.8

deepin-compressor security update

.

Security Fix(es):

Deepin-Compressor is the default archive manager of Deepin Linux OS. Prior to 5.12.21, there's a path traversal vulnerability in deepin-compressor that can be exploited to achieve Remote Command Execution on the target system upon opening crafted archives. Users are advised to update to version 5.12.21 which addresses the issue. There are no known workarounds for this vulnerability. (CVE-2023-50255)

Record
OESA-2026-3506
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVOESA-2026-3507 7.8

deepin-compressor security update

.

Security Fix(es):

Deepin-Compressor is the default archive manager of Deepin Linux OS. Prior to 5.12.21, there's a path traversal vulnerability in deepin-compressor that can be exploited to achieve Remote Command Execution on the target system upon opening crafted archives. Users are advised to update to version 5.12.21 which addresses the issue. There are no known workarounds for this vulnerability. (CVE-2023-50255)

Record
OESA-2026-3507
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVOESA-2026-3508 7.8

deepin-compressor security update

.

Security Fix(es):

Deepin-Compressor is the default archive manager of Deepin Linux OS. Prior to 5.12.21, there's a path traversal vulnerability in deepin-compressor that can be exploited to achieve Remote Command Execution on the target system upon opening crafted archives. Users are advised to update to version 5.12.21 which addresses the issue. There are no known workarounds for this vulnerability. (CVE-2023-50255)

Record
OESA-2026-3508
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVOESA-2026-3509 7.8

deepin-compressor security update

.

Security Fix(es):

Deepin-Compressor is the default archive manager of Deepin Linux OS. Prior to 5.12.21, there's a path traversal vulnerability in deepin-compressor that can be exploited to achieve Remote Command Execution on the target system upon opening crafted archives. Users are advised to update to version 5.12.21 which addresses the issue. There are no known workarounds for this vulnerability. (CVE-2023-50255)

Record
OESA-2026-3509
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2023:0423-1 No score

Security update for deepin-compressor

This update for deepin-compressor fixes the following issues:

  • CVE-2023-50255: Fix Zip Path Traversal (boo#1218428)
Record
openSUSE-SU-2023:0423-1
Updated
2026-11-02
OSVopenSUSE-SU-2023:0424-1 No score

Security update for deepin-compressor

This update for deepin-compressor fixes the following issues:

  • CVE-2023-50255: Fix Zip Path Traversal (boo#1218428)
Record
openSUSE-SU-2023:0424-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:13541-1 No score

deepin-compressor-5.12.13-2.1 on GA media

These are all security issues fixed in the deepin-compressor-5.12.13-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:13541-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
deepin-compressor
openEuler:20.03-LTS-SP4
before 5.10.11-4.oe2003sp4
5.10.11-4.oe2003sp4
deepin-compressor
openEuler:22.03-LTS-SP4
before 5.12.13-4.oe2203sp4
5.12.13-4.oe2203sp4
deepin-compressor
openEuler:24.03-LTS-SP1
before 5.12.13-4.oe2403sp1
5.12.13-4.oe2403sp1
deepin-compressor
openEuler:24.03-LTS-SP3
before 5.12.13-4.oe2403sp3
5.12.13-4.oe2403sp3
deepin-compressor
SUSE:Package Hub 15 SP5
before 5.12.13-bp155.2.3.1
5.12.13-bp155.2.3.1
deepin-compressor
openSUSE:Leap 15.5
before 5.12.13-bp155.2.3.1
5.12.13-bp155.2.3.1
deepin-compressor
SUSE:Package Hub 15 SP4
before 5.12.2-bp154.2.3.1
5.12.2-bp154.2.3.1
deepin-compressor
openSUSE:Leap 15.4
before 5.12.2-bp154.2.3.1
5.12.2-bp154.2.3.1
deepin-compressor
openSUSE:Tumbleweed
before 5.12.13-2.1
5.12.13-2.1

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-50255 is a critical vulnerability (CVSS 9.3) in Deepin Deepin-compressor, published December 27, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.05%, the 64th percentile. Fixed in deepin-compressor 5.10.11-4.oe2003sp4.

References

Show 6 moreShow less
MoveEnter Open