Every CVE Search/ Get API key

CVE-2023-50980

gf2n.cpp in Crypto++ (aka cryptopp) through 8.9.0 allows attackers to cause a denial of service ...

7.5 HighFix available

gf2n.cpp in Crypto++ (aka cryptopp) through 8.9.0 allows attackers to cause a denial of service (application crash) via DER public-key data for an F(2^m) curve, if the degree of each term in the polynomial is not strictly decreasing.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.83%Up 0.8 points since Dec 18, 2023
90%50%10%1%

What each source reports

NVD Score used 7.5

gf2n.cpp in Crypto++ (aka cryptopp) through 8.9.0 allows attackers to cause a denial of service (application crash) via DER public-key data for an F(2^m) curve, if the degree of each term in the polynomial is not strictly decreasing.

Record
CVE-2023-50980
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
CVE List No score

gf2n.cpp in Crypto++ (aka cryptopp) through 8.9.0 allows attackers to cause a denial of service (application crash) via DER public-key data for an F(2^m) curve, if the degree of each term in the polynomial is not strictly decreasing.

Record
CVE-2023-50980
Updated
2026-11-02
EUVDEUVD-2023-55707 No score

gf2n.cpp in Crypto++ (aka cryptopp) through 8.9.0 allows attackers to cause a denial of service (application crash) via DER public-key data for an F(2^m) curve, if the degree of each term in the polynomial is not strictly decreasing.

Record
EUVD-2023-55707
Updated
2026-11-03
GitHub AdvisoriesGHSA-x2gw-hrqg-xq6x 7.5

gf2n.cpp in Crypto++ (aka cryptopp) through 8.9.0 allows attackers to cause a denial of service ...

gf2n.cpp in Crypto++ (aka cryptopp) through 8.9.0 allows attackers to cause a denial of service (application crash) via DER public-key data for an F(2^m) curve, if the degree of each term in the polynomial is not strictly decreasing.

Record
GHSA-x2gw-hrqg-xq6x
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2023-50980 7.5

gf2n.cpp in Crypto++ (aka cryptopp) through 8.9.0 allows attackers to cause a denial of service (application crash) via DER public-key data for an F(2^m) curve, if the degree of each term in the polynomial is not strictly decreasing.

Record
DEBIAN-CVE-2023-50980
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVJLSEC-2026-1272 7.5

gf2n.cpp in Crypto++ (aka cryptopp) through 8.9.0 allows attackers to cause a denial of service (application crash) via DER public-key data for an F(2^m) curve, if the degree of each term in the polynomial is not strictly decreasing.

Record
JLSEC-2026-1272
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2023-50980 7.5

gf2n.cpp in Crypto++ (aka cryptopp) through 8.9.0 allows attackers to cause a denial of service (application crash) via DER public-key data for an F(2^m) curve, if the degree of each term in the polynomial is not strictly decreasing.

Record
UBUNTU-CVE-2023-50980
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV No score

gf2n.cpp in Crypto++ (aka cryptopp) through 8.9.0 allows attackers to cause a denial of service (application crash) via DER public-key data for an F(2^m) curve, if the degree of each term in the polynomial is not strictly decreasing.

Record
CVE-2023-50980
Updated
2026-11-02
OSVopenSUSE-SU-2024:13528-1 No score

libcryptopp-devel-8.9.0-1.1 on GA media

These are all security issues fixed in the libcryptopp-devel-8.9.0-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:13528-1
Updated
2026-11-02
OSVSUSE-SU-2023:4957-1 No score

Security update for libcryptopp

This update for libcryptopp fixes the following issues:

  • CVE-2023-50980: Fixed DoS via malformed DER public key file (bsc#1218219).
Record
SUSE-SU-2023:4957-1
Updated
2026-11-02
OSVSUSE-SU-2024:0030-1 No score

Security update for libcryptopp

This update for libcryptopp fixes the following issues:

  • CVE-2023-50980: Fixed DoS via malformed DER public key file (bsc#1218219).
Record
SUSE-SU-2024:0030-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libcrypto++
Debian:12
All versions, plus listed versions
8.7.0+git220824-18.8.0-18.8.0-28.9.0-18.9.0-1.18.9.0-1.1~exp18.9.0-28.9.0-3
None known
libcrypto++
Debian:13
before 8.9.0-2
8.9.0-2
libcrypto++
Debian:14
before 8.9.0-2
8.9.0-2
cryptopp_jll
Julia
All versions None known
libcryptopp
openSUSE:Leap 15.4
before 5.6.5-150000.1.9.1
5.6.5-150000.1.9.1
libcryptopp
SUSE:Linux Enterprise Module for Basesystem 15 SP5
before 8.6.0-150400.3.3.1
8.6.0-150400.3.3.1
libcryptopp
SUSE:Linux Enterprise Real Time 15 SP4
before 8.6.0-150400.3.3.1
8.6.0-150400.3.3.1
libcryptopp
openSUSE:Leap 15.4
before 8.6.0-150400.3.3.1
8.6.0-150400.3.3.1
libcryptopp
openSUSE:Leap 15.5
before 8.6.0-150400.3.3.1
8.6.0-150400.3.3.1
libcrypto++
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
5.6.1-65.6.1-6+deb8u1build0.14.04.15.6.1-6+deb8u3build0.14.04.15.6.1-6+deb8u3ubuntu0.1~esm1
None known
Show 9 moreShow less
Affected packages
PackageAffectedFixed
libcrypto++
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
5.6.1-85.6.1-95.6.1-9ubuntu0.15.6.1-9ubuntu0.1+esm1
None known
libcrypto++
Ubuntu:18.04:LTS
All versions, plus listed versions
5.6.4-8
None known
libcrypto++
Ubuntu:20.04:LTS
All versions, plus listed versions
5.6.4-95.6.4-9build1
None known
libcrypto++
Ubuntu:22.04:LTS
All versions, plus listed versions
8.4.0-18.6.0-2ubuntu1
None known
libcrypto++
Ubuntu:24.04:LTS
All versions, plus listed versions
8.8.0-18.9.0-18.9.0-1.18.9.0-1.1build1
None known
libcrypto++
Ubuntu:25.10
All versions, plus listed versions
8.9.0-1.1build18.9.0-2
None known
libcrypto++
Ubuntu:26.10
All versions, plus listed versions
8.9.0-2build18.9.0-3
None known
libcrypto++
Ubuntu:26.04:LTS
All versions, plus listed versions
8.9.0-28.9.0-2build1
None known
libcryptopp
openSUSE:Tumbleweed
before 8.9.0-1.1
8.9.0-1.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-50980 is a high vulnerability (CVSS 7.5) in Cryptopp Crypto\+\+, published December 18, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.83%, the 57th percentile. Fixed in libcrypto++ 8.9.0-2.

References

Show 5 moreShow less
MoveEnter Open