Every CVE Search/ Get API key

CVE-2023-51704

An issue was discovered in MediaWiki before 1.35.14, 1.36.x through 1.39.x before 1.39.6, and 1...

6.1 MediumFix available

An issue was discovered in MediaWiki before 1.35.14, 1.36.x through 1.39.x before 1.39.6, and 1.40.x before 1.40.2. In includes/logging/RightsLogFormatter.php, group-*-member messages can result in XSS on Special:log/rights.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.68%Up 0.6 points since Dec 22, 2023
90%50%10%1%

What each source reports

NVD Score used 6.1

An issue was discovered in MediaWiki before 1.35.14, 1.36.x through 1.39.x before 1.39.6, and 1.40.x before 1.40.2. In includes/logging/RightsLogFormatter.php, group-*-member messages can result in XSS on Special:log/rights.

Record
CVE-2023-51704
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

An issue was discovered in MediaWiki before 1.35.14, 1.36.x through 1.39.x before 1.39.6, and 1.40.x before 1.40.2. In includes/logging/RightsLogFormatter.php, group-*-member messages can result in XSS on Special:log/rights.

Record
CVE-2023-51704
Updated
2026-11-02
EUVDEUVD-2023-56401 No score

An issue was discovered in MediaWiki before 1.35.14, 1.36.x through 1.39.x before 1.39.6, and 1.40.x before 1.40.2. In includes/logging/RightsLogFormatter.php, group-*-member messages can result in XSS on Special:log/rights.

Record
EUVD-2023-56401
Updated
2026-11-02
GitHub AdvisoriesGHSA-pmh9-hwq5-vvpj 6.1

An issue was discovered in MediaWiki before 1.35.14, 1.36.x through 1.39.x before 1.39.6, and 1...

An issue was discovered in MediaWiki before 1.35.14, 1.36.x through 1.39.x before 1.39.6, and 1.40.x before 1.40.2. In includes/logging/RightsLogFormatter.php, group-*-member messages can result in XSS on Special:log/rights.

Record
GHSA-pmh9-hwq5-vvpj
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVDEBIAN-CVE-2023-51704 6.1

An issue was discovered in MediaWiki before 1.35.14, 1.36.x through 1.39.x before 1.39.6, and 1.40.x before 1.40.2. In includes/logging/RightsLogFormatter.php, group-*-member messages can result in XSS on Special:log/rights.

Record
DEBIAN-CVE-2023-51704
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2023-51704 6.1

An issue was discovered in MediaWiki before 1.35.14, 1.36.x through 1.39.x before 1.39.6, and 1.40.x before 1.40.2. In includes/logging/RightsLogFormatter.php, group-*-member messages can result in XSS on Special:log/rights.

Record
UBUNTU-CVE-2023-51704
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVBIT-mediawiki-2023-51704 No score

An issue was discovered in MediaWiki before 1.35.14, 1.36.x through 1.39.x before 1.39.6, and 1.40.x before 1.40.2. In includes/logging/RightsLogFormatter.php, group-*-member messages can result in XSS on Special:log/rights.

Record
BIT-mediawiki-2023-51704
Updated
2026-11-02
OSV No score

An issue was discovered in MediaWiki before 1.35.14, 1.36.x through 1.39.x before 1.39.6, and 1.40.x before 1.40.2. In includes/logging/RightsLogFormatter.php, group-*-member messages can result in XSS on Special:log/rights.

Record
CVE-2023-51704
Updated
2026-11-02
OSVMGASA-2024-0155 No score

Updated mediawiki packages fix security vulnerabilities

Mediawiki v1.40.0 does not validate namespaces used in XML files. Therefore, if the instance administrator allows XML file uploads, a remote attacker with a low-privileged user account can use this exploit to become an administrator by sending a malicious link to the instance administrator. (CVE-2023-3550) An issue was discovered in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. There is XSS in youhavenewmessagesmanyusers and youhavenewmessages i18n messages. This is related to MediaWiki:Youhavenewmessagesfromusers. (CVE-2023-45360) An issue was discovered in DifferenceEngine.php in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. diff-multi-sameuser (aka "X intermediate revisions by the same user not shown") ignores username suppression. This is an information leak. (CVE-2023-45362) An issue was discovered in ApiPageSet.php in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. It allows attackers to cause a denial of service (unbounded loop and RequestTimeoutException) when querying pages redirected to other variants with redirects and converttitles set. (CVE-2023-45363) An issue was discovered in includes/page/Article.php in MediaWiki 1.36.x through 1.39.x before 1.39.5 and 1.40.x before 1.40.1. Deleted revision existence is leaked due to incorrect permissions being checked. This reveals that a given revision ID belonged to the given page title, and its timestamp, both of which are not supposed to be public information. (CVE-2023-45364) An issue was discovered in MediaWiki before 1.35.14, 1.36.x through 1.39.x before 1.39.6, and 1.40.x before 1.40.2. In includes/logging/RightsLogFormatter.php, group-*-member messages can result in XSS on Special:log/rights. (CVE-2023-51704)

Record
MGASA-2024-0155
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mediawiki
Bitnami
before 1.35.14, 1.36.0 up to 1.39.6, 1.40.0 up to 1.40.2
1.35.141.39.61.40.2
mediawiki
Debian:12
before 1:1.39.7-1~deb12u1, plus listed versions
1:1.39.2-11:1.39.4-11:1.39.4-1~deb12u11:1.39.4-21:1.39.5-11:1.39.5-1~deb12u11:1.39.6-1
1:1.39.7-1~deb12u1
mediawiki
Debian:13
before 1:1.39.6-1
1:1.39.6-1
mediawiki
Debian:14
before 1:1.39.6-1
1:1.39.6-1
mediawiki
Debian:10
From an advisory covering 2 CVEs
before 1:1.31.16-1+deb10u8, plus listed versions
1:1.31.10-1~deb10u11:1.31.12-1~deb10u11:1.31.14-1~deb10u11:1.31.16-1+deb10u21:1.31.16-1+deb10u3
Show 16 moreShow less
1:1.31.16-1+deb10u41:1.31.16-1+deb10u51:1.31.16-1+deb10u61:1.31.16-1+deb10u71:1.31.16-1~deb10u11:1.31.2-11:1.31.4-11:1.31.4-1~deb10u11:1.31.5-11:1.31.5-21:1.31.5-31:1.31.6-11:1.31.6-1~deb10u11:1.31.7-11:1.31.7-1~deb10u11:1.31.8-1
1:1.31.16-1+deb10u8
mediawiki
Debian:11
before 1:1.35.13-1+deb11u3, plus listed versions
1:1.35.11-1~deb11u11:1.35.13-1+deb11u21:1.35.13-1~deb11u11:1.35.2-11:1.35.3-1
Show 10 moreShow less
1:1.35.4-11:1.35.4-1+deb11u21:1.35.4-1~deb11u11:1.35.5-11:1.35.5-21:1.35.6-11:1.35.7-11:1.35.8-11:1.35.8-1.11:1.35.8-1~deb11u1
1:1.35.13-1+deb11u3
mediawiki
Mageia:9
From an advisory covering 8 CVEs
before 1.35.14-1.mga9
1.35.14-1.mga9
mediawiki
Ubuntu:18.04:LTS
All versions, plus listed versions
1:1.27.3-11:1.27.4-11:1.27.4-21:1.27.4-3
None known
mediawiki
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
1:1.31.2-1ubuntu11:1.31.5-11:1.31.5-1ubuntu11:1.31.5-21:1.31.5-3
Show 4 moreShow less
1:1.31.5-3ubuntu11:1.31.6-11:1.31.7-11:1.31.7-1ubuntu0.1~esm1
None known
mediawiki
Ubuntu:Pro:22.04:LTS
All versions, plus listed versions
1:1.35.3-11:1.35.4-11:1.35.5-11:1.35.5-1ubuntu11:1.35.5-1ubuntu21:1.35.5-1ubuntu31:1.35.6-11:1.35.6-1ubuntu0.1~esm1
None known

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-51704 is a medium vulnerability (CVSS 6.1) in Mediawiki, published December 22, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.68%, the 52nd percentile. Fixed in mediawiki 1.35.14.

References

Show 8 moreShow less
MoveEnter Open