Every CVE Search/ Get API key

CVE-2023-51792

Buffer Overflow vulnerability in libde265 v1.0.12 allows a local attacker to cause a denial of...

3.3 LowFix available

Buffer Overflow vulnerability in libde265 v1.0.12 allows a local attacker to cause a denial of service via the allocation size exceeding the maximum supported size of 0x10000000000.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
None

Exploit likelihood

0.23%Up 0.2 points since Apr 20, 2024
90%50%10%1%

What each source reports

CVE List Score used 3.3

Buffer Overflow vulnerability in libde265 v1.0.12 allows a local attacker to cause a denial of service via the allocation size exceeding the maximum supported size of 0x10000000000.

Record
CVE-2023-51792
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-121
Updated
2026-11-02
EUVDEUVD-2023-56476 3.3

Buffer Overflow vulnerability in libde265 v1.0.12 allows a local attacker to cause a denial of service via the allocation size exceeding the maximum supported size of 0x10000000000.

Record
EUVD-2023-56476
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-xj57-m8w7-83wf 3.3

Buffer Overflow vulnerability in libde265 v1.0.12 allows a local attacker to cause a denial of...

Buffer Overflow vulnerability in libde265 v1.0.12 allows a local attacker to cause a denial of service via the allocation size exceeding the maximum supported size of 0x10000000000.

Record
GHSA-xj57-m8w7-83wf
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-121
Updated
2026-11-02
NVD 3.3

Buffer Overflow vulnerability in libde265 v1.0.12 allows a local attacker to cause a denial of service via the allocation size exceeding the maximum supported size of 0x10000000000.

Record
CVE-2023-51792
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-121
Updated
2026-11-02
OSV 3.3

Buffer Overflow vulnerability in libde265 v1.0.12 allows a local attacker to cause a denial of service via the allocation size exceeding the maximum supported size of 0x10000000000.

Record
CVE-2023-51792
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2023-51792 3.3

Buffer Overflow vulnerability in libde265 v1.0.12 allows a local attacker to cause a denial of service via the allocation size exceeding the maximum supported size of 0x10000000000.

Record
DEBIAN-CVE-2023-51792
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2023-51792 3.3

Buffer Overflow vulnerability in libde265 v1.0.12 allows a local attacker to cause a denial of service via the allocation size exceeding the maximum supported size of 0x10000000000.

Record
UBUNTU-CVE-2023-51792
CVSS 3.1
3.3 LowCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSVROOT-OS-DEBIAN-11-CVE-2023-51792 No score

CVE-2023-51792 in libde265 - Patched by Root

Root has patched CVE-2023-51792 in the libde265 package for Root:Debian:11. Multiple fixed versions available.

Record
ROOT-OS-DEBIAN-11-CVE-2023-51792
Updated
2026-11-02
OSVROOT-OS-DEBIAN-12-CVE-2023-51792 No score

CVE-2023-51792 in libde265 - Patched by Root

Root has patched CVE-2023-51792 in the libde265 package for Root:Debian:12. Multiple fixed versions available.

Record
ROOT-OS-DEBIAN-12-CVE-2023-51792
Updated
2026-11-02
OSVUSN-6764-1 No score

libde265 vulnerability

It was discovered that libde265 could be made to allocate memory that exceeds the maximum supported size. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly use this issue to cause a denial of service.

Record
USN-6764-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libde265
Debian:12
before 1.0.11-1+deb12u3, plus listed versions
1.0.11-11.0.11-1+deb12u11.0.11-1+deb12u2
1.0.11-1+deb12u3
libde265
Debian:13
before 1.0.13-1
1.0.13-1
libde265
Debian:14
before 1.0.13-1
1.0.13-1
libde265
Ubuntu:Pro:16.04:LTS
before 1.0.2-2ubuntu0.16.04.1~esm5, plus listed versions
1.0.2-1build11.0.2-21.0.2-2ubuntu0.16.04.1~esm11.0.2-2ubuntu0.16.04.1~esm21.0.2-2ubuntu0.16.04.1~esm31.0.2-2ubuntu0.16.04.1~esm4
1.0.2-2ubuntu0.16.04.1~esm5
libde265
Ubuntu:Pro:18.04:LTS
before 1.0.2-2ubuntu0.18.04.1~esm5, plus listed versions
1.0.2-2build11.0.2-2ubuntu0.18.04.1~esm11.0.2-2ubuntu0.18.04.1~esm21.0.2-2ubuntu0.18.04.1~esm31.0.2-2ubuntu0.18.04.1~esm4
1.0.2-2ubuntu0.18.04.1~esm5
libde265
Ubuntu:Pro:20.04:LTS
before 1.0.4-1ubuntu0.4+esm1, plus listed versions
1.0.3-1build11.0.4-11.0.4-1build11.0.4-1ubuntu0.11.0.4-1ubuntu0.21.0.4-1ubuntu0.31.0.4-1ubuntu0.4
1.0.4-1ubuntu0.4+esm1
libde265
Ubuntu:Pro:22.04:LTS
before 1.0.8-1ubuntu0.3+esm1, plus listed versions
1.0.8-11.0.8-1ubuntu0.11.0.8-1ubuntu0.21.0.8-1ubuntu0.3
1.0.8-1ubuntu0.3+esm1

History

History
RecordedChangedSources
affected
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-51792 is a low vulnerability (CVSS 3.3) in Mitre Caldera, published April 19, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.23%, the 14th percentile. Fixed in libde265 1.0.11-1+deb12u3.

References

Show 8 moreShow less
MoveEnter Open