CVE-2023-5214
CVE-2023-5214 - Privilege Escalation in Puppet Bolt
In Puppet Bolt versions prior to 3.27.4, a path to escalate privileges was identified.
Attack profile
How easy it is to exploit
- Attack vector
- Adjacent network
- Complexity
- High
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.5
CVE-2023-5214 - Privilege Escalation in Puppet Bolt
In Puppet Bolt versions prior to 3.27.4, a path to escalate privileges was identified.
- Record
CVE-2023-5214- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:C/C:L/I:H/A:N - Weakness
- CWE-269
- Updated
- 2026-11-02
EUVDEUVD-2023-2616
6.5
In Puppet Bolt versions prior to 3.27.4, a path to escalate privileges was identified.
- Record
EUVD-2023-2616- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:C/C:L/I:H/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-289m-2964-f8q5
9.8
Puppet Bolt privilege escalation vulnerability
In Puppet Bolt versions prior to 3.27.4, a path to escalate privileges was identified.
- Record
GHSA-289m-2964-f8q5- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-269
- Updated
- 2026-11-02
NVD
6.5
In Puppet Bolt versions prior to 3.27.4, a path to escalate privileges was identified.
- Record
CVE-2023-5214- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:C/C:L/I:H/A:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-269
- Updated
- 2026-11-02
OSVAZL-110324
9.8
CVE-2023-5214 affecting package bolt 0.9.8-1
In Puppet Bolt versions prior to 3.27.4, a path to escalate privileges was identified.
- Record
AZL-110324- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-05
OSV
9.8
In Puppet Bolt versions prior to 3.27.4, a path to escalate privileges was identified.
- Record
CVE-2023-5214- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-289m-2964-f8q5
9.8
Puppet Bolt privilege escalation vulnerability
In Puppet Bolt versions prior to 3.27.4, a path to escalate privileges was identified.
- Record
GHSA-289m-2964-f8q5- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-269
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
boltRubyGems |
before 3.27.4 | 3.27.4 |
boltAzure Linux:3 |
through 0.9.8-1 | None known |
boltRubyGems |
before 3.27.4, plus listed versions 0.0.10.10.00.11.00.12.00.13.0 Show 45 moreShow less0.14.00.15.00.16.00.16.10.16.20.16.30.16.40.17.00.17.10.17.20.18.00.18.10.18.20.19.00.19.10.20.00.20.20.20.30.20.50.20.60.20.70.21.00.21.10.21.20.21.30.21.40.21.50.21.60.21.70.21.80.22.00.23.00.24.00.25.00.5.00.5.10.6.00.6.10.7.00.8.00.9.01.0.01.1.01.10.01.11.0 |
3.27.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | OSV | |
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-5214 is a medium vulnerability (CVSS 6.5) in Puppet Bolt, published October 6, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.45%, the 39th percentile. Fixed in bolt 3.27.4.
References
puppet.com/security/cve/cve-2023-5214-privilege-escalation-puppet-bolt
nvd.nist.gov/vuln/detail/CVE-2023-5214
puppet.com/security/cve/cve-2023-5255-denial-service-revocation-auto-renewed-certificates
github.com/rubysec/ruby-advisory-db/blob/master/gems/bolt/CVE-2023-5214.yml
github.com/advisories/GHSA-289m-2964-f8q5
github.com/puppetlabs/bolt
Left out here: 137 versions. The JSON record has them.