CVE-2023-52159
gross - security update
A stack-based buffer overflow vulnerability in gross 0.9.3 through 1.x before 1.0.4 allows remote attackers to trigger a denial of service (grossd daemon crash) or potentially execute arbitrary code in grossd via crafted SMTP transaction parameters that cause an incorrect strncat for a log entry.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
A stack-based buffer overflow vulnerability in gross 0.9.3 through 1.x before 1.0.4 allows remote attackers to trigger a denial of service (grossd daemon crash) or potentially execute arbitrary code in grossd via crafted SMTP transaction parameters that cause an incorrect strncat for a log entry.
- Record
CVE-2023-52159- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List
7.5
A stack-based buffer overflow vulnerability in gross 0.9.3 through 1.x before 1.0.4 allows remote attackers to trigger a denial of service (grossd daemon crash) or potentially execute arbitrary code in grossd via crafted SMTP transaction parameters that cause an incorrect strncat for a log entry.
- Record
CVE-2023-52159- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
EUVDEUVD-2023-56832
7.5
A stack-based buffer overflow vulnerability in gross 0.9.3 through 1.x before 1.0.4 allows remote attackers to trigger a denial of service (grossd daemon crash) or potentially execute arbitrary code in grossd via crafted SMTP transaction parameters that cause an incorrect strncat for a log entry.
- Record
EUVD-2023-56832- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSV
7.5
A stack-based buffer overflow vulnerability in gross 0.9.3 through 1.x before 1.0.4 allows remote attackers to trigger a denial of service (grossd daemon crash) or potentially execute arbitrary code in grossd via crafted SMTP transaction parameters that cause an incorrect strncat for a log entry.
- Record
CVE-2023-52159- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-52159
7.5
A stack-based buffer overflow vulnerability in gross 0.9.3 through 1.x before 1.0.4 allows remote attackers to trigger a denial of service (grossd daemon crash) or potentially execute arbitrary code in grossd via crafted SMTP transaction parameters that cause an incorrect strncat for a log entry.
- Record
DEBIAN-CVE-2023-52159- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-52159
7.5
A stack-based buffer overflow vulnerability in gross 0.9.3 through 1.x before 1.0.4 allows remote attackers to trigger a denial of service (grossd daemon crash) or potentially execute arbitrary code in grossd via crafted SMTP transaction parameters that cause an incorrect strncat for a log entry.
- Record
UBUNTU-CVE-2023-52159- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUSN-6942-1 No score
gross vulnerability
It was discovered that Gross incorrectly handled memory when composing log entries. An attacker could possibly use this issue to cause Gross to crash, resulting in a denial of service, or possibly execute arbitrary code.
- Record
USN-6942-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
grossDebian:12 |
before 1.0.2-4.1~deb12u1, plus listed versions 1.0.2-41.0.2-4.1~deb10u11.0.2-4.1~deb11u1 |
1.0.2-4.1~deb12u1 |
grossDebian:13 |
before 1.0.2-4.1 | 1.0.2-4.1 |
grossDebian:14 |
before 1.0.2-4.1 | 1.0.2-4.1 |
grossDebian:10 |
before 1.0.2-4.1~deb10u1, plus listed versions 1.0.2-4 |
1.0.2-4.1~deb10u1 |
grossUbuntu:Pro:16.04:LTS |
before 1.0.2-4ubuntu0.16.04.1~esm1, plus listed versions 1.0.2-4 |
1.0.2-4ubuntu0.16.04.1~esm1 |
grossUbuntu:Pro:18.04:LTS |
before 1.0.2-4ubuntu0.18.04.1~esm1, plus listed versions 1.0.2-41.0.2-4build1 |
1.0.2-4ubuntu0.18.04.1~esm1 |
grossUbuntu:20.04:LTS |
before 1.0.2-4ubuntu0.20.04.1, plus listed versions 1.0.2-4build1 |
1.0.2-4ubuntu0.20.04.1 |
grossUbuntu:22.04:LTS |
before 1.0.2-4ubuntu0.22.04.1, plus listed versions 1.0.2-4build1 |
1.0.2-4ubuntu0.22.04.1 |
grossUbuntu:24.04:LTS |
before 1.0.2-4ubuntu0.24.04.1, plus listed versions 1.0.2-4build11.0.2-4build2 |
1.0.2-4ubuntu0.24.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-52159 is a high vulnerability (CVSS 7.5) in Bizdelnick Gross, published March 18, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.05%, the 64th percentile. Fixed in gross 1.0.2-4.1~deb12u1.
References
codeberg.org/bizdelnick/gross/wiki/Known-vulnerabilities
lists.debian.org/debian-lts-announce/2024/03/msg00027.html
security-tracker.debian.org/tracker/CVE-2023-52159
ubuntu.com/security/CVE-2023-52159
codeberg.org/bizdelnick/gross/commit/6403985fc1060e7aacea96e60535e1e7b0f6f193
codeberg.org/bizdelnick/gross/commit/3f5508cce2c49d216b163eb7b38ea72d5162c76e
cve.org/CVERecord?id=CVE-2023-52159
ubuntu.com/security/notices/USN-6942-1