Every CVE Search/ Get API key

CVE-2023-52304

Stack overflow in paddle.searchsorted

8.2 HighFix available

Stack overflow in paddle.searchsorted in PaddlePaddle before 2.6.0. This flaw can lead to a denial of service, or even more damage.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
Low

Exploit likelihood

0.58%Up 0.5 points since Jan 10, 2024
90%50%10%1%

What each source reports

CVE List Score used 8.2

Stack overflow in paddle.searchsorted

Stack overflow in paddle.searchsorted in PaddlePaddle before 2.6.0. This flaw can lead to a denial of service, or even more damage.

Record
CVE-2023-52304
CVSS 3.1
8.2 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:L
Weakness
CWE-120
Updated
2026-11-02
EUVDEUVD-2024-0138 8.2

Stack overflow in paddle.searchsorted in PaddlePaddle before 2.6.0. This flaw can lead to a denial of service, or even more damage.

Record
EUVD-2024-0138
CVSS 3.1
8.2 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-4rrv-8gcp-24v8 8.2

PaddlePaddle stack overflow in paddle.searchsorted

Stack overflow in paddle.searchsorted in PaddlePaddle before 2.6.0. This flaw can lead to a denial of service, or even more damage.

Record
GHSA-4rrv-8gcp-24v8
CVSS 3.1
8.2 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:L
Weakness
CWE-120, CWE-787
Updated
2026-11-02
NVD 8.2

Stack overflow in paddle.searchsorted in PaddlePaddle before 2.6.0. This flaw can lead to a denial of service, or even more damage.

Record
CVE-2023-52304
CVSS 3.1
8.2 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:L
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-120, CWE-787
Updated
2026-11-02
OSV 9.8

Stack overflow in paddle.searchsorted in PaddlePaddle before 2.6.0. This flaw can lead to a denial of service, or even more damage.

Record
CVE-2023-52304
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-4rrv-8gcp-24v8 8.2

PaddlePaddle stack overflow in paddle.searchsorted

Stack overflow in paddle.searchsorted in PaddlePaddle before 2.6.0. This flaw can lead to a denial of service, or even more damage.

Record
GHSA-4rrv-8gcp-24v8
CVSS 3.1
8.2 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:L
Weakness
CWE-120, CWE-787
Updated
2026-11-02
OSVPYSEC-2024-136 9.8

Stack overflow in paddle.searchsorted in PaddlePaddle before 2.6.0. This flaw can lead to a denial of service, or even more damage.

Record
PYSEC-2024-136
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
paddlepaddle
PyPI
before 2.6.0
2.6.0
paddlepaddle
PyPI
before 2.6.0, plus listed versions
1.8.5
2.6.0
paddlepaddle
PyPI
before 2.6.0, plus listed versions
1.8.52.3.02.3.12.3.22.4.0
Show 8 moreShow less
2.4.0rc02.4.12.4.22.5.02.5.0rc02.5.0rc12.5.12.5.2
2.6.0

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-52304 is a high vulnerability (CVSS 8.2) in Paddlepaddle, published January 3, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.58%, the 47th percentile. Fixed in paddlepaddle 2.6.0.

References

MoveEnter Open