CVE-2023-53154
parse_string in cJSON before 1.7.18 has a heap-based buffer over-read via {"1":1, with no...
parse_string in cJSON before 1.7.18 has a heap-based buffer over-read via {"1":1, with no trailing newline if cJSON_ParseWithLength is called.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
2.9
parse_string in cJSON before 1.7.18 has a heap-based buffer over-read via {"1":1, with no trailing newline if cJSON_ParseWithLength is called.
- Record
CVE-2023-53154- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-125
- Updated
- 2026-11-02
EUVDEUVD-2023-59777
2.9
parse_string in cJSON before 1.7.18 has a heap-based buffer over-read via {"1":1, with no trailing newline if cJSON_ParseWithLength is called.
- Record
EUVD-2023-59777- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-8h4w-44qv-79mq
2.9
parse_string in cJSON before 1.7.18 has a heap-based buffer over-read via {"1":1, with no...
parse_string in cJSON before 1.7.18 has a heap-based buffer over-read via {"1":1, with no trailing newline if cJSON_ParseWithLength is called.
- Record
GHSA-8h4w-44qv-79mq- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-125
- Updated
- 2026-11-02
NVD
2.9
parse_string in cJSON before 1.7.18 has a heap-based buffer over-read via {"1":1, with no trailing newline if cJSON_ParseWithLength is called.
- Record
CVE-2023-53154- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L - CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSV
2.9
parse_string in cJSON before 1.7.18 has a heap-based buffer over-read via {"1":1, with no trailing newline if cJSON_ParseWithLength is called.
- Record
CVE-2023-53154- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-125
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-53154
5.5
parse_string in cJSON before 1.7.18 has a heap-based buffer over-read via {"1":1, with no trailing newline if cJSON_ParseWithLength is called.
- Record
DEBIAN-CVE-2023-53154- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Show 5 moreShow less
OSVUBUNTU-CVE-2023-53154
2.9
parse_string in cJSON before 1.7.18 has a heap-based buffer over-read via {"1":1, with no trailing newline if cJSON_ParseWithLength is called.
- Record
UBUNTU-CVE-2023-53154- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L - CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVAZL-62005 No score
CVE-2023-53154 affecting package apparmor for versions less than 3.0.4-5
parse_string in cJSON before 1.7.18 has a heap-based buffer over-read via {"1":1, with no trailing newline if cJSON_ParseWithLength is called.
- Record
AZL-62005- Updated
- 2026-11-02
OSVAZL-67455 No score
CVE-2023-53154 affecting package apparmor for versions less than 3.1.7-1
parse_string in cJSON before 1.7.18 has a heap-based buffer over-read via {"1":1, with no trailing newline if cJSON_ParseWithLength is called.
- Record
AZL-67455- Updated
- 2026-11-05
OSVROOT-OS-DEBIAN-12-CVE-2023-53154 No score
CVE-2023-53154 in cjson - Patched by Root
Root has patched CVE-2023-53154 in the cjson package for Root:Debian:12. Multiple fixed versions available.
- Record
ROOT-OS-DEBIAN-12-CVE-2023-53154- Updated
- 2026-11-02
OSVUSN-7973-1 No score
cjson vulnerabilities
It was discovered that cJSON incorrectly handled parsing large numbers. An attacker could possibly use this issue to cause a denial of service. (CVE-2023-26819)
It was discovered that cJSON may perform out-of-bounds read when processing specially crafted JSON files using parse_object. An attacker could possibly use this issue to expose sensitive information or crash the program. (CVE-2023-53154)
It was discovered that cJSON incorrectly validated array indices in JSON pointers, which could result in an out-of-bounds memory access. An attacker could possibly use this issue to cause a denial of service, or execute arbitrary code. (CVE-2025-57052)
- Record
USN-7973-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
apparmorAzure Linux:2 |
before 3.0.4-5 | 3.0.4-5 |
apparmorAzure Linux:3 |
before 3.1.7-1 | 3.1.7-1 |
cjsonDebian:12 |
before 1.7.15-1+deb12u3, plus listed versions 1.7.15-11.7.15-1+deb12u11.7.15-1+deb12u2 |
1.7.15-1+deb12u3 |
cjsonDebian:13 |
before 1.7.18-1 | 1.7.18-1 |
cjsonDebian:14 |
before 1.7.18-1 | 1.7.18-1 |
cjsonDebian:11 From an advisory covering 2 CVEs |
before 1.7.14-1+deb11u2, plus listed versions 1.7.14-11.7.14-1+deb11u1 |
1.7.14-1+deb11u2 |
cjsonRoot:Debian:12 |
before 1.7.15-1+deb12u4.aikido.3 | 1.7.15-1+deb12u4.aikido.31.7.15-1+deb12u2.root.io.11.7.15-1+deb12u4.aikido.2 |
rootio-cjsonRoot:Debian:12 |
before 1.7.15-1+deb12u4.aikido.3 | 1.7.15-1+deb12u4.aikido.31.7.15-1+deb12u2.root.io.11.7.15-1+deb12u4.aikido.2 |
cjsonUbuntu:Pro:20.04:LTS |
before 1.7.10-1.1ubuntu0.1~esm1, plus listed versions 1.7.10-1.1 |
1.7.10-1.1ubuntu0.1~esm1 |
cjsonUbuntu:22.04:LTS |
before 1.7.15-1ubuntu0.1, plus listed versions 1.7.14-11.7.15-1 |
1.7.15-1ubuntu0.1 |
Show 5 moreShow less
| Package | Affected | Fixed |
|---|---|---|
cjsonUbuntu:Pro:24.04:LTS |
before 1.7.17-1ubuntu0.1~esm3, plus listed versions 1.7.16-11.7.16-21.7.17-11.7.17-1ubuntu0.1~esm2 |
1.7.17-1ubuntu0.1~esm3 |
cjsonUbuntu:Pro:20.04:LTS From an advisory covering 3 CVEs |
before 1.7.10-1.1ubuntu0.1~esm1, plus listed versions 1.7.10-1.1 |
1.7.10-1.1ubuntu0.1~esm1 |
cjsonUbuntu:22.04:LTS From an advisory covering 3 CVEs |
before 1.7.15-1ubuntu0.1, plus listed versions 1.7.14-11.7.15-1 |
1.7.15-1ubuntu0.1 |
cjsonUbuntu:Pro:24.04:LTS From an advisory covering 3 CVEs |
before 1.7.17-1ubuntu0.1~esm3, plus listed versions 1.7.16-11.7.16-21.7.17-11.7.17-1ubuntu0.1~esm2 |
1.7.17-1ubuntu0.1~esm3 |
cjsonUbuntu:25.10 From an advisory covering 3 CVEs |
before 1.7.18-3.1ubuntu0.1, plus listed versions 1.7.18-31.7.18-3.1 |
1.7.18-3.1ubuntu0.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| facts | OSV | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-53154 is a low vulnerability (CVSS 2.9) in Cjson Project Cjson, published May 23, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.28%, the 20th percentile. Fixed in apparmor 3.0.4-5.
References
github.com/DaveGamble/cJSON/compare/v1.7.17...v1.7.18
github.com/DaveGamble/cJSON/issues/800
lists.debian.org/debian-lts-announce/2025/06/msg00014.html
nvd.nist.gov/vuln/detail/CVE-2023-53154
github.com/advisories/GHSA-8h4w-44qv-79mq
github.com/CVEProject/cvelistV5/tree/main/cves/2023/53xxx/CVE-2023-53154.json
Show 9 moreShow less
security-tracker.debian.org/tracker/CVE-2023-53154
ubuntu.com/security/CVE-2023-53154
cve.org/CVERecord?id=CVE-2023-53154
github.com/DaveGamble/cJSON/pull/852
github.com/DaveGamble/cJSON/commit/3ef4e4e730e5efd381be612df41e1ff3f5bb3c32
github.com/DaveGamble/cJSON/commit/826cd6f842ae7e46ee38bbc097f9a34f2947388d
ubuntu.com/security/notices/USN-7973-1
ubuntu.com/security/CVE-2023-26819
ubuntu.com/security/CVE-2025-57052