Every CVE Search/ Get API key

CVE-2023-53160

sequoia-openpgp vulnerable to out-of-bounds array access leading to panic

2.9 LowFix available

The sequoia-openpgp crate before 1.16.0 for Rust allows out-of-bounds array access and a panic.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
Low

Exploit likelihood

0.33%Up 0.3 points since Jul 28, 2025
90%50%10%1%

What each source reports

CVE List Score used 2.9

The sequoia-openpgp crate before 1.16.0 for Rust allows out-of-bounds array access and a panic.

Record
CVE-2023-53160
CVSS 3.1
2.9 LowCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-125
Updated
2026-11-02
EUVDEUVD-2023-59770 2.9

The sequoia-openpgp crate before 1.16.0 for Rust allows out-of-bounds array access and a panic.

Record
EUVD-2023-59770
CVSS 3.1
2.9 LowCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-25mx-8f3v-8wh7 2.9

sequoia-openpgp vulnerable to out-of-bounds array access leading to panic

Affected versions of the crate have several bugs where attacker-controlled input can result in the use of an out-of-bound array index. Rust detects the use of the out-of-bound index and causes the application to panic. An attacker may be able to use this to cause a denial-of-service. However, it is not possible for an attacker to read from or write to the application's address space.

Record
GHSA-25mx-8f3v-8wh7
CVSS 3.1
2.9 LowCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-125
Updated
2026-11-02
NVD 2.9

The sequoia-openpgp crate before 1.16.0 for Rust allows out-of-bounds array access and a panic.

Record
CVE-2023-53160
CVSS 3.1
2.9 LowCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-125
Updated
2026-11-02
OSV 2.9

The sequoia-openpgp crate before 1.16.0 for Rust allows out-of-bounds array access and a panic.

Record
CVE-2023-53160
CVSS 3.1
2.9 LowCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-125
Updated
2026-11-02
OSVDEBIAN-CVE-2023-53160 5.3

The sequoia-openpgp crate before 1.16.0 for Rust allows out-of-bounds array access and a panic.

Record
DEBIAN-CVE-2023-53160
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVGHSA-25mx-8f3v-8wh7 2.9

sequoia-openpgp vulnerable to out-of-bounds array access leading to panic

Affected versions of the crate have several bugs where attacker-controlled input can result in the use of an out-of-bound array index. Rust detects the use of the out-of-bound index and causes the application to panic. An attacker may be able to use this to cause a denial-of-service. However, it is not possible for an attacker to read from or write to the application's address space.

Record
GHSA-25mx-8f3v-8wh7
CVSS 3.1
2.9 LowCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-125
Updated
2026-11-02
OSVUBUNTU-CVE-2023-53160 2.9

The sequoia-openpgp crate before 1.16.0 for Rust allows out-of-bounds array access and a panic.

Record
UBUNTU-CVE-2023-53160
CVSS 3.1
2.9 LowCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVRUSTSEC-2023-0038 No score

Out-of-bounds array access leads to panic

Affected versions of the crate have several bugs where attacker-controlled input can result in the use of an out-of-bound array index. Rust detects the use of the out-of-bound index and causes the application to panic. An attacker may be able to use this to cause a denial-of-service. However, it is not possible for an attacker to read from or write to the application's address space.

Record
RUSTSEC-2023-0038
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
sequoia-openpgp
crates.io
before 1.1.1
1.1.1
sequoia-openpgp
crates.io
1.2.0 up to 1.8.1
1.8.1
sequoia-openpgp
crates.io
1.9.0 up to 1.16.0
1.16.0
rust-sequoia-openpgp
Debian:12
All versions, plus listed versions
1.12.0-21.13.0-11.16.0-11.16.0-21.16.0-3
Show 28 moreShow less
1.16.1-11.16.1-21.17.0-11.17.0-21.18.0-11.19.0-11.20.0-11.20.0-21.21.0-11.21.1-11.21.1-21.21.2-11.21.2-21.22.0-11.22.0-22.0.0-12.0.0-22.0.0-32.0.0-42.0.0-52.1.0-12.1.0-22.1.0-32.2.0-12.2.0-22.3.0-12.4.1-12.4.1-2
None known
rust-sequoia-openpgp
Debian:13
before 1.16.0-1
1.16.0-1
rust-sequoia-openpgp
Debian:14
before 1.16.0-1
1.16.0-1
sequoia-openpgp
crates.io
0.0.0-0 up to 1.1.1, 1.2.0 up to 1.8.1, 1.9.0 up to 1.16.0
1.1.11.8.11.16.0
rust-sequoia-openpgp
Ubuntu:22.04:LTS
All versions, plus listed versions
1.1.0-31.3.0-41.7.0-6
None known
rust-sequoia-openpgp
Ubuntu:24.04:LTS
All versions, plus listed versions
1.16.0-11.17.0-11.17.0-21.18.0-11.19.0-11.19.0-1build1
None known
rust-sequoia-openpgp-mt
Ubuntu:24.04:LTS
All versions, plus listed versions
0.1.0-2
None known
Show 6 moreShow less
Affected packages
PackageAffectedFixed
rust-sequoia-openpgp
Ubuntu:25.10
All versions, plus listed versions
1.22.0-12.0.0-2
None known
rust-sequoia-openpgp-mt
Ubuntu:25.10
All versions, plus listed versions
0.1.0-30.2.0-1
None known
rust-sequoia-openpgp
Ubuntu:26.10
All versions, plus listed versions
2.2.0-12.3.0-1
None known
rust-sequoia-openpgp-mt
Ubuntu:26.10
All versions, plus listed versions
0.2.0-1
None known
rust-sequoia-openpgp
Ubuntu:26.04:LTS
All versions, plus listed versions
2.0.0-22.0.0-52.1.0-12.1.0-22.1.0-32.2.0-1
None known
rust-sequoia-openpgp-mt
Ubuntu:26.04:LTS
All versions, plus listed versions
0.2.0-1
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-53160 is a low vulnerability (CVSS 2.9) in Sequoia-pgp Sequoia, published May 16, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.33%, the 25th percentile. Fixed in sequoia-openpgp 1.1.1.

References

Show 7 moreShow less
MoveEnter Open