CVE-2023-53161
buffered-reader vulnerable to out-of-bounds array access leading to panic
The buffered-reader crate before 1.1.5 for Rust allows out-of-bounds array access and a panic.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
2.9
The buffered-reader crate before 1.1.5 for Rust allows out-of-bounds array access and a panic.
- Record
CVE-2023-53161- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-125
- Updated
- 2026-11-02
EUVDEUVD-2023-59772
2.9
The buffered-reader crate before 1.1.5 for Rust allows out-of-bounds array access and a panic.
- Record
EUVD-2023-59772- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-29mf-62xx-28jq
2.9
buffered-reader vulnerable to out-of-bounds array access leading to panic
Affected versions of the crate have a bug where attacker-controlled input can result in the use of an out-of-bound array index. Rust detects the use of the out-of-bound index and causes the application to panic. An attacker may be able to use this to cause a denial-of-service. However, it is not possible for an attacker to read from or write to the application's address space.
- Record
GHSA-29mf-62xx-28jq- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
NVD
2.9
The buffered-reader crate before 1.1.5 for Rust allows out-of-bounds array access and a panic.
- Record
CVE-2023-53161- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L - CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-125
- Updated
- 2026-11-02
OSV
2.9
The buffered-reader crate before 1.1.5 for Rust allows out-of-bounds array access and a panic.
- Record
CVE-2023-53161- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-125
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-53161
5.3
The buffered-reader crate before 1.1.5 for Rust allows out-of-bounds array access and a panic.
- Record
DEBIAN-CVE-2023-53161- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
OSVGHSA-29mf-62xx-28jq
2.9
buffered-reader vulnerable to out-of-bounds array access leading to panic
Affected versions of the crate have a bug where attacker-controlled input can result in the use of an out-of-bound array index. Rust detects the use of the out-of-bound index and causes the application to panic. An attacker may be able to use this to cause a denial-of-service. However, it is not possible for an attacker to read from or write to the application's address space.
- Record
GHSA-29mf-62xx-28jq- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-53161
2.9
The buffered-reader crate before 1.1.5 for Rust allows out-of-bounds array access and a panic.
- Record
UBUNTU-CVE-2023-53161- CVSS 3.1
- 2.9 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L - CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-02
OSVRUSTSEC-2023-0039 No score
Out-of-bounds array access leads to panic
Affected versions of the crate have a bug where attacker-controlled input can result in the use of an out-of-bound array index. Rust detects the use of the out-of-bound index and causes the application to panic. An attacker may be able to use this to cause a denial-of-service. However, it is not possible for an attacker to read from or write to the application's address space.
- Record
RUSTSEC-2023-0039- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
buffered-readercrates.io |
before 1.0.2 | 1.0.2 |
buffered-readercrates.io |
1.1.0 up to 1.1.5 | 1.1.5 |
rust-buffered-readerDebian:12 |
All versions, plus listed versions 1.1.4-11.2.0-11.3.0-11.3.1-11.3.1-21.4.0-11.4.0-21.4.1-1 |
None known |
rust-buffered-readerDebian:13 |
before 1.2.0-1 | 1.2.0-1 |
rust-buffered-readerDebian:14 |
before 1.2.0-1 | 1.2.0-1 |
buffered-readercrates.io |
0.0.0-0 up to 1.0.2, 1.1.0 up to 1.1.5, 1.2.0 up to 1.2.0 | 1.0.21.1.51.2.0 |
rust-buffered-readerUbuntu:20.04:LTS |
All versions, plus listed versions 0.7.0-20.11.0-10.12.0-10.13.0-10.14.0-1 |
None known |
rust-buffered-readerUbuntu:22.04:LTS |
All versions, plus listed versions 1.0.1-11.1.1-11.1.2-1 |
None known |
rust-buffered-readerUbuntu:24.04:LTS |
All versions, plus listed versions 1.2.0-11.3.0-1 |
None known |
rust-buffered-readerUbuntu:25.10 |
All versions, plus listed versions 1.3.1-2 |
None known |
rust-buffered-readerUbuntu:26.10 |
All versions, plus listed versions 1.4.0-21.4.1-1 |
None known |
rust-buffered-readerUbuntu:26.04:LTS |
All versions, plus listed versions 1.3.1-21.4.0-11.4.0-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-53161 is a low vulnerability (CVSS 2.9) in Sequoia-pgp Buffered-reader, published May 16, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.39%, the 33rd percentile. Fixed in buffered-reader 1.0.2.
References
lists.sequoia-pgp.org/hyperkitty/list/[email protected]/thread/SN2E3QRT4DMQ5JNEK6VIN6DJ5SH766DI
rustsec.org/advisories/RUSTSEC-2023-0039.html
github.com/advisories/GHSA-29mf-62xx-28jq
crates.io/crates/buffered-reader
gitlab.com/sequoia-pgp/sequoia/-/tags/buffered-reader%2Fv1.0.2
gitlab.com/sequoia-pgp/sequoia/-/tags/buffered-reader%2Fv1.1.5
Show 9 moreShow less
github.com/advisories/GHSA-25mx-8f3v-8wh7
gitlab.com/sequoia-pgp/sequoia/-/blob/main/buffered-reader/NEWS
nvd.nist.gov/vuln/detail/CVE-2023-53161
github.com/CVEProject/cvelistV5/tree/main/cves/2023/53xxx/CVE-2023-53161.json
security-tracker.debian.org/tracker/CVE-2023-53161
gitlab.com/sequoia-pgp/sequoia
gitlab.com/sequoia-pgp/sequoia/-/tags/buffered-reader%2Fv1.2.0
ubuntu.com/security/CVE-2023-53161
cve.org/CVERecord?id=CVE-2023-53161