CVE-2023-5332
Dependency on Vulnerable Third-Party Component in GitLab
Patch in third party library Consul requires 'enable-script-checks' to be set to False. This was required to enable a patch by the vendor. Without this setting the patch could be bypassed. This only affects GitLab-EE.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- High
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
5.9
Dependency on Vulnerable Third-Party Component in GitLab
Patch in third party library Consul requires 'enable-script-checks' to be set to False. This was required to enable a patch by the vendor. Without this setting the patch could be bypassed. This only affects GitLab-EE.
- Record
CVE-2023-5332- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-1395
- Updated
- 2026-11-02
EUVDEUVD-2023-57649
5.9
Patch in third party library Consul requires 'enable-script-checks' to be set to False. This was required to enable a patch by the vendor. Without this setting the patch could be bypassed. This only affects GitLab-EE.
- Record
EUVD-2023-57649- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-xcgm-v273-44cr
5.9
Patch in third party library Consul requires 'enable-script-checks' to be set to False. This was...
Patch in third party library Consul requires 'enable-script-checks' to be set to False. This was required to enable a patch by the vendor. Without this setting the patch could be bypassed. This only affects GitLab-EE.
- Record
GHSA-xcgm-v273-44cr- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
NVD
5.9
Patch in third party library Consul requires 'enable-script-checks' to be set to False. This was required to enable a patch by the vendor. Without this setting the patch could be bypassed. This only affects GitLab-EE.
- Record
CVE-2023-5332- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N - CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV
5.9
Dependency on Vulnerable Third-Party Component in GitLab
Patch in third party library Consul requires 'enable-script-checks' to be set to False. This was required to enable a patch by the vendor. Without this setting the patch could be bypassed. This only affects GitLab-EE.
- Record
CVE-2023-5332- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N - Weakness
- CWE-1395
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2023-5332
8.1
Patch in third party library Consul requires 'enable-script-checks' to be set to False. This was required to enable a patch by the vendor. Without this setting the patch could be bypassed. This only affects GitLab-EE.
- Record
DEBIAN-CVE-2023-5332- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2023-5332
5.9
Patch in third party library Consul requires 'enable-script-checks' to be set to False. This was required to enable a patch by the vendor. Without this setting the patch could be bypassed. This only affects GitLab-EE.
- Record
UBUNTU-CVE-2023-5332- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N - CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVBIT-consul-2023-5332 No score
Dependency on Vulnerable Third-Party Component in GitLab
Patch in third party library Consul requires 'enable-script-checks' to be set to False. This was required to enable a patch by the vendor. Without this setting the patch could be bypassed. This only affects GitLab-EE.
- Record
BIT-consul-2023-5332- Updated
- 2026-11-02
OSVBIT-gitlab-2023-5332 No score
Dependency on Vulnerable Third-Party Component in GitLab
Patch in third party library Consul requires 'enable-script-checks' to be set to False. This was required to enable a patch by the vendor. Without this setting the patch could be bypassed. This only affects GitLab-EE.
- Record
BIT-gitlab-2023-5332- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
consulBitnami |
before 0.9.4, 1.0.0 up to 1.0.8, 1.1.0 up to 1.1.1, 1.2.0 up to 1.2.4 | 0.9.41.0.81.1.11.2.4 |
gitlabBitnami |
9.5.0 up to 16.2.8, 16.3.0 up to 16.3.5, 16.4.0 up to 16.4.1 | 16.2.816.3.516.4.1 |
consulDebian:11 |
All versions, plus listed versions 1.10.12+dfsg1-11.8.7+dfsg1-21.8.7+dfsg1-31.8.7+dfsg1-41.8.7+dfsg1-51.8.7+dfsg1-61.9.17+dfsg2-1 |
None known |
consulUbuntu:18.04:LTS |
All versions, plus listed versions 0.6.4~dfsg-3 |
None known |
consulUbuntu:20.04:LTS |
All versions, plus listed versions 1.0.7~dfsg1-5ubuntu11.4.4~dfsg1-2ubuntu21.5.2+dfsg1-61.5.2+dfsg1-101.5.2+dfsg1-121.5.2+dfsg2-14 |
None known |
consulUbuntu:22.04:LTS |
All versions, plus listed versions 1.7.4+dfsg1-11.8.7+dfsg1-3 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2023-5332 is a medium vulnerability (CVSS 5.9) in Gitlab, published December 4, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.87%, the 59th percentile. Fixed in consul 0.9.4.
References
gitlab.com/gitlab-org/omnibus-gitlab/-/issues/8171
hashicorp.com/blog/protecting-consul-from-rce-risk-in-specific-configurations
nvd.nist.gov/vuln/detail/CVE-2023-5332
github.com/advisories/GHSA-xcgm-v273-44cr
github.com/CVEProject/cvelistV5/tree/main/cves/2023/5xxx/CVE-2023-5332.json
security-tracker.debian.org/tracker/CVE-2023-5332
ubuntu.com/security/CVE-2023-5332
cve.org/CVERecord?id=CVE-2023-5332