Every CVE Search/ Get API key

CVE-2023-5520

Out-of-bounds Read in gpac/gpac

4.0 MediumFix available

Out-of-bounds Read in GitHub repository gpac/gpac prior to 2.2.2.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
Low

Exploit likelihood

0.34%Up 0.3 points since Oct 12, 2023
90%50%10%1%

What each source reports

CVE List Score used 4.0

Out-of-bounds Read in gpac/gpac

Out-of-bounds Read in GitHub repository gpac/gpac prior to 2.2.2.

Record
CVE-2023-5520
CVSS 3.0
4.0 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-125
Updated
2026-11-02
EUVDEUVD-2023-57833 4.0

Out-of-bounds Read in GitHub repository gpac/gpac prior to 2.2.2.

Record
EUVD-2023-57833
CVSS 3.0
4.0 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-8x9m-4hhm-x696 4.0

Out-of-bounds Read in GitHub repository gpac/gpac prior to 2.2.2.

Out-of-bounds Read in GitHub repository gpac/gpac prior to 2.2.2.

Record
GHSA-8x9m-4hhm-x696
CVSS 3.0
4.0 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-125
Updated
2026-11-02
NVD 7.7

Out-of-bounds Read in GitHub repository gpac/gpac prior to 2.2.2.

Record
CVE-2023-5520
CVSS 3.1
7.7 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
CVSS 3.0
4.0 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-125
Updated
2026-11-02
OSV 4.0

Out-of-bounds Read in gpac/gpac

Out-of-bounds Read in GitHub repository gpac/gpac prior to 2.2.2.

Record
CVE-2023-5520
CVSS 3.0
4.0 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-125
Updated
2026-11-02
OSVDEBIAN-CVE-2023-5520 7.7

Out-of-bounds Read in GitHub repository gpac/gpac prior to 2.2.2.

Record
DEBIAN-CVE-2023-5520
CVSS 3.1
7.7 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2023-5520 7.7

Out-of-bounds Read in GitHub repository gpac/gpac prior to 2.2.2.

Record
UBUNTU-CVE-2023-5520
CVSS 3.1
7.7 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
CVSS 3.0
4.0 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVMGASA-2025-0090 No score

Updated gpac packages fix security vulnerabilities

Out-of-bounds Read in GitHub repository gpac/gpac prior to 2.2.2. (CVE-2023-5520) Stack-based Buffer Overflow in GitHub repository gpac/gpac prior to 2.3-DEV. (CVE-2024-0321) Out-of-bounds Read in GitHub repository gpac/gpac prior to 2.3-DEV. (CVE-2024-0322)

Record
MGASA-2025-0090
Updated
2026-11-02
OSVUSN-7320-1 No score

gpac vulnerabilities

It was discovered that the GPAC MP4Box utility incorrectly handled certain AC3 files, which could lead to an out-of-bounds read. A remote attacker could use this issue to cause MP4Box to crash, resulting in a denial of service (system crash). This issue only affected Ubuntu 22.04 LTS and Ubuntu 24.04 LTS. (CVE-2023-5520, CVE-2024-0322)

It was discovered that the GPAC MP4Box utility incorrectly handled certain malformed text files. If a user or automated system using MP4Box were tricked into opening a specially crafted RST file, an attacker could use this issue to cause a denial of service (system crash) or execute arbitrary code. (CVE-2024-0321)

Record
USN-7320-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gpac
Debian:11
All versions, plus listed versions
1.0.1+dfsg1-41.0.1+dfsg1-4+deb11u11.0.1+dfsg1-4+deb11u21.0.1+dfsg1-4+deb11u31.0.1+dfsg1-5
Show 8 moreShow less
2.0.0+dfsg1-12.0.0+dfsg1-22.0.0+dfsg1-42.2.1+dfsg1-12.2.1+dfsg1-22.2.1+dfsg1-32.2.1+dfsg1-3.12.2.1+dfsg1-3.1~exp1
None known
gpac
Mageia:9
From an advisory covering 3 CVEs
before 2.2.1-1.2.mga9.tainted
2.2.1-1.2.mga9.tainted
gpac
Ubuntu:Pro:22.04:LTS
before 2.0.0+dfsg1-2ubuntu0.1~esm2, plus listed versions
1.0.1+dfsg1-41.0.1+dfsg1-52.0.0+dfsg1-2
2.0.0+dfsg1-2ubuntu0.1~esm2
gpac
Ubuntu:Pro:24.04:LTS
before 2.2.1+dfsg1-3.1ubuntu0.1~esm2, plus listed versions
2.2.1+dfsg1-32.2.1+dfsg1-3.12.2.1+dfsg1-3.1build12.2.1+dfsg1-3.1build2
2.2.1+dfsg1-3.1ubuntu0.1~esm2
gpac
Ubuntu:Pro:14.04:LTS
From an advisory covering 3 CVEs
before 0.5.0+svn4288~dfsg1-4ubuntu1+esm2, plus listed versions
0.5.0+svn4288~dfsg1-1ubuntu10.5.0+svn4288~dfsg1-40.5.0+svn4288~dfsg1-4ubuntu10.5.0+svn4288~dfsg1-4ubuntu1+esm1
0.5.0+svn4288~dfsg1-4ubuntu1+esm2
gpac
Ubuntu:Pro:16.04:LTS
From an advisory covering 3 CVEs
before 0.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1+esm2, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-1build10.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1
0.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1+esm2
gpac
Ubuntu:Pro:18.04:LTS
From an advisory covering 3 CVEs
before 0.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1+esm1, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-30.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1
0.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1+esm1
gpac
Ubuntu:Pro:20.04:LTS
From an advisory covering 3 CVEs
before 0.5.2-426-gc5ad4e4+dfsg5-5ubuntu0.1~esm2, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-4ubuntu10.5.2-426-gc5ad4e4+dfsg5-5
0.5.2-426-gc5ad4e4+dfsg5-5ubuntu0.1~esm2
gpac
Ubuntu:Pro:22.04:LTS
From an advisory covering 3 CVEs
before 2.0.0+dfsg1-2ubuntu0.1~esm2, plus listed versions
1.0.1+dfsg1-41.0.1+dfsg1-52.0.0+dfsg1-2
2.0.0+dfsg1-2ubuntu0.1~esm2
gpac
Ubuntu:Pro:24.04:LTS
From an advisory covering 3 CVEs
before 2.2.1+dfsg1-3.1ubuntu0.1~esm2, plus listed versions
2.2.1+dfsg1-32.2.1+dfsg1-3.12.2.1+dfsg1-3.1build12.2.1+dfsg1-3.1build2
2.2.1+dfsg1-3.1ubuntu0.1~esm2

History

History
RecordedChangedSources
affected, facts
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2023-5520 is a medium vulnerability (CVSS 4.0) in Gpac, published October 11, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.34%, the 27th percentile. Fixed in gpac 2.0.0+dfsg1-2ubuntu0.1~esm2.

References

Show 7 moreShow less
MoveEnter Open